Previous 1 2 Next 15 Replies Latest reply: Mar 16, 2014 5:28 AM by basilmir
mabadjiev Level 1 Level 1 (0 points)

Hello,

 

On the new OS X Server 3.0 when selecting 'Relay Outgoing Mail through ISP' and entering example.com:587 the Server App complains and rejects the entry as invalid.

Works fine on OS X Server 2.2.2

Any suggestions/help will be greatly appreciated.

 

Thanks,

 

Michael A.


Aperture 3
  • Charles Leslie Level 1 Level 1 (135 points)

    Hi,

     

    I'm also facing the same issue.  Prior to Mavericks server, I could specify a different relay port by appending the port to the relayhost like, relayhost.domain.com:587.  Now I get a 'Formating Error - Please provide a valid value' error. 

     

    Has the format changed in Mavericks?

     

    -Charles

  • mabadjiev Level 1 Level 1 (0 points)

    In my case everything else worked just fine except the mai relay portion. I've tried forums, internet - no luck so far.

    Anyone with solution for this issue?

  • louser Level 1 Level 1 (0 points)

    Not that it helps necessarily, but answers Charles' question.

     

    According to:

     

    https://help.apple.com/advancedserveradmin/mac/3.0/

     

    The relevant parts under Provide Mail and Messages services -> Mail -> Manage Mail service -> Provide Mail service -> Specify a mail relay server - the format has not changed. You are still supposed to be able to place the port following a colon after the address such as: example.com:587.

     

    Sending mail is now at a halt on my server as my ISP does not allow sending mail via relay without a specified port or without relay for that matter.

     

    - Steven

  • mabadjiev Level 1 Level 1 (0 points)

    Yes, everywhere it says that example.com:587 is supported, but the reality is different.

    It's definately a BUG.

  • Rambling Man Level 1 Level 1 (35 points)

    I had the same problem, the fix I used was adding the port using the serveradmin command.

     

    sudo serveradmin set mail:postfix:smtp_auth_relay_dict:smtp_auth_relay_host = "example.com:587"

     

    This shouls add the port number for you.

     

    to see if the port is added to the relay use the command below to see all the mail settings.

     

    sudo serveradmin settings mail

     

    Hope this helps but let me know if it doesn't

    Ed

  • Charles Leslie Level 1 Level 1 (135 points)

    Issues resolved..

     

    serveradmin works as well as manually updating the main.cf configuration file in /Library/Server/Mail/Config . However, serveradmin is cleaner.  Thanks.

     

    Charles

  • mabadjiev Level 1 Level 1 (0 points)

    All,

     

         sudo serveradmin set mail:postfix:smtp_auth_relay_dict:smtp_auth_relay_host = "example.com:587"

    didn't work for me, even though the ountput of

         sudo serveradmin settings mail:postfix:smtp_auth_relay_dict:smtp_auth_relay_host

         (and restart the mail system)

    shows the right thing mail:postfix:smtp_auth_relay_dict:smtp_auth_relay_host = "example.com:587"

    but /Library/Server/Mail/Config/postfix/main.cf does not.

     

    I had to do it the old school way (like Charles suggested)

     

    sudo vi /Library/Server/Mail/Config/postfix/main.cf

     

    and add relayhost = host.example.com:587 (actually add the port only)

    and issue 'sudo postfix reload' and it works.

     

    The fun part is when I clieck on the 'Edit' button for 'Relay outgoing mail through ISP' it show blank.

    I did not wanted to save it, so at this point I don't know what the result will be.

     

    I think this is a major bug.

    Thank you all for helping me figure it out.

    At this point I will wait untill Apple fixes the issue before I migrate.

     

    Michael Abadjiev

  • mabadjiev Level 1 Level 1 (0 points)

    Another really anoying feature is that after the upgrde to Server 3.0 all the setting of my Airport Extreme are wiped... without even asking me...

  • tarfan Level 1 Level 1 (0 points)

    I have the same problem when i do vi and port then restart mail service i get these problems

     

     

    Oct 30 09:44:30 tarfan.net postfix/master[3206]: fatal: bad string length 0 < 1: setgid_group =

    Oct 30 09:44:41 tarfan.net postfix/master[3229]: fatal: bad string length 0 < 1: setgid_group =

    Oct 30 09:44:51 tarfan.net postfix/master[3252]: fatal: bad string length 0 < 1: setgid_group =

    Oct 30 16:06:55 tarfan.net postfix/postmap[2544]: fatal: bad string length 0 < 1: mydomain_fallback =

    Oct 30 16:06:56 tarfan.net postfix/postmap[2546]: fatal: bad string length 0 < 1: mydomain_fallback =

    Oct 30 16:07:09 tarfan.net postfix/postmap[2559]: fatal: bad string length 0 < 1: mydomain_fallback =

    Oct 30 16:07:10 tarfan.net postfix/postmap[2563]: fatal: bad string length 0 < 1: mydomain_fallback =

    Oct 30 16:08:53 tarfan.net postfix/postmap[2666]: fatal: bad string length 0 < 1: mydomain_fallback =

    Oct 30 16:08:54 tarfan.net postfix/postmap[2672]: fatal: bad string length 0 < 1: mydomain_fallback =

     

     

    Help please not using setgid and have localhost as backup domain can some give me example of what my main .cf file should look like

     

    Thans

  • Fred de Gembloux Level 1 Level 1 (10 points)

    Same issue for me. Setting the port through the serveradmin didn't work.

     

    The old school way and vi finally fixed the issue.

     

    manually edit the main.cf file

    sudo vi /Library/Server/Mail/Config/postfix/main.cf

     

    then reload the postfix configuration

    sudo postfix reload

     

    Problem should be solved.

  • basilmir Level 1 Level 1 (75 points)

    OS X Server 3.0.2 is out and they have not "fixed" the issue. I think this is in acordance with the industry specification and they have removed the ability to add a custom port. Port 465 or 587 are not industry spec, nor are other ports EXCEPT port 25.

     

    This is Apple enforcing standards on the community. They are right... but... time to call my ISP or OUTBOUND SMTP provider.

  • happy hippy Level 1 Level 1 (0 points)

    Greetings,

     

    It and old problem, but after looking around and trying stuff to no avail, I found the answer in this forum somewheres (lost the post already, hehehe...my bad)

     

    I had the "server can not relay" issue and, what it worked for me like a charm on my old iPod and iMac (no issues with old iPad whatsoever), was doing this via Settings on the iPod, (it's gotta work for the iPhone too, what's the difference?) and via System Preferences>Internet Accounts on the Mac:

     

    1. Delete the faulty e-mail account (AOL in this case, and where I've seen around the problem exists), and then...

    2. Re-set it again.

     

    As simple as that.

     

    Tested it, and everything went back to normal. You can't lose any emails,  because everything is on the email online servers right? It makes sense.

     

    Hope this helps.

  • mabadjiev Level 1 Level 1 (0 points)

    So, how is this related to OS X Server 3.0.2?

  • happy hippy Level 1 Level 1 (0 points)

    Yeah, my bad. I think I replied on the wrong thread. I was just thinking of the problem of not being able to send emails through AOL and acted hastily. Apologies.

Previous 1 2 Next