Previous 1 2 Next 15 Replies Latest reply: Nov 23, 2013 11:56 PM by Terence Devlin
Roomtone007 Level 1 (0 points)

Since I have installed Maverick my iphoto crashes.   It opens but when I click to open a photo it crashes.


What is there to do?

iMac, iOS 7.0.3
  • Old Toad Level 10 (133,375 points)

    What version of iPhoto are you running?



  • Roomtone007 Level 1 (0 points)

    I have iphoto '08 7.1.5

  • Old Toad Level 10 (133,375 points)

    Apply the two fixes below in order as needed:


    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.




    Select the options identified in the screenshot


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


      1. Download IPhoto Library Manager 4 for OS XC 10.6.8 and iPhoto  8.1.2 and later  or iPhoto Library Manager 3 (for OS X 10.5.8 and iPhoto 7.1.5 and earlier) and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu (iPLM 3) or Library ➙ Rebuild Library menu (iPLM 4) option.
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

  • svanden Level 1 (0 points)

    I am also having a terrible problem.  First, iPhoto had crashed pretty much continually for me before Mavericks; I installed Mavericks and updated iPhoto hoping to fix the problem--all of which took literally HOURS on a gorgeous fall day.  No go.  I tried both of TD's fixes.  I rebuilt the database in iPhoto but the first photo I tried to edit afterwards the system crashed again--shut-down--and when it re-opened the message was "your library cannot be read." I am rebuilding, again.  When I try to use iPhoto Library Manager, it can never detect any photos in iPhoto--I get the "to get started with iPhoto" . . . screen--except once.  The one  time that it did detect my iPhoto library, it instantly crashed. 


    I am an Apple devote--but am getting close to saying "was."  It takes a lot for Apple to turn me off, but it's doing a pretty good job.  Photography is my passion, and I have always used iPhoto to its full advantage--I've just loved it.  But since taking over this mid-2010 machine last summer, I can't use it and keep losing stuff.  I've taken to downloading my photos onto the desktop, then uploading into iPhoto to avoid these problems, but it's killing my memory to have dups of everything.  (Yet, I don't want to do a depot repair, b/c I have a 3rd party 1 TB hard drive in there, in order to accomodate my need for all of this storage space.)  Please please help!  Don't make me resort to trying to get used to "Windows h8."  Thank you!!


    Here is the latest error log: 

    Mon Oct 28 00:14:47 2013

    panic(cpu 0 caller 0xffffff7f85fadfac): "GPU Panic: [<None>] 5 3 7f 0 0 0 0 3 : NVRM[0/1:0:0]: Read Error 0x00000100: CFG 0xffffffff 0xffffffff 0xffffffff, BAR0 0xd2000000 0xffffff80fbc1a000 0x0a5480a2, D0, P3/4\n"@/SourceCache/AppleGraphicsControl/AppleGraphicsControl-3.4.12/src/Apple MuxControl/kext/GPUPanic.cpp:127

    Backtrace (CPU 0), Frame : Return Address

    0xffffff80ec20b230 : 0xffffff8003c22f69

    0xffffff80ec20b2b0 : 0xffffff7f85fadfac

    0xffffff80ec20b380 : 0xffffff7f8461c53d

    0xffffff80ec20b440 : 0xffffff7f846e8d9e

    0xffffff80ec20b480 : 0xffffff7f846e8dfc

    0xffffff80ec20b4f0 : 0xffffff7f8496d5be

    0xffffff80ec20b620 : 0xffffff7f8470cd41

    0xffffff80ec20b640 : 0xffffff7f8462308d

    0xffffff80ec20b6f0 : 0xffffff7f84620bae

    0xffffff80ec20b8f0 : 0xffffff7f84622cb4

    0xffffff80ec20b9e0 : 0xffffff7f85606980

    0xffffff80ec20ba40 : 0xffffff7f85603702

    0xffffff80ec20bad0 : 0xffffff7f855edfd6

    0xffffff80ec20bb10 : 0xffffff7f855e4f1b

    0xffffff80ec20bb70 : 0xffffff80040cc226

    0xffffff80ec20bb90 : 0xffffff80040cd821

    0xffffff80ec20bbf0 : 0xffffff80040cb28f

    0xffffff80ec20bd40 : 0xffffff8003cb6008

    0xffffff80ec20be50 : 0xffffff8003c26bb1

    0xffffff80ec20be80 : 0xffffff8003c139b5

    0xffffff80ec20bef0 : 0xffffff8003c1e003

    0xffffff80ec20bf70 : 0xffffff8003cc921d

    0xffffff80ec20bfb0 : 0xffffff8003cf3e26

          Kernel Extensions in backtrace:[A4934A66-0E30-36E9-984A-650481102449]@ 0xffffff7f85fa0000->0xffffff7f85fb2fff

                dependency:[661E3C87-5B97-3272-88FF-B9BA9B6E2 4ED]@0xffffff7f85f98000

    dependency:[045D5D6F-AD1E-36DB-A249-A346E2B48E54]@0xfffff f7f84524000

                dependency:[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff 7f842ba000

                dependency:[38E388A5-92D6-3388-B799-F2498E582287]@0 xffffff7f84578000

                dependency:[E04639C5-D734-3AB3-A682-FE66694C66 53]@0xffffff7f85f9b000

   [0A1B6F41-168D-307A-BABD-162F3B3 C2786]@0xffffff7f845cb000->0xffffff7f8483afff

                dependency:[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff 7f842ba000

                dependency:[86BA68C6-18DD-30A1-ABF6-54597AD6C277]@0xff ffff7f845bb000

                dependency:[38E388A5-92D6-3388-B799-F2498E582287]@0 xffffff7f84578000[3666E0FC-87C7-3329-BD8C-2F1ADE D100A4]@0xffffff7f84845000->0xffffff7f84af1fff

                dependency:[0A1B6F41-168D-307A-BABD-162F3B3 C2786]@0xffffff7f845cb000

                dependency:[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff 7f842ba000[67BAF872-A238-3787-AB74-22297A51FE8F]@0xffffff7f8 55a3000->0xffffff7f8566dfff

                dependency:[447B4896-16FF-3616-95A2-1C516B2A1498]@0xffffff 7f842ba000

                dependency:[86BA68C6-18DD-30A1-ABF6-54597AD6C277]@0xff ffff7f845bb000

                dependency:[38E388A5-92D6-3388-B799-F2498E582287]@0 xffffff7f84578000

                dependency:[0A1B6F41-168D-307A-BABD-162F3B3 C2786]@0xffffff7f845cb000


    BSD process name corresponding to current thread: iPhoto


    Mac OS version:



    Kernel version:

    Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64

    Kernel UUID: 1D9369E3-D0A5-31B6-8D16-BFFBBB390393

    Kernel slide:     0x0000000003a00000

    Kernel text base: 0xffffff8003c00000

    System model name: MacBookPro6,2 (Mac-F22586C8)


    System uptime in nanoseconds: 3819966843922

    last loaded kext at 278877711352:      1.9 (addr 0xffffff7f860b0000, size 65536)

    last unloaded kext at 339977667576: 1.9 (addr 0xffffff7f860b0000, size 57344)

    loaded kexts:

    1.    3.11
    2.           1.60
    3.   1.9.5d0
    4.        100.14.11
    5.           4.2.0f6
    6.            3.0
    7.            4.2.0f6
    8.     124
    9. 2.5.2fc2
    10.           2.5.2fc2
    11.       1.0.0d1
    12.    8.1.8
    13.     2.0.4d1
    14.   1.0.0
    15.            8.1.8
    16.  1.7.0
    17.       8.1.8
    18.      7.0.0
    19.   1
    20.          1.0.0
    21.          3.5.13
    22.            3.4.12
    23.          1.1.12
    24.           3.0.4d1
    25.        240.2
    26.    240.2
    27.     3.3.5
    28.            325.7
    29.      1.0.0d1
    30.  1.0.0d1
    31.            35
    32.            3.6.0
    33. 404
    34.           2.4.0
    35.      650.4.4
    36.     2.9.5
    37.      4.9.9
    38.           700.20.22
    39.   3.6.9b9
    40.     650.4.1
    41.      161.0.0
    42.           2.0
    43.  2.0
    44.           1.8
    45.       2.0
    46.        2.0
    47.            1.7
    48.          216.0.0
    49.   153
    50.        3
  • Terence Devlin Level 10 (136,710 points)

    That's not an iPhoto crash, and frankly we've no way to know if you have an iPhoto problem or not. That's a Kernal panic and these are most often associated with hardware issues. How did that 3rd party HD get in there? Perhaps you need to go to the depot with it.

  • Old Toad Level 10 (133,375 points)

    Does the Mac have 3rd party RAM installed in it?  If it does that might be part of the problem. 

  • svanden Level 1 (0 points)

    Thanks for your time. I don't know much at all about hardware, so apologies if this question is ignorant, TD and Old Toad--the system only crashes when I am using iPhoto. I can edit images in preview, upload images from the desktop onto sites and insert them in documents--that is why I am so confused.  Could a hardware issue crash just one application (or vice versa)?  Again--thanks!

  • Old Toad Level 10 (133,375 points)

    Boot into the Recovery volume (boot with the Command + R keys held down).  Select Disk Utility and repair the disk and the disk permissions.  Reboot and try iPhoto again.

  • Brookny Level 1 (0 points)

    I am having the same issue.  I have iPhoto 11 version 9.5.  I have tried the following:


    • rebuilding and repairing using iPhoto
    • rebuilding my library with iPhoto Library Manager
    • creating a test library (still crashed)
    • deleting the iPhoto preference file and cache.


    Macbook Air - mid 2013

    OS X 10.9

    iPhoto 11 version 9.5

  • Old Toad Level 10 (133,375 points)

    Log into another user account on your Mac and try iPhoto there.  Does it work or crash there?

  • Brookny Level 1 (0 points)

    I created a new user account and iPhoto works.

  • Old Toad Level 10 (133,375 points)

    That means that there is something in your account that is the culprit. First fix attempt will be to try the following:


    1 - delete the iPhoto preference file,, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/ folder (Snow Leopard and Earlier).




    or with Lion, Mt. Lion or Mavericks delete the contents the User/Library/Containers/




    3 - reboot, launch iPhoto and try again.


    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and press the Return key - 10.7: Un-hide the User Library folder.


    If you're running Mavericks, 10.9,  go to your Home folder and use the View ➙ Show View Options menu to bring the this window:


    where you can check the Show Library Folder checkbox.


    If that fails it could be another preference file other than iPhoto's that is causing the problem.  Here's how to determine if that's the case:


    Trouble Shooting Preferences

    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and press the Return key - 10.7: Un-hide the User Library folder.


    If you're running Mavericks, 10.9,  go to your Home folder and use the View ➙ Show View Options menu to bring the this window:




    1 - close all applications.


    2 - open your Home/Library folder and Option-drag (copy) the Preferences folder to the Desktop. 


    3 - select the contents of your Home/Library/Preferences folder and drag them into the Trash bin in the Dock.  You will be asked to provide your Admin password.


    4 - reboot. Be sure to know your account's username and password as you will be asked to log in with it.


    5 - run the application again and determine if the problem(s) is fixed.


    6 - If the problem is fixed:


    A - open the working Home/Library/Preferences folder.


    B - Open the Preferences  folder on the Desktop, select all of the contents and drag them into the working Home/Library/Preferences folder.


    C - When the Copy window pops up check the "Apply to All" check box and then click on the Don't Replace or Skip button.


    D - reboot.


    7 - If the problem is NOT fixed, drag the contents of the Preference folder on the Desktop into the Home/Library/Preference folder and replace the entire contents that were created by clicking on Replace.


    8 - reboot and you're back as square one.


    Note:  keep the Preference folder on the desktop until you're sure all registration info for your apps are working.  If not you can copy the required files from the desktop pref folder to the working one.

  • Brookny Level 1 (0 points)

    I tried both and iphoto is still freezing.  Thank you for taking the time to try and help me!

  • Apple Man Since 1992 Level 1 (0 points)

    I'm having the same issues.  New Mac, loaded Mavericks, updated iPhoto, and crash, crash, crash.  All of these attempted "fixes" I'm reading just remind me of my evil empire Windows days.  I'm rapidly losing my 20+ year Mac devotion.

Previous 1 2 Next