2 Replies Latest reply: Oct 27, 2013 4:14 AM by Yeehat
theycallmeshua Level 1 Level 1 (0 points)

after the upgrade completed i got the "you need to restart your computer" screen, after doing so i kept getting sent to that screen

i called apple support, did numorous things that solved nothing.

 

finally booted into safemode and the install was completed and successful. but when i try to boot normally i get this kernel panic and the "you need to restart your computer" screen. i can not boot up out of safe mode..

not really sure what is causing the issue because there are no unloaded kexts...

 

Interval Since Last Panic Report:  624 sec

Panics Since Last Report:          2

Anonymous UUID:                    9134867A-54A2-407C-A681-FF5E38527167

 

Sun Oct 27 00:24:19 2013

panic(cpu 0 caller 0x226ec0): "thread_invoke: preemption_level -1, possible cause: unlocking an unlocked mutex or spinlock"@/SourceCache/xnu/xnu-1504.15.3/osfmk/kern/sched_prim.c:1471

Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

0x30ae3418 : 0x21b837 (0x5dd7fc 0x30ae344c 0x223ce1 0x0)

0x30ae3468 : 0x226ec0 (0x593ab8 0xffffffff 0x593a50 0x226aa1)

0x30ae34e8 : 0x2275c6 (0x45c101c 0x45c101c 0x30ae3548 0x233203)

0x30ae3558 : 0x227654 (0x0 0x0 0x0 0x4bf8ab4)

0x30ae3578 : 0x221d42 (0x0 0x0 0x18 0x0)

0x30ae3598 : 0x5362e7 (0x4889490 0x0 0x47dbda9 0x0)

0x30ae35b8 : 0x2a0d603a (0x4889490 0x47dbda9 0x0 0x4bf8ab4)

0x30ae35d8 : 0x2a0d8e9b (0x4aa1180 0x4aa1180 0x30ae3608 0x5619c8)

0x30ae3638 : 0x2a51c59e (0x47dbc00 0x47f3700 0xbc169000 0x2d)

0x30ae3688 : 0x2a5259ea (0x47dbc00 0x47f3700 0xbc169000 0x2d)

0x30ae3738 : 0x30af286f (0x2c233740 0x30af3c98 0x3 0x2741bf)

0x30ae37f8 : 0x30d08c (0x2c233740 0x0 0x46684bc 0x2a0354)

0x30ae3858 : 0x2ce7fc (0x30ae3948 0x49397e0 0x30ae38f8 0x42d929)

0x30ae3908 : 0x42d35f (0x492ff38 0x30ae3948 0x30ae3958 0x2cce69)

0x30ae3928 : 0x2fa6c8 (0x30ae3948 0x0 0x2 0x2e2493)

0x30ae3958 : 0x2d3cf5 (0x2c233740 0xf 0x0 0x0)

0x30ae3a68 : 0x2d436d (0x4000 0x0 0xfffff096 0x242c)

0x30ae3af8 : 0x2d6565 (0x4096 0x0 0x4000 0x0)

0x30ae3c48 : 0x2d7b2b (0x4096 0x0 0x4002 0x0)

0x30ae3ca8 : 0x2d7bca (0x4b83534 0x400 0x0 0x0)

0x30ae3cc8 : 0x421dca (0x4b83534 0x400 0x4a93294 0x30ae3d08)

0x30ae3da8 : 0x2fe8b1 (0x30ae3dc0 0x246 0x30ae3de8 0x2ff05a)

0x30ae3de8 : 0x2e0c92 (0x4b83534 0x45c5934 0x30ae3e18 0x0)

0x30ae3e08 : 0x2e0d02 (0x4b83534 0x0 0x0 0x0)

0x30ae3e28 : 0x2f5005 (0x4b83534 0x1000a 0x30ae3ed8 0x490706)

0x30ae3e88 : 0x473bb7 (0x4a1d998 0x30ae3ed8 0x3c 0x3)

0x30ae3ef8 : 0x475968 (0x4a1bf00 0x4a1d998 0x49832a0 0x0)

0x30ae3f38 : 0x475a39 (0x0 0x0 0x30ae3f5c 0x1)

0x30ae3f78 : 0x4f82fb (0x49832a0 0x4086688 0x45c5874 0x1)

0x30ae3fc8 : 0x2a251d (0x4086684 0x1 0x10 0x4085004)

      Kernel Extensions in backtrace (with dependencies):

         com.faronics.driver.DFXDriver(4.2.0f26)@0x2a0d5000->0x2a0eafff

            dependency: com.apple.iokit.IOUSBFamily(4.2.4)@0x309ac000

            dependency: com.apple.iokit.IOStorageFamily(1.6.3)@0x2a517000

            dependency: com.apple.iokit.IOPCIFamily(2.6.5)@0x2a4c2000

         com.apple.BootCache(31.1)@0x30aef000->0x30af3fff

         com.apple.iokit.IOStorageFamily(1.6.3)@0x2a517000->0x2a52ffff

 

BSD process name corresponding to current thread: fsck_hfs

 

Mac OS version:

10K549

 

Kernel version:

Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386

System model name: MacBookPro5,1 (Mac-F42D86C8)

 

System uptime in nanoseconds: 5258088740

unloaded kexts:

(none)

loaded kexts:

com.faronics.driver.DFXDriver          4.2.0f26

com.apple.driver.AppleUSBTCButtons          201.6 - last loaded 2363282189

com.apple.driver.AppleUSBTCKeyEventDriver          201.6

com.apple.driver.AppleUSBTCKeyboard          201.6

com.apple.driver.AppleIRController          303.8

com.apple.iokit.SCSITaskUserClient          2.6.8

com.apple.iokit.IOAHCIBlockStorage          1.6.4

com.apple.driver.AppleFWOHCI          4.7.3

com.apple.BootCache          31.1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

com.apple.driver.AppleUSBOHCI          4.2.0

com.apple.driver.AppleAHCIPort          2.1.7

com.apple.driver.AppleUSBHub          4.2.4

com.apple.driver.AppleEFINVRAM          1.4.0

com.apple.driver.AppleUSBEHCI          4.2.4

com.apple.driver.AppleRTC          1.3.1

com.apple.driver.AppleHPET          1.5

com.apple.driver.AppleSmartBatteryManager          160.0.0

com.apple.driver.AppleACPIButtons          1.3.6

com.apple.driver.AppleSMBIOS          1.7

com.apple.driver.AppleACPIEC          1.3.6

com.apple.driver.AppleAPIC          1.4

com.apple.driver.AppleIntelCPUPowerManagementClient          142.6.0

com.apple.security.sandbox          1

com.apple.security.quarantine          0

com.apple.nke.applicationfirewall          2.1.12

com.apple.driver.AppleIntelCPUPowerManagement          142.6.0

com.apple.driver.AppleUSBMultitouch          207.7

com.apple.driver.BroadcomUSBBluetoothHCIController          2.4.5f3

com.apple.driver.AppleUSBBluetoothHCIController          2.4.5f3

com.apple.iokit.IOBluetoothFamily          2.4.5f3

com.apple.iokit.IOUSBHIDDriver          4.2.0

com.apple.iokit.IOSCSIMultimediaCommandsDevice          2.6.8

com.apple.iokit.IOBDStorageFamily          1.6

com.apple.iokit.IODVDStorageFamily          1.6

com.apple.iokit.IOCDStorageFamily          1.6.1

com.apple.driver.AppleUSBMergeNub          4.2.4

com.apple.driver.AppleUSBComposite          3.9.0

com.apple.driver.XsanFilter          402.1

com.apple.iokit.IOAHCISerialATAPI          1.2.6

com.apple.iokit.IOSCSIArchitectureModelFamily          2.6.8

com.apple.iokit.IOFireWireFamily          4.2.6

com.apple.driver.AppleFileSystemDriver          2.0

com.apple.iokit.IOAHCIFamily          2.0.6

com.apple.iokit.IOUSBUserClient          4.2.4

com.apple.iokit.IOUSBFamily          4.2.4

com.apple.driver.AppleEFIRuntime          1.4.0

com.apple.iokit.IOHIDFamily          1.6.6

com.apple.iokit.IOSMBusFamily          1.1

com.apple.security.TMSafetyNet          6

com.apple.kext.AppleMatch          1.0.0d1

com.apple.driver.DiskImages          289.1

com.apple.iokit.IOStorageFamily          1.6.3

com.apple.driver.AppleACPIPlatform          1.3.6

com.apple.iokit.IOPCIFamily          2.6.5

com.apple.iokit.IOACPIFamily          1.3.0


MacBook Pro, Mac OS X (10.6.3)
  • FrenchToast Level 3 Level 3 (645 points)

    What were the peripherals you had plugged into your Mac when you installed Snow Leopard? Apparently, one or more drivers or kernel extensions are corrupted.

     

    You may have to perform another clean install to solve the problem, after completely erasing your hard drive. Since you seem to have a MacBook Pro (which model?), you may want to install with the battery removed: it'll clock the CPUs down, and it'll take a little longer, but you won't risk overheating, and that may sometimes be the reason why SL installs go bad.

     

    Since Snow Leopard, the OS caches the files prior to install, so that you can perform a clean install in several instalments. The downside of this is, if/when a corrupted file is being cached, it gets written to disk anyway, and is not overwritten by a clean copy.

  • Yeehat Level 1 Level 1 (40 points)

    Another user reported kernel panics caused by the com.faronics.driver.DFXDriver extension (a version older than yours though):

     

    https://discussions.apple.com/thread/3205581

     

    It may be worth moving it to trash and see if it's the culprit.