Previous 1 2 Next 25 Replies Latest reply: Mar 13, 2015 2:44 AM by gantenbeyn Branched to a new discussion.
Schwa72 Level 1 (15 points)

I've been messing with this for the last 12 hours and am at my wit's end.  Hopefully you guys can help.  Anyway, here's the deal:


I just installed a new LaCie 2big Thunderbolt external hard drive (configured as a 4TB striped RAID 0 volume) to my 2011 iMac.  I currently have my personal home folder located on my iMac's internal 2TB hard drive.  All I'm trying to do is move this personal home folder from the internal hard drive to the new external RAID volume.  I've tried this two different ways -- first, I logged in to my iMac using a different admin account and copied my personal home folder from the internal HD to the external one, then I used System Preferences/Users & Groups/account name/Advanced Options to tell the OS the new location of the home folder.  I've also logged directly into the personal home folder account and, from within that account, copied the personal home folder from the internal HD to the external HD.  I used the same procedure described above to tell the OS the new location of the home folder.


Neither method works.  I can log into my personal account, but when I log in the OS clearly isn't seeing my home folder because the desktop and dock look like they do when logging into a new account for the first time.  What's weird is that if I go through System Preferences to again select the location of the home folder and browse to the folder's location, the system has appended a "1" to the end of the external volume's name.  In other words, if the path to the home folder after the initial folder move was "/Volumes/external/Users/personal", if I try to browse to the new home folder location after the unsuccessful login, the path becomes "/Volumes/external 1/Users/personal".


I've followed the tips in this post and do see the redundant volumes in the hidden Volume folder listing on my Macintosh HD, but deleting them and remounting my external drive doesn't fix my problem.


I'm sure I'm missing something obvious but I've followed every procedure on the web that I can find to the letter and still can't get this to work.


Help!  And thanks in advance!

  • Schwa72 Level 1 (15 points)

    I completely forgot to mention -- my iMac has both a 256GB SSD and a 2TB HDD in it.  The OS and apps are on the SSD; only the home folder that I'm trying to move is on the internal HDD.

  • actionmarker Level 4 (1,555 points)

    It sounds like during login, your new home folder location is not been found, it may be due to the external drive not being found at the time.


    I would suggest using symlinks for these home folders.


    Here is quite a good description of how to set them up


  • Schwa72 Level 1 (15 points)

    I took your advice and started moving subfolders from my user folder to my external drive creating symlinks as I went.  It seemed to work fine until I moved the ~/Library folder -- moving that folder broke everything and caused the same problem as I described in my first post; namely, when I log in, the OS isn't seeing my home folder because the desktop and dock look like they do when logging into a new account for the first time.  In fact, copying the ~/Library folder back to the internal drive from the external drive didn't fix the issue so right now I'm restoring my home folder from Time Machine.


    What is it about the ~/Library folder that screws everything up when I move it?  Could the fact that my RAID 0 array is a software RAID configuration be the issue?  I can probably get the vast majority of my large files moved out of my home folder but I'm baffled as to why this is giving me such a hard time.

  • Hans D. Level 1 (5 points)

    Interesting, I'm having the same issue on my MacBook Pro that has both an SSD (for the OS and Apps) and a Hard Disk in place of the Superdrive. This config worked just fine with Mountain Lion; since upgrading to Mavericks this morning, I am unable to log into my personal account that has its home folder on the hard disk.


    Unfortunately, it also seems to be an issue with the library folder, as I've been able to solve this issue with symlinks just fine with the exception of Library: the system keeps asking me to key in my password because the Library folder "needs to be repaired".


    I can't move my Library folder to the SSD, as it is way too big (for whatever reason) - the SSD is only 96 Gig.


    What is so different here is that the hard disk in the system is encrypted - I think this is the problem. I don't understand why, though, because under ML, I just logged in as admin after every reboot, which mounted the encrypted disk and then logged out / logged back in with my user account - it worked just fine.


    Something seems to have changed with Mavericks regarding making available the encrypted HD...


    Oddly enough, on my Mac Mini at home, which also has the SSD/HD pair, the moved home folder works fine - of course, here the HD isn't encrypted...


    I hope someone has a fix for this, otherwise I'll have to go back to ML!

  • actionmarker Level 4 (1,555 points)

    What happens if you make a new user account and move its home folder to the HDD, reboot and log into that account.

    Does the same issue occur?

  • Hans D. Level 1 (5 points)

    An excellent idea. However - for whatever reason - I am now able to log into my working account, despite the home directory being on the second, encrypted HDD. The only thing I changed was to make a symbolic link directly to the root of the home directory.


    I.e. I made a link called "accountname" (replace with the proper name of the account) in the Users directory on the SSD and had it point to the directory of the same name in the /Users directory on the encrypted HDD.


    Even though selecting the link name on the SSD, when changing the home directory path for the user, goes straight to the linked directory (which I would expect), the login works now!


    The only reasonable explanation I was able to create was that Mavericks - for whatever reason - expects some directory / file (perhaps the Library directory?) to be in the user's directory on the boot drive and is - using the link - fooled to go to the 2nd HDD after all???


    Sounds fishy, but whatever.


    Unfortunately, my problems aren't fixed, but I'll open a new thread for the new (?) problem.

  • har30185 Level 1 (0 points)

    I'm having a similar issue...


    I moved my home directory to another volume (external RAID5 via eSATA) and all my data seems to be intact, and I can log-in just fine. However, there seems to be a permissions issue (at least I think this is the problem). If I log-out none of my preferences are saved (i.e. when I log back in desktop icons are back to defaut positions, dock icons are also rearranged into default positions). I can move, modify, and delete folders and files, but the system prompts me for an administrator password each time.


    I was sure to add permissions on my home directory to read/write for my user, take ownership and apply to all subfolders, but still unable to save preferences or modify files. When I check permissions (via Get Info) on various subfolders and files all looks good - read/write for my username.

    I have not played with the symbolic links as one person mentioned - I followed instructions from a post that indicated using the Advanced Options under Users & Groups to modify the location of my home directory - again, all seemed to have gone okay except for this permissions thing.


    Any ideas?

  • Hans D. Level 1 (5 points)

    Hi har,

    I fixed that: had the same issues, it turned out that my personal Library folder (need to make it visible first) had - for whatever reason - two ACL entries in addition to the regular POSIX permissions. The latter were okay, the ACL stuff was crap.


    One entry was for Everyone to have no access at all.


    I removed the ACL permissions (there is no reason for them on a regular Mac - there may be if you're running on a server account) and propagated the removal to every file and directory in my Library folder.


    And: voila! Everything was fine!


    Give it a shot, its easy to fix!

  • har30185 Level 1 (0 points)

    This worked... my Library file and preferences are saving changes now. I still have some other files under Documents, etc, that I still need to change permissions - still getting an admin password prompt when modifying other files, but the No Access to the Everyone group seemed to work.

    It's slow going b/c this all happened when one of 4 drives went out on my external RAID5 array - waiting on my drive replacement and crossing my fingers that another drive does not go out before then.

  • jedlh Level 1 (0 points)

    For those w/a SSD+HDD, everything I've read suggests it makes more sense to move only "parts" of the Home folder rather then the entire thing*. Only files/folders that are infrequently used or large should go into the HDD, everything else (esp. most of the stuff in the hidden ~Library folder) is best-off left on the SSD. This approach takes advantage of the strengths of your SSD & your HDD.


    *those parts can be symlinked back to the SSD

  • mark00thomas Level 1 (0 points)

    Hey Friends,


    Looks like we all jumped in the same boat. I have documented a little bit on mine here along with Apple Enginers responce. The real issue I suspect is that the security process looks to your keychain to unlock/decrypt the rest of the volume. Which is why restorying access to the user/Library fixes the problem.


  • mark00thomas Level 1 (0 points)

    jedlh, my library is over 300GB with iphone backups, email, and other items.


    there should be an easier way than jugeling all these symbolic links.

  • jedlh Level 1 (0 points)

    There's nothing to "juggle", just pick out the dirs/files that are most appropriate & away you go...

    Which ones is easy to determine if you understand the nature of HDD's & SSD's & which dirs/files they deal with best, if you don't, do some reading.

    Takes about 5min, there's even a plugin for Finder which gets rid of the need for terminal (except for when deleting dirs/files from home dir).

    A blanket redirection of the entire ~/home directory is silly, a carefully partially redirected one exploits both drives much better, & it avoid technical issues.

  • jedlh Level 1 (0 points)

    I had typed out a much more detailed & succinct response, but because of the stupid time-out it's all lost, not typing it again.


    Final point, any sort of redirection will be moot soon, $/GB is quickly dropping for SSD's, already one can get 500GB for relatively cheap, current $/GB leaders are generally considered to be: M500 & Evo.*

    In my case, I made an assessment & found it was still necessary; for over-provisioning & other reasons (240GB SSD).


    *they're not the 6G SSD performance leaders, just the $/GB leaders


    <Edited By Host>

Previous 1 2 Next