Previous 1 2 3 Next 108 Replies Latest reply: Apr 12, 2015 10:03 AM by Steve Heffern
t.pawelek Level 1 Level 1 (0 points)

Hey Everyone,

 

So I upgraded to 10.9, which is great, purchased the new Server, which is great and no matter what I do I can't get it to work. Which is not so great.

 

Here's the story:

 

1) Clean install of 10.9 on 2013 mac mini. Multiple times in fact.

 

2) Install OS > Configure Network (fixed eth ip) > Disable Wifi > Set Hostname > Configure App Store ID > Download Server > Install Server > Enable Caching.

 

3) Server is not a gateway and is connected directly to the LAN with a fixed IP (via time capsule). External IP confirmed to be the same between Server logs and the clients. Power saving is disabled (mini is on 24/7). Firewall is disabled.

 

4) Multiple clients running latest OSX / iOS. All using the same Apple ID as the Server. Tried some clients with a different ID from the same region (US) and from a different region (EU).

 

5) No matter what I do, the only stuff that's being cached is the system updates (itunes / codecs / etc.). Not a single OSX / iOS app is being cached.

 

6) Tried a variety of .plist changes, increased the log verbosity. No errors in Debug.log: normal registration, etc. But not a single OSX / iOS app is being cached. Downloading apps on clients doesn't do anything (i.e. doesn't spawn a single line of log), even with logging = verbose. Restarting the services doesn't reveal any issues, just a regular registration every single time.

 

7) Asked Apple for help, they asked for log files and remain silent since then (couple of days now).

 

I wasted so much time on this already. I'd be really grateful if anyone pointed me in the right direction (other than a wall with a "bang head here" poster).

Previous 1 2 3 Next