Previous 1 2 3 4 5 Next 62 Replies Latest reply: Apr 14, 2014 4:07 PM by Crounbie Roberts Go to original post
  • RoupenM Level 1 (0 points)

    Thanks Mak! This seems to have corrected the problem for me as well. My issue was with the HDV files and it looks like the PerianHDV component fixed that playback. Lesson learned - do not update any of your critical macs before testing the updates on a less critical one! I don't know why I keep forgetting this lesson. This is not the first time an Apple update has messed up my workflow.

  • Birdman308 Level 1 (0 points)

    I just want to say thank you thank you thank you to the person who figured out the problem and posted the solution.  You are a genius and you just saved my week!!

  • rejj Level 1 (0 points)

    It is, indeed, the HDV file that is the problem, but you can also solve the issue by reverting to an earlier version if you have it available.

     

    I have FCP 7 on an older computer and simply replaced this one file, and my XD Cam footage was back online.

    Path to replace Apple HDV Codec.png

  • peter stephen Level 2 (260 points)

    so glad yo have found this. I had a meltdown today. I have a load of HDV files exported by FCP 7 in 2011, 2012, that play with a black screen. Obviously a codec problem. Interestingly I also have HDV files made this year that WILL play ?? As it looks like I'll have to find and replace this file as identified by rejj my problem is where can I get a copy that isn't updated. ?

  • rejj Level 1 (0 points)

    peter stephen: read previous posts ... StevenEsqTwo2 and makbookpro offer suggestions.

  • algamedia Level 1 (0 points)

    Hello,

     

    I have the same problem.

    I change AppleHDVCodec.component from my macbook pro, and perfect!

     

    Thank you!!!!

     

     

    I´m sorry, i can insert the component in this message...

  • peter stephen Level 2 (260 points)

    OK got that, thanks, I'll try ity in the morning with a clear head.

  • algamedia Level 1 (0 points)

    Hello,

     

    Finally, i copy all the quicktime library from my macbook pro.

    Only with AppleHDVCodec.component doesn´t work 100% perfect.

     

    I can´t believe how apple do this mistake....

  • peter stephen Level 2 (260 points)

    Well I didn't do and re-instals etc, simply drilled down into my FCP backup with Pacifist and lifted the HDVCodec and dropped it into the quicktime folder, loggerd out and in again ans so far HAPPY DAYS.  Thanks a milliuon lads

  • bernardis Level 1 (0 points)

    Hi, Steve,

     

    i am having the same problem. Can't play mov files in FC 7. COuld you send meby email this codec to be replaced?

     

    tks fomr Brazil

     

    btomasi@hotmail.com

  • Birdman308 Level 1 (0 points)

    Hey Everyone, here is a yousendit link to the HDV codec that you all need.  It goes in your HD>Library>Quicktime folder.

     

    https://www.yousendit.com/download/OGhkZ28xeWFiV3dYRHRVag

  • gonzochicago Level 1 (0 points)

    Please help.  I am at the end of my rope with this.

     

    I recently updated my ios to 10.6.8 and from what I remember, it made me updated Quicktime and Itunes (?) . . . this was all just so I could put music on my stupid Iphone.

     

    Then I went into FCP7 today (regular 7...i still can't find a link to download 7.0.3) and I could *SEE* the XF files (Canon XF100) but non of them would 'log and transfer' into .AVI files.

     

    Frustrated, I began to re-download everything.  The XF utility, etc.  I believe I downloaded this dreaded program you all speak of in the process.

     

    THEN, *NOTHING* would work.  I could put the XF files into log and transfer, but theyd only play for 2 seconds, and theyd be black.

     

    Then I found this thread.  I downloaded the HDV file you all speak of, and it did nothing. 

     

    HOWEVER, the "PerianXDcam" file *DOES* work!  I was elated, but then, to my dismay, FCP7 keeps crashing.  I can encode about 6 seconds of videos, but when I try to move to something else, or play them in 'log and transfer', crash crash crash.  This never happened before.

     

    ALL I HAVE in the library folder of Quicktime is now this "persianxdcam" .... (i don't even think the XF100's are XD format?)

     

    I don't have my original disc, and I don't have my original FCP7 disk!

     

    Am I screwed?  Why is it crashing so much?

     

    Could someone ZIP me their Library folder?

     

    This is my info.

     

    FCP7 (there are no .x.x after it)

    Canon XF100 (w/ XF100 FCP plugin)

    ios 10.6.8

     

    HELP!!!!!! I'm gonna beat up a wall! 

  • heathfranklin Level 1 (5 points)

    birdman's solution worked for me, thanks!

  • RoupenM Level 1 (0 points)

    I'm on the same boat as Gonzo. I thought the perian install would work and it plays them fine but in final cut when I try to export anything it gives me a "General Error". Tried removing the perian files and adding the HDV codec in the yousendit link posted above but now I get an out of memory error when I try to open hdv in final cut I only messed with this component folder so maybe some other file in here is causing issues? If someone could just zip up their whole components folder like Gonzo said that would be real helpful! Never update your mac software!!!