Previous 1 3 4 5 6 7 Next 180 Replies Latest reply: Mar 19, 2015 4:06 AM by Laura Malick Smith Go to original post Branched to a new discussion.
  • kb8wfh Level 1 Level 1 (5 points)

    Never mind. I went into the folder info and unlocked the folder (authenticated) and added Administrator as a viable read/write authorization. Glad I didn't have to get the bloomstick of the wicked witch of the west first.

     

    This level of bug can not possibly have escaped Apple's beta testing and it's inexcusable they release Mavericks with stuff like this in it.

  • Scott Newman Level 2 Level 2 (220 points)

    kb8wfh:  It's probably a good idea to go into Disk Utility and repair permissions.  It certainly won't hurt anything and it will restore the default and correct permissions to this file.

  • kb8wfh Level 1 Level 1 (5 points)

    I've run DiskUtility and repaired permission five times today. Three after I have run the workaround.

     

    EPIC FAIL, APPLE!

  • Reinko Hallenga Level 1 Level 1 (20 points)

    Having this problem too. Quickest workaround when I'm saving a file is to drag and drop the correct location from the finder onto the app's dialog. This will then show up (even if the folders at the same levels still aren't showing).  

  • Dan Pimentel Level 1 Level 1 (55 points)

    I am several days into the workaround posted here by Snaggletooth_DE and it has worked perfectly...issue is gone for me. I have three external FW drives on this Macbook Pro, mounting them, ejecting, etc...all read fine. No more finder issues for me at this point. Just follow the instructiosn exactly...a little unnerving at first but I did it and have not seen any other issues with any part of the system or various apps.

  • R C-R Level 6 Level 6 (15,120 points)

    kb8wfh wrote:

     

    tryign to edit this file, I recieve a message indicating I do not have permission to edit this file. I asks me if I want to dreate a pupliucate, which is useless becuase it changes the document type to a text file rather than a 'document."

     

    I am looged in as the administator. So how do I edit this file with the great and powerfull Oz's benevolent permission to fix this maddening probelm?

    For future reference, a simple way to change files like this is to go ahead & save a duplicate somewhere you do have permissions to change, like the desktop. Then do a Get Info on the duplicate, remove the extension (the OS will ask you if you are sure you want to do this but let you), make sure the filename is exactly the same as the original, & then drag it back to the original location.

     

    The OS will once again tell you you don't have permissions to change the file, but this time it will give you an opportunity to authenticate as an admin user. After doing that the file will be replaced.

     

    The best thing about this is you can use some familiar GUI-based text editor like TextEdit to modify the file. Just make sure you save the duplicate with UTF 8 plain text encoding. ("Duplicate" changes to "Save as" in the file menu if you hold down the option key.) It also doesn't require you to remove the permissions restrictions on system level folders that (among other things) protects the OS from malware.

     

    As for why you need to go through all these steps, it is because modifying any system level file owned by root potentially can render the OS unusable. In effect, by requiring admin authentication, it is telling you that you better know exactly what you are doing if you do this.

  • andyBall_uk Level 7 Level 7 (20,495 points)

    While that does replace the file, the new one will have user-staff permissions, rather than the original system:wheel. That may not cause problems, but in some cases it certainly will.

  • OrazioTP Level 1 Level 1 (0 points)

    Thank you Snaggletooth DE.

    I was looking for days to solve this problem, not even a fresh install of mavericks solved this issue.

    Now everything work smooth thank to the Snaggletooth DE workaround!

    If anybody need help for VI at this link can find basic instruction to edit "auto_master" file.

  • R C-R Level 6 Level 6 (15,120 points)

    andyBall_uk wrote:

    While that does replace the file, the new one will have user-staff permissions, rather than the original system:wheel. That may not cause problems, but in some cases it certainly will.

    True, but a permissions repair will correct the file's permissions, or that can be done manually for that one file by the user. Regardless, it is better than adding admin permissions to the whole folder.

  • zer0ed Level 1 Level 1 (0 points)

    Hard to believe, but this issue doesn't look to have been addressed in the 9.1 beta!

  • Dickie7 Level 1 Level 1 (5 points)

    Having the same missing files/folders here... don't feel al that comfortable messing with Terminal though, so not sure where to even insert the workaraound from Snaggletooth.

  • R C-R Level 6 Level 6 (15,120 points)

    Dickie7 wrote:

    Having the same missing files/folders here... don't feel al that comfortable messing with Terminal though, so not sure where to even insert the workaraound from Snaggletooth.

    The issue being discussed here is files & folders being slow to show up in Finder windows. If you have ones that are missing (they don't show up in Finder windows even after waiting 10-30 seconds or so) then your problem is a different one & this (possibly questionable) hack probably won't change anything or maybe even make things worse.

  • zer0ed Level 1 Level 1 (0 points)

    Well there is a new build out for Beta 9.1 that is designated 13B40. Since the prior build of 9.1 (13B27) didn't address our issue, hopefully build 13B40 will.

  • Vktor Level 1 Level 1 (0 points)

    I have resolved the issue in my Mavericks not showing the TAGS in the left side panel in Finder. Apparently it dynamically update all Tags when the Finder dialog box is open from any application, causing all delays...

     

    I hope it helps...

     

    (Open Finder, Preferences->Sidebar, uncheck TAGS)

  • Ken McEwen Level 1 Level 1 (5 points)

    Hi Azamino

     

    Weird. It works. I had been annoyed that the contents of folders were not showing when I clicked on the paperclip to add a file to an email. It would show the folder but not the contents.

     

    I had the scroll bars turned on, so I changed to automatically and now the files inside folder show up instantly.

     

    So, thanks for that suggestion. (But, we should have to toggle scroll bars to get the finder to work for attaching files!)

     

    Ken

Previous 1 3 4 5 6 7 Next