Previous 1 5 6 7 8 9 Next 186 Replies Latest reply: Feb 4, 2016 12:56 AM by G-rubb Go to original post Branched to a new discussion.
  • Laurent Seroude Level 1 (65 points)

    THANK YOU Snaggletooth, your solution fixed the problem and might have also fixed the random eject issue that affects FireWire drives since Lion (see this thread:

  • zer0ed Level 1 (20 points)

    Apple has released a 9.2 (13C32) build a few days back which I believe still doesn't address this delay issue.

  • igirl1 Level 1 (25 points)

    Same issues - just migrated to a new Mavericks iMac - never a problem before in Lion on an identically configured computer.  I don't like the idea of mucking around in Terminal to have to fix this - will wait for the update to fix it.

  • zer0ed Level 1 (20 points)

    Unfortunately, you might be waiting a long time for Apple to address this issue! I'd recommend you reconsider implementing the fix! If you need help, just ask. It's really very easy to do!

  • Brian Covalt Level 1 (55 points)

    I think you're right zer0ed.

    I'm going to take a stab at this.

    Is this the exact command to enter in Terminal as suggested by Snaggle?


    sudo vi /etc/auto_master


    In this file comment out /net with #  (#/net .....)


    sudo automount -vc


    I wonder if the "....." after "#/net" is meant to be replaced with something specific, but I wouldn't know what.

    Thanks for the clarification.

  • brilor Level 1 (20 points)

    Suggest looking at the comments in this related thread ( different problem - same workaround ). It explains using a GUI editor instead of vi or pico.

  • OrazioTP Level 1 (0 points)

    Maybe my experience could help you.

    Read everything before start.

    Use at your own risk!


    To follow the Snaggletooth workaround

    you may edit "auto-master" file following instruction from vim user manual at this link


    Below what I did.


    open terminal


    type: “sudo vi /etc/auto_master”


    autenticate with your password


    you will see something like this:



    # Automounter master map


    +auto_master            # Use directory service

    /net                   -hosts          -nobrowse,hidefromfinder,nosuid

    /home                   auto_home       -nobrowse,hidefromfinder

    /Network/Servers        -fstab

    /-                      -static




    move the blinking cursor with arrows keys until the start of the following line




    Now, if you type the "i" command, Vim will display --INSERT-- at the bottom

    of the window.  This indicates you are in Insert mode.


    type: “#” before “/net” to obtain "#/net ...." to comment the line


    now you should see something like this:



    # Automounter master map


    +auto_master            # Use directory service

    #/net                   -hosts          -nobrowse,hidefromfinder,nosuid

    /home                   auto_home       -nobrowse,hidefromfinder

    /Network/Servers        -fstab

    /-                      -static


    if ok type esc key to exit from --INSERT-- mode


    NOW To exit and save your work, use the "ZZ" command (shift zz).  This command writes the file and exits.



    Unlike many other editors, Vim does not automatically make a backup

    file.  If you type "ZZ", your changes are committed and there's no

    turning back.


    exit from terminal


    sorry for my english i'm from italy

  • Eric Hildum Level 2 (265 points)

    If commenting out automounting network shares works for you, then it is clear that the issue is a configuation problem of your Mac, not a bug in OS X. Most likely, you are trying to mount a share that is no longer available or taking a long time to respond. What are the contents of /etc/autofs.conf and what share points are you attempting to mount? Are they all actually present and responding over the network promptly?

    Try removing all network shares you have configured (including aliases to files on the shares) and see if that resolves your problem.

  • zer0ed Level 1 (20 points)

    Eric, First of all, this is the default installation configuration for Mavericks, none of us have modified it in anyway! The problem is not a configuration problem on our Mac's unless Apple has created it!

  • brilor Level 1 (20 points)

    Eric Hildum wrote:


    If commenting out automounting network shares works for you, then it is clear that the issue is a configuation problem of your Mac, not a bug in OS X.


      What are the contents of /etc/autofs.conf and what share points are you attempting to mount?

    A reasonable diagnosis but it doesn't match my circumstances and perhaps others too. There have never been any network shares attached to this Mac. I do mount some local external volumes ( and later eject them ) for clone backup. It is a standalone Mac.


    The live entries in my  /etc/autofs.conf are:






    Thanks for the input Eric.

  • OrazioTP Level 1 (0 points)

    I had problems on a fresh installation to, at home without any shared disk

  • Scott Newman Level 2 (220 points)

    Really don't like being lectured to.


    The file at issue hasn't changed for a while.  I did not have the problem described in this thread in Lion or Mountain Lion.  As soon as I updated to Mavericks, I did have the problem on two different 2011 MacBook Airs.  Then, I updated my wife's mid2010 MacBook Air.  Same problem again even though her setup is quite different from mine.


    The bug relates to how Mavericks is handling the contents of the file--not what's in the file because it didn't change with Mavericks.


    Commenting out that line in the file works for now...perfectly.

  • zer0ed Level 1 (20 points)

    Well now we know why it hasn't been fixed yet! Time to stop putting the blame on the users and to start looking closer at your code!

  • zer0ed Level 1 (20 points)


    Perhaps you'd like to collect and submit the below info that Eric's requested, since I'm back on 10.8.5. Here's Eric's response found elsewhere on this board:



    Interesting. Are these really clean installs with no migration of any kind? Simply format hard drive and install Mavericks with no migration by Setup Assistant or Migration Assistant, and no network connections active - a pure install on a standalone system? And these are stock Macs with no third party hardware?


    If so, then check the Console for any messages which would indicate I/O issues to the hard drive, and Activity Monitor for unusual memory usage (e.g. memory pressure in yellow). Also verify the drive in stand alone mode or booted from the recovery partition.


    If there is no hardware issue, and a true clean install really does show an issue, then from the Terminal run

    sudo sysdiagnose -t Finder

    while duplicating the problem and submit the resulting diagnostic file and a System Report in a bug report to Apple with as complete a description of the symptoms as you can. Note that the resulting diagnostic file will be large, and will take some time to collect.



    Yes, this issue was indeed happening on a newly formatted system drive with no migration whatsover, just a pure virgin install of Mavericks! Yes, I for one am running on a stock Late 2009 27" iMac 2.66Mhz Quad Core that suffers the symptom.

  • Technick Solutions Level 1 (0 points)

    Wel this solved the issue for me. Was drving me nuts. Thanks very much.

Previous 1 5 6 7 8 9 Next