5 Replies Latest reply: Nov 27, 2013 5:15 PM by PeauDeSoie
RugbyStar Level 1 Level 1

Hi everyone, hope someone out there can help me with this problem as it is driving me and my family absolutely crazy. Let me start by giving you some information and background.


I have been experiencing problems with AppleTV since purchasing it earlier this year. It is a 2nd generation model and initially worked fine when I first installed it connecting to my network and theinternet via wifi.Slowly connection became intermittent then following a software update I was no longer able to utilise the Home Sharing function although other items such as Netflix, Youtube and items within the iCloud were still accessible. Try as I might I was unable to access Home Sharing and so reported the problem and booked an appointment at my local Apple Store. They examined the unit and as it was still under guarrantee they replaced it with another.During that time I purchased a new computer and thought that a combination of the two would result in a faultless performance but I have still not been able to access Home Sharing.


Several months have now passed and the problem remains. I suspect this is something connected with the firewall settings possibly causing the problem although I am unsure of what the exact settings need to be within my Windows firewall and Virgin Media security to ensure the AppleTV works correctly (and so I can finally eliminate this as the potential source of the problem). Unfortunately the problem has now escalated as my family were settling down to watch a movie on Netflix. After we had chosen a film and selected play it responded that we didn't have a network connection. I checked and restarted my router and this had no effect. I checked the network settings on the AppleTV and whilst the network was clearly visible and signal strength was very strong a test of the network suggested that there wasn't a network to check. I tried this several times but unable to connect to itunes and the test facility did not recognise my Apple ID (when it got that far).


After several restarts that told me I was not connected to the network even though settings suggested that I was, I tried to restore the unit to factory settings but it wasn't able to do that claiming that the update was unsuccessful. The only other option I was able to select was a reset of the unit which I did and re-entered all of the network information to permit a connection to the network via wifi. This proved unsucessful although the unit was saying that I was in fact connected to the network but not able to connect to the internet. I checked this claim by using my ipod and iphone which both were able to connect to the internet using the same wifi network so I couldn't understand why this was happening. When I checked the 'About' information on the AppleTV it confirmed the Network, IP address, signal strength etc but for some reason under 'Initalisation' it said that this had failed.


Does anyone know what is happening here? Any help would be gratefully received. Thank You!

AppleTV 2
  • Winston Churchill Level 10 Level 10
    Mac OS X

    Welcome to the Apple Community.


    Intermittent problems are often a result of interference. Interference can be caused by other networks in the neighbourhood or from household electrical items.


    You can download and install iStumbler (NetStumbler for windows users) to help you see which channels are used by neighbouring networks so that you can avoid them, but iStumbler will not see household items.


    Refer to your router manual for instructions on changing your wifi channel or adjusting your multicast rate.


    There are other types of problems that can affect networks, but this is by far the most common, hence worth mentioning first. Networks that have inherent issues can be seen to work differently with different versions of the same software. You might also try moving the Apple TV away from other electrical equipment.


    The following article(s) may help you.


    Troubleshooting Wi-Fi networks and connections 

    Recommended Wi-Fi settings

    Sources of Interference

    Wifi Diagnostic Software (for Mac users)

  • RugbyStar Level 1 Level 1

    Thanks Winston, however I don't think that this is the cause of the problem. We haven't had any additional equipment added within the house and everything is in the same position as it was when the original AppleTV was working as it should. We do have a number of neighbouring networks that I appreciate can cause traffic issues but the AppleTV is clearly showing that it is connected to the network with a really strong signal although it is unable to connect to the internet, update or connect to itunes. It doesn't even recognise my Apple ID. In it's current state it is completely useless.


    In terms of the exact position of the AppleTV. I have this next to the TV connected via HDMI cable. There are no other electricals directly next to the AppleTV except the TV which it needs in order to work. However, there is a dvd player, a digi-box (freeview) and a Wii contained within the same cabinet but these are well separated from the AppleTV and do not have any network connection. As I say the only electrical equipment that the AppleTV has direct contact with is the TV and nothing else. Again this set-up was the same when the original AppleTV worked as it should and at which stage I was able to utilise Home Sharing. I will of course take a look through the other articles that you've recommended and I thank you for taking the time to respond to my issue. Do you or any other kind soul out there think this might be something else based on the above info? As before any help would be greatly appreciated.



  • RugbyStar Level 1 Level 1

    Still experiencing problems. The Apple TV is still unable to load anything with the buffering symbol going round and round. It does eventually load Netflix up but even then the pictures for the movies are still downloading. It's as if the connection is too slow but other Apple products such as my iphone and ipod touch are able to connect to the same network without any problems. Just to confirm even when Netflix has loaded up it is still unable to play a film with the screen hanging with the buffering symbol going round and round. It's really infuriating. The Apple TV is useless at the moment as I'm not able to do anything with it. I've checked the settings and everything looks to be correct however I'd just like to correct something within my original post when I checked the details within the About section of the AppleTV settings it was the 'Activation' that was showing as failed and not the intialisation as I'd previously said. Not sure what this activation failure is referring to and whether this is the source of the problem. If it is what exactly do I need to do in order to correct it? Does anyone have any answers to this problem? Has anyone been experiencing anything similar? Would like to here from anyone whose experienced similar problems and what if anything they did that helped.



  • Winston Churchill Level 10 Level 10
    Mac OS X

    All I can suggest is that you try it at another location to rule out network problems. Out of interest, what IP address has it been given by the router.

  • PeauDeSoie Level 1 Level 1

    Hi There,

    I am having the identical problem as you, RugbyStar!! My network is clearly displayed under the General setting, with a full signal, but I am unable to connect to the internet!! When I first set up Apple TV, it worked fine....this was 10 days ago. Recently, it started losing it's signal in the middle of a film, and I would have to restart. Apple told me that I was probably on a channel with too many other clients, so I changed the channel on my router. That did nothing. Next it was suggested that my Modum was outdated, so I replaced it with a new model. It did nothing. Apple tried to have me connect my Apple TV to my laptop to reboot the system, but although Apple TV was visible in the laptop devices...it would not connect to iTunes. Apple told me it was probably a hardware issue within the device itself so today I went to Apple and after a long wait, exchanged the Apple TV unit for a new one. Just got home now, and connected the new box... And it is doing exactly the same thing!!! It will not connect, even though it shows my network with a strong signal!!! Now, of course tomorrow is Thanksgiving, so no assistance with this until at least Friday!

    Crazy annoying!