6 Replies Latest reply: Jan 29, 2015 2:18 PM by PeterBreis0807
Jmar Gambol Level 1 Level 1 (5 points)

Since I like to output manuscrupts to ePUB for reading in iBooks, I prefer to have typographical quotation marks—smart quotes—on. Pages 5's parity with Pages for iOS made it more difficult to globally search-and-replace ordinary quotes (inch marks) with smart quotes from the Find & Replace dialog. (The crippling of the Find & Replace even more is a subject for another rant ) But it seemed Pages 5 has the answer in its Show Substitutions submenu.


In the help, it says:

  1. Choose Edit > Substitutions > Show Substitutions (the Edit menu is at the top of your computer screen).
  2. In the Substitutions window, select the Smart Quotes checkbox.
  3. Choose a quotation mark style from each of the pop-up menus.
  4. Click a button to replace all occurrences of quotation marks in the document, or just in the selected text.


Which I thought means if I have straight quotes and double-dashes, hitting "replace all" or "replace in selection" will convert them to curly quotes and em dashes.


But it doesn't.


So far as I can tell, nothing happens.


Knowing that a lot of this is actually shunted into OS X's Text preferences, I tried making sure the Text preferences were set properly, quit all apps, restarted, opened Pages, opened a new document, typed in a test sentence with straight quotes and double-dashes, and then did the above Help procedure.


Nope. Still nothing happens.


I hope this is a bug and not another "refinement". I reported it as a bug.


This wouldn't matter on documents edited on the Mac, since typing smart quotes and em dashes still work. Moving around from Pages on iOS, however—where getting to the correct quotes is a bit of a chore—I liked being able to do a global "smartify my quotes" on Pages on Mac. But like I said, can't seem to do that anymore—and the Help seems to say that I should, using the Substitutions dialog.


Have you gotten this to work? Have I misinterpreted what the Substitutions submenu and dialog is supposed to do?

MacBook Pro with Retina display, Mac OS X (10.7.4)
  • fruhulda Level 6 Level 6 (15,120 points)

    Have you set the smart quotes in the system Preferences >Keyboard > Text. The new Pages relies on system setting more than before.

  • paulfromshoreline Level 1 Level 1 (0 points)

    My sense this is a bug in Pages. The procedure you're describing works a treat in TextEdit, but repeated with the exact same text in Pages does nothing.

  • Jmar Gambol Level 1 Level 1 (5 points)

    As of 5.5, this still doesn't work. The Substitutions window shows up, but its title bar is still grayed out, indicating it's not activated, and the function to convert dashes or quotes still does nothing. Sigh. Already sent feedback via the Send Pages Feedback menu item.

  • the-navigator Level 1 Level 1 (0 points)

    I had a similar problem.  When typing fractions, eg 1/2, the substitution did not work.  This was because I was using the fraction immediately after a number, for example, two and half (2½).  Pages didn't recognise the need to substitute 1/2 with ½ because I had not typed a space between the 2 and 1/2.  As soon as I typed 2 space 1/2 Pages implemented the substitution as follows 2 ½.  If you prefer no space between the number and the fraction you can delete it after the substitution has been made.

  • davescz Level 1 Level 1 (0 points)

    A workaround, of sorts. After pasting large amounts of text (full of straight quote marks and straight apostrophes) into Pages documents I, too, have tried and tried to convert to smart quotes, only to be frustrated. (I also spent quite a bit of time on the phone in November 2014 with a Pages tech support person, and he could not provide an answer. He promised to pass this on to the Pages team. This is where you start holding your breath...) Here is my workaround until (if) Apple fixes this. You are going to groan when I say this, but if you have Word on your Mac simply copy and paste the text into Word. (Perhaps you may find another word processor that does the same thing.) There the conversion is quick and simple. Then paste it back into Pages. I happen to have an older copy of Word because I was forced to start using Pages when the version of Word would not utilize the Retina display on my new Power Book an everything was fuzzy.

  • PeterBreis0807 Level 7 Level 7 (32,860 points)

    Hardly necessary and a really awkward solution.


    1. Use Pages '09




    2. Search and replace on space" and "space for the curly quotes.