Previous 1 2 3 Next 41 Replies Latest reply: Jul 10, 2015 8:34 AM by Che-DuBois
janjerick Level 1 Level 1

Hello,

 

I recently downloaded GarageBand 10.0.0 and Logic Remote for the iPad, the thing is, it only stays connected when:

 

(1) GarageBand does not have any open projects or

(2) When the project is about to be closed, as the user is being prompted to: "Don't Save", "Cancel" or "Save"

 

I know Logic Remote connects to the Mac I am using since it tells me to open a project first, then right after I open a project,

logic remote always tells me

 

"The connection to <computer name> was lost. Please select the Mac you wish to connect to"

 

The app then tries to reconnect and reconnect, but nothing happens.

 

By accident, as I tried to close the project in the Mac, whose snapshot is attached in this posting:

 

 

the app then is able to remotely control garageband...

 

When I cancel the project closing, the problem persists...

 

This actually renders the app useless...

 

Have you guys encountered this situation.?


iPad (3rd gen) Wi-Fi, iOS 7.0.3
  • janjerick Level 1 Level 1

    for some reason the image was not inline with the text above... I can't fit in the image in here because of its size.

    I hope someone can help me with this.

  • seattleguitarman Level 1 Level 1

    I ran into this too on trying this morning.  Found another post then headed off to work and tried it tonight.  Trick is to go into system preferences in the privacy/security area then pick firewall and choose the firewall options.  Need to turn off the "block all incoming connections" checkbox.  I also checked the one down below to allow signed applications...and left the one below it checked....tried again and it worked.

     

    I did find that on a trial of the touch instruments from ipad to garageband 10 in Mavericks...the lag was pretty noticeable...that'll be my next thing to figure out.  Key thing though is now being able to use the ipad from across the room to record/rewind and that sort of cool control.

     

    Hope this helps fix things in your situation.

  • ronfromstittsville Level 1 Level 1

    I am experiencing the identical problem as janjerick.

     

    To reproduce the problem:

    1) On iMac OS 10.9, Launch Garageband 10.0  - choose Empty Project.  Created a "software instrument" track.

     

    2) On iPad, Launch Logic Remote 1.02  and select the hosting iMac computer.

     

    3) Connection seemed to come up on the iPad, then prompty goes away.  "The connect to <host> was lost".

     

    4) The connection doesn't come back... UNTIL I try to dismiss the project on iMac Garageband. The instant I get the "Do you want to save the document" dialog -- Boom!  The Logic Remote connection is established.  And then the Logic Remote seems to be able to control Garageband (while the 'Do you want to save the document' dialog is in the foreground on Garageband.).   But as soon as I try to go back into a project on Garageband, the connection is lost.

     

    Here's the kicker: I also have Logic Pro X on the same iMac and the "Logic Pro" remote app is working PERFECTLY with that.  But as soon as I flip back to Garageband, no go.

     

    Anyone else?

  • mj4man Level 1 Level 1

    Exact same problem here. Newest version of Garageband. Late 2011 iMac. iPad 4th generation.

     

    when I initially connected a dialog appeared on mac and I accepted the connection to logic remote. but as soon as I start a project I lose the connection.

     

    If I open the "save as" dialog box, the app immediately connects and can play, but as soon as "save as" dialog is dismissed I lose the connection again.

     

    Definitely a software issue.

    Very annoying as the software obviously has no problem working as far as functionality AS LONG AS "save dialog" is open.

  • putrabiz Level 1 Level 1

    Same problem... please someone help us...

  • seattleguitarman Level 1 Level 1

    read the above post...turn off the firewall and I think you'll find it will connect.  Had this issue with both Logic remote and more recently Touchable...both getting jammed up by the firewall.

  • mj4man Level 1 Level 1

    No. Firewall on or off, same problem. Even tried connecting via bluetooth.

  • ronfromstittsville Level 1 Level 1

    Hi seattleguitarman.

     

    Thanks for the advice.  I have checked that my Firewall is completely OFF.  And the problem still exists. 

     

    One would think that communication between the iPad and the Mac is actually working, given that the iPad Logic remote is actually working as long as the "Save As" dialog is up on the Mac screen.  It really is odd.

     

    For a bit more info: My Mac is connected directly to an Apple Base Station Extreme via Ethernet.  The iPad is communicating wirelessly to that same Base Station... yes, I've fully embraced the Apple ecosystem ;-)

  • seattleguitarman Level 1 Level 1

    Have you instead tried Bluetooth between the two where the firewall is off?  I was using that mode w logic remote. For touchable I picked create network and named it something recognizable and made a password.  Then on iPad went to wifi setting and picked that instead of my AirPort Extreme...rendering both not connected to Internet but both connected to each other...and firewall off on MacBook.

  • Hepcat70 Level 1 Level 1

    I have the same problem and have tried all the suggestions in this thread to no benefit. (changed firewall settings, linking through wifi or bluetooth).

    Has anyone fixed this issue?

  • Hepcat70 Level 1 Level 1

    One additional thing I forgot to say. Logic remote app work beautifully from same ipad to same MPB when running MainStage 3...

  • hoodooh Level 1 Level 1

    I have had this exact same problem.  I called into Apple and spoke with the senior advisor for garageband about it. He was not aware of the problem and had me reinstall everything, nothing worked.  He was going to talk with his engineers and get back with me tomorrow.  In th meantime, I have been experimenting with a few different things and found the problem.  You have to turn off bluetooth on your ipad, then disconnect your wifi on your ipad and reconnect it to wifi.  After that, I was able to connect.  This was driving me nuts so I hope this works for all of you!

     

    Take care.

  • ronfromstittsville Level 1 Level 1

    Hoodooh !  That's it !  I disabled bluetooth on the ipad and then toggled the wireless connection (and then I had to restart the Logic Remote)... and now it works! Woohoo!

     

    Many, many thanks for taking the time to post this!

  • Hepcat70 Level 1 Level 1

    Lucky for you. But this did not work for me...

    Same old problem. Very weird how it connects when GB has the save menu open....

    Let me know if the apple folks find an alternative solution.

Previous 1 2 3 Next