Previous 1 2 3 4 5 Next 210 Replies Latest reply: Oct 3, 2014 6:01 PM by EdSinger Go to original post
  • jjohn3 Level 1 Level 1 (0 points)

    Forums getting little attention from Apple would be a huge missed opportunity for Apple to get feedback on this OS X and other role out issues. Bummer for us if that is the case.

  • fearull Level 1 Level 1 (0 points)

    My issue seems to have solved itself again, I never actually went through all the steps as I said I previously would in my last post, I just didn't have the time to do it that day, each morning since then it has woken up as it should, so fingers crossed it remains this way,

     

    It would appear from the popularity of this post that quite a few people are having this issue, which disappoints me, as you wouldn't normally expect this with Apple, especially for an OS upgrade!!

  • drerocs Level 1 Level 1 (0 points)

    I have a mid 2010 Macbook Pro which originally came loaded with SL. Ever since upgrading to Lion up to the latest Maverick, my macbook has had this problem. It goes to sleep and it will not wake. Screen stays dark and I have to do a hard reset with the power button. It is the most frustrating thing to deal with. I wish Apple would fix this. I know they have to be aware of the problem. Now I have heard for some folks, a clean, fresh install had done the trick but I am leery as too many have said it has not helped.

  • N0L@N Level 1 Level 1 (0 points)

    Ok, I found something that has "fixed" the issue for me. 

     

    A little background, I have spent 3 days wiping and reinstalling and cloning and restoring clones, etc. Both Snow Leopard and Mavericks always had the problem.  This is on my internal SSD drive (Crucial M4 256GB).  Then, I noticed it didn't have the problem when running it from my clone on my external firewire drive. 

     

    I found that changing my hibernate mode to 0 using pmset has fixed the issue.  Now, it doesn't use a sleep image at all and it seems to sleep and wake just fine.  Both Mavericks and Snow Leopard work.  I can set the computer to sleep (instead of never) and I can leave the "put the hard drive to sleep" function turned on (since I still have HDD installed in my optical bay).

     

    It seems that the problem occured when the sleep image was written to the SSD.  I would return to find the mac really hot and the fans blowing full speed, but absolutely no response from the mac.  I don't know if this is the same cause for others having this problem, but you could try this to see if it "fixes" the issue.  I won't go into detail about using pmset.  Just do a google search for "mac hibernate pmset".  Note: that if you "restore defaults" in the engergy preference pane, the hibernation mode is reset as well (although the hibernation mode cannot be changed in that preference pane).

     

    I'm starting to think that I must have done this forever ago when I installed the SSD and only recently updating to Mavericks reset the setting.  That would also make sense why Snow Leopard also did it after a fresh install.  This leads me to believe that its a problem between this SSD and the operating system.

     

    Even though, this isn't a true fix, I'm ok with it since I hardly use my macbook on battery and I don't really care if i lose what i'm working on if the RAM loses power by not having a sleep image to restore from.

     

    Just a sidenote, I'm sticking with my Snow Leopard from now on.  I notice it is way faster than Mavericks on my older 2007 Macbook Pro.

     

    Hope someone finds this info useful.  Cheers to all.

  • drerocs Level 1 Level 1 (0 points)

    I can confirm this method works. Since changing pmset to 0 I haven't had a problem waking from sleep or with the fan constantly running with the screen off. I have tested it for the past three days and nights using different methods that in the past would cause the issues mentioned. Good job and thanks for the tip NOL@N!

     

    Cheers

     

    Dre

  • fearull Level 1 Level 1 (0 points)

    Well, after a week or so of waking up normally in the mornings, the issue came back again this morning,

     

    I hit return on the keyboard, and the screen came on, however it stayed black, and i very briefly saw the cursor,

     

    It is very frustrating now as every morning, it's a wait and see type thing whether my very expensive iMac will wake up or not.

     

    Apple. Sort this out, or I'm going back to Mountain Lion.

  • vido Level 1 Level 1 (0 points)

    This method seems to work for me on my old MacBook Pro 15'' late 2007, now fitted with a 256 GB SSD hard disk (Kingston SH100S3240G).

     

    Just a small remark: I have noticed that changes in the pmset hibernate mode are effective ONLY if they are performed while there are not conditions preventing the system to enter sleep/hibernation mode. One of the most common reasons is that Time machine backup is running. So, BEFORE attempting to changhe pmset hibernate option it is better to stop any backup operation and to deactivate automatic backup (it can be reactivated after pmset hibernate has been set).

     

    Many thanks to N0l@n!!!!

  • BobHassinger Level 1 Level 1 (0 points)

    An update.  I have been going through various testing and experiments looking for clues.

     

    So far I don't think I have seen the problem when I have both Computer and Display set for Never sleep in Energy Saver prefs (Note I hav a UPS connected and I get two tabs there - Power and UPS.  Both have those two settings and I set them all to Never.

     

    What I see seems most likely to be some sort of software conflict and I am looking in that dieection.

     

    I have gone to a Safe Mode boot and normal Energy Save sleep settings to try to eliminate as much software like extensions or utilities, etc that run behind the scenes as possible.  It will remain to be seen if that keeps it from happening.

     

    Tonight I had a hot idea that about where to look.  I noted this first a few days after I upgraded to !0.9 Mavericks.  I went back and found I had installed i1ProfilerD2LionEditionfor an xrite display calibrator a few days after the 10.9 install.  It seemed to work OK.  But thinking back I think it was right around that time that I started to see this no wake issue.

     

    It turns out Xrite has abandoned support for the calibrator in question and this software.  The software distributed with the product stopped working with Lion (it was a legacy app that Apple rem,oved the support for in Lion) and Xrite issued this version.  But they have not updated or maintained it and now if you look in the right place on their web site you find that they say it is not supported, and not compatible with Mavericks (as well as not being tested on the intermediate OS version(s)).  I have asked them about an uninstaller or removal instructions but so far no help.

     

    The problem in this case is that if you were on Lion and installed it then moved on to later versions of OS X it would continue to be there and continue to launch at system startup.  Nothing would alert you to Xrite's non-support, and there is nothing to alert you to noncompatibility with Mavericks.

     

    It would be very interesting if anyone else with the problem happens to have the same software.  But the more likely answer for anyone is the possibility of any number of old software installs remaining around and becoming incompatible with new OS versions.  It can be a real challenge to track down a culprite.  Particularly if the symptim is not easiely reproduced.  Each time I make a change I have to wait a few days to see if it is OK or still broken.

  • N0L@N Level 1 Level 1 (0 points)

    Thanks drerocs and vido.  Glad to hear the method is helping others.

     

    Vido, that makes sense.  I don't use Time Machine or similar auto backup so I didn't think of that.

  • jjohn3 Level 1 Level 1 (0 points)

    I also have a x-rite Colormunki Display  calibration device. I made the jump from 10.6.8 Snow Leopard to 10.9 Mavericks.  I found this link associated with the i1Profler.

     

    http://www.xrite.com/product_overview.aspx?ID=1397&Action=support&SupportID=5727

     

    There is four items under OS support one being for Mavericks. Link above.

     

    http://xritephoto.com/ph_product_overview.aspx?action=support&id=1513

     

     

    I will see what more I can find out.

     

     

    On another note my audio out problems have disappeared… I have no idea why.

  • SeiFy Level 1 Level 1 (0 points)

    I have been having the same issue for weeks and have tried all fixes noteds in this post.

     

    My hibernate mode is set to 0 as I have a mac mini.  I just double checked to be sure.

     

    Still having the issue after attempting all fixes noted here.  I even reinstalled Mavericks.

  • kresnamurti Level 1 Level 1 (0 points)

    hi N0L@N.. can you tell me where to set 'changing my hibernate mode to 0 using pmset'? i am totally newbie in mac after decades with windows. this mac book air (mid 2013) is my first mac and after upgrading to mavericks the unwaken symptomps occured so often. thanks in advance for your answer.

  • vido Level 1 Level 1 (0 points)

    Dear kresnaurti,

    here below the procedure (sorry N0L@N for answering, but having experienced some frustration with this problem I think that a quick anser to kresnaurti will help him/her...):

     

     

    1. open your "Application" folder, then the "Utility" folder, and search for the "Terminal" application (here below its icon. Note that its name is in Italian, in my case). Double click on it to launch the Terminal application

    2. In the terminal window, at the prompt (= immediately after user$ ; where "user" is the name you selected to login in Mac OSX) digit the following code (or just copy/paste it) and then hit return to check your current hibernation mode:

     

    pmset -g | grep hibernatemode

     

    In your case, you should get the following message:

     

    hibernatemode        3

     

    3. To change the hibernate mode to "0", digit the following code and then hit return key:

     

    sudo pmset -a hibernatemode 0

     

    You will be prompted to insert a password. Use your user password (if the user has administrator privileges, as it should be). NOTE: during password insertion, no charachters (neither dots, asterisks, etc.) will be displayed, so you will not be aware of how many keys you have already pressed...do not worry: if you make a mistake the system will just ask you to repeat the password.

     

    4. To check the hibernate mode has been correctly changed, follow again the instructions indicated at step 2.


     

    IMPORTANT: if you restore the default values from the Energy Saver window in System Preferences, the hibernate mode will be restored also to 3. In this case, just repeat the procedure.

     

    IMPORTANT (again...): BEFORE changing the hibernate mode, be sure that your system is not backing up using Time Machine (to be sure, temporarily disable Automatic Backups). In any case, you will not "damage" in your system...the change of hibernate mode will simply not occur.

     

    Cheers

  • kresnamurti Level 1 Level 1 (0 points)

    wow, great tutorial vido, thanks a lot. i already made the hibernate mode to 0 as explained, thanks again. now it's my time to unplug the charger and let the mba runs on batteries.

     

    i will inform you guys later whether this mode is working or not for my mba. many thanks from me.

     

    i am a man, by the way

  • bscardin Level 1 Level 1 (0 points)

    I am seeing what appears to be the same problem on a mid 2011 27" iMac.  After upgrading to Mavericks there have been several occasions where the iMac display will not wake up.  The machine is still on and I can do several things remotely (via ssh, itunes share, etc.)  Here is a rundown of the symptoms:

     

    Display is completely black and will not wake up.  I have a hot corner to sleep/wake and that does not work.

    Pressing caps lock cycles the green light on the keyboard.

    Volume up/down does NOT make the "popping" sound.

    I can connect to the iTunes library from an Apple TV.

    I CANNOT connect via Screen Sharing from another MAC nor from iPad iSSH VNC.

    I can remote in to a terminal via ssh from another computer.

    When remoted I can issue a "say hello world" and I hear hello world spoken from the computer.

    If try to shutdown or reboot the machine from ssh I get kicked out of ssh and the computer quits responding to network queries but does NOT power off.  Ultimately I have to hard reboot by holding the power button down.

     

    I am running a TON of things on the iMac: VMware, AirFoil speakers, Google Drive, DropBox, Aperture, EyeTv, iTunes sharing, Remote screen sharing, Remote file sharing, remote terminal (ssh), etc.  However I have run all of these things prior to the Mavericks update without a single instance of this ever happening in 2 years.  Now it happens ~weekly.

     

    Not cool.

Previous 1 2 3 4 5 Next