Previous 1 8 9 10 11 12 Next 172 Replies Latest reply: May 26, 2015 7:50 PM by Kurt Lang Go to original post
  • timbearcub Level 1 Level 1 (0 points)

    I had the same problem, and I started on 10.9.2 - I've never had earlier versions on this computer because I recently upgraded from 10.8.5. So no, new users upgrading direct to the latest version - which I guess is 10.9.2, and definitely had updated fully - have this problem. It must have been something else, because Apple certainly hadn't fixed it on what I installed last week.

     

    But this fix does work! Yay - the long delay was driving me nuts.

  • iching6 Level 1 Level 1 (0 points)

    Mine problem never got resolved regardless of the version I upgraded to.  Workaround doesn't work, either. 

    The symptom happens to all my 3 macs.  Terrible!

  • ADeweyan Level 1 Level 1 (0 points)

    I think it is clear that there are different reasons for the slow open/save dialogue performance. I'm pretty sure for my setup it's that the system insists on accessing my external Time Machine drive in the dialogues. Since the Time Machine drive goes to sleep between hourly backups, the system often has to wake up the drive before the dialogue box will become useable, even though the entire drive is used by the Time Machine backup.

     

    There should be an option to have the system ignore dedicated Time Machine drives for anything other than Time Machine use. Short of that, maybe the dialogues can be written so that they don't have to wait for every device to be ready before becoming functional.

  • KSDenison Level 1 Level 1 (15 points)

    I've tried the fix suggest by Snaggletooth_DE... no help. Any other thoughts?

  • Syncopator Level 1 Level 1 (115 points)

    Snaggletooth_DE wrote:

     

    Working workaround:

     

    Use the following statements in Terminal.

     

    sudo vi /etc/auto_master

     

    In this file comment out /net with #  (#/net .....)

     

    sudo automount -vc

     

    Fixed.

     

    Thanks for posting this fix.

     

    To clarify this for other users, it's important to note that the 2nd line is not a statement to be entered in Terminal. only the 1st and 3rd lines are terminal commands.

     

    In line 2, the phrase "comment out" means "Add the # character at the beginning of the existing text "/net," which will turn that line into a comment (thereby preventing the system from reading that line).  :-)

     

    After doing that, proceed with line 3, which is a terminal command.

  • jerrytech01 Level 1 Level 1 (0 points)

    The auto_master fix worked for me. Thanks guys! I have an older G5 running 10.7.5 and this worked like charm!!

  • Kurt Lang Level 7 Level 7 (34,905 points)

    We'll, it can't possibly be a G5 (which is a PowerPC CPU), but good to hear.

     

    Though I am curious. This was never an issue before Mavericks, 10.9.0 and 10.9.1. Are you certain you're still running Lion, 10.7.x?

  • jerrytech01 Level 1 Level 1 (0 points)

    Mac Pro OS X Lion 10.7.5

  • Kurt Lang Level 7 Level 7 (34,905 points)

    So it's an Intel based Mac Pro, which it would have to be to use Snow Leopard or later. The last G5 tower and its predecessors were called Power Macs.

     

    Interesting that you have the same issue in Lion. I've seen anyone note that in these forums until the release of Mavericks.

  • riteshraja Level 1 Level 1 (0 points)

    Same problem here and modifying /etc/auto_master workaround did not work. Any other workarounds?

     

    Macbook pro early 2013, latest OSX.

  • jerrytech01 Level 1 Level 1 (0 points)

    Actually, as it turns out… my problem was my old hard drive. It was still installed. Once I removed it my problem went away. I got back all my speed.

  • Scraps628 Level 1 Level 1 (0 points)

    I am also still having no luck.  I have a mid-2011 Macbook Air, OSX 10.9.4, and I experience the file system issues with my network drive.  I had a WD MyBook that used to work really well, and then it started having all of these file system incompatibilities with my Mac that it didn't use to have.  Unfortunately, I never even thought the issue might be with my Mac, so I actually just moved over to a Time Capsule this weekend, and only just now have discovered that the problem remains.  I did the auto_master edit, and that didn't seem to change anything for me.  The problem I have is that any modifications to the file structure (e.g., adding a subfolder within an existing subfolder and then moving some files into that) takes a painfully long time to do.  After I've moved the files, then it also takes an even longer time to see what I put into the subfolder.  In short, it seems like any changes to directory structure are being handled in some very ineffecient way, thus meaning you have to wait forever for changes to become viewable.

     

    If anyone has other ideas, I am all ears.  I am pretty annoyed that I sunk time into switching over to a Time Capsule on the assumption that Apple couldn't have had a bug this bad, only to find out that I was wrong.  The biggest irony is that my old WinXP computer used to rip through the folder structures with ease on the MyBook, but my fully updated Air is practically crippled by the same task.

  • Scraps628 Level 1 Level 1 (0 points)

    I have another observation.  When I compare how long it takes to view the contents of a directory in Mavericks, it is clearly a lot longer than it would take a DOS "dir" or Unix "ls" command to do the same.  Could it be that the Mavericks Finder is doing other things at the same time as it is giving me a list of what is in the directory?  For example, could the Mavericks Finder be loading ALL metadata for each of the files into some database or index being built on the fly every time I pop into a new folder, even if I'm not using a view mode where I am asking to see those other bits of metadata?  If so, that might make sense as I generally am using the network drive to navigate directories of my photographs, and they have a lot more categories of metadata associated with them than do Word docs and PDFs (e.g., date of picture, time of picture, aperture, shutter speed, exposure, etc.).  Or, perhaps is Finder trying to load previews of ALL of the files whenever a directory request is made, so that bouncing through the previews takes less time?  I sort of doubt that, because even after a directory listing finally comes up, it seems to churn a bit on each photo before the preview comes up, which I take as an indication that it's creating each preview only after a request is made for that particular file.  Either way, I will say that in old WinXP and even in the newer Windows 7, if you want to view files in a Detailed setting where you can see other metadata (called "Attributes"), it definitely prioritizes giving you a directory listing, and then continues filling in the various selected Attributes one-by-one after that.  Thus, if you want to sort by the date a photograph was taken (as opposed to its modified or created date, which seem to be default attributes that load as quickly (or nearly as quickly) as the filename), or by the photo's dimensions, it might take a few minutes to load in those attributes for a folder of a couple thousand pictures.  But, critically, if you are not planning on using those attributes, but rather, merely want to see how many files you have in that folder, or select them all and load them into a photo viewer, you won't have to wait for the file system to load the file attributes before you get a listing of the folder's contents.  It seems to me like the Mavericks Finder, however, might actually be forcing you to wait until it has loaded all of those attributes. 

     

    Does the foregoing sound like a plausible explanation of the problem to those out there with knowledge of how Finder actually works?  And if so, does that bring to mind any potential settings that could be turned off or any other work-arounds (since the auto_master edit didn't fix the problems I've been experiencing)?

     

    As another point, I will also note that it seems to me that whatever process is going on often seems to continue even after I've left a folder, with the result being that if I bounce in and out of several folders in a short period of time, the Finder gets slower and slower, to the point where even listing the contents of a folder with one file in it can take over a minute.  Again, it seems like Finder is doing something time-consuming in the background whenever you go into a folder for the first time.  Whatever it is, I will echo what others here have said – this is not a small issue.  For certain routine operations, it is excruciatingly slow, and makes the computer almost unusable as a practical matter.  This is not – as others have suggested – a problem that can be chalked up to people just being impatient.

  • Scraps628 Level 1 Level 1 (0 points)

    So sorry.  I totally meant to post this on a different thread that I had been looking at simultaneously, and only just noticed the mistake now.  Please disregard.

  • geraldfromdorchester Level 1 Level 1 (0 points)

    Yikes, running 10.9.4 on three Macs, including a brand new MacBook Pro. Glad to see this thread.

    When I save a file, Microsoft products in particular, but really any, I get 20 - 30 seconds of beachball. Then regardless of the original directory, it switches back to Documents before the beachball ends. Really frustrating.