Previous 1 2 3 Next 195 Replies Latest reply: Apr 13, 2016 3:23 PM by Simon Banton
d60Dave Level 1 Level 1



I upgraded to Mavericks OS over the weekend and everything seems to work ok. The only thing I have noticed is that my when I try to attach a file in Mail the dialogue box opens and where previously files would immediately appear they now take several seconds, maybe as long as five, ten seconds.


I think I've noticed similar behaviour in other applications but Mail is the one I use the most in this way.


Has anyone else experienced this since upgrading to Mavericks?



Regards and thanks,



MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.2)
Reply by Snaggletooth_DE on Nov 20, 2013 10:17 AM Helpful

Working workaround:


Use the following statements in Terminal.


sudo vi /etc/auto_master


In this file comment out /net with #  (#/net .....)


sudo automount -vc



All replies

  • MindFad Level 1 Level 1

    Yep, I am also seeing this‚ in many apps. At first I thought it was just because of the external drives spinning up, but that doesn't seem to be the case. It often takes as long as ten seconds, too. The pinwheel in the bottom left of the dialogue box will go to town and I can click through folders, but no contents will list and default directory icons will stay blank until it's done "loading".


    It also seems that each app I'm using has to go through the process—so it's not like it goes through it once and it's "fired up" so to speak. So it's a little frustrating going back and forth between Photoshop and Illustrator. WIsh I knew how to narrow down exactly what it is!


    I'm on a late 2011 21.5" iMac.

  • d60Dave Level 1 Level 1



    A friend and fellow Mac user suggested the delay could be due to to the system looking across the network for files. I've now turned off file sharing in the sharing panel of the system preferences and there is no longer the delay.


    Does this work for your MindFad?





  • MindFad Level 1 Level 1

    I'm affraid not unfortunately. I have no file sharing on on this machine, so that doesn't seem to be it.

  • cjcj Level 1 Level 1

    Hi Dave,


    I just wanted to chip in and say I'm seeing the same issue too over the last week since upgrading.  Filesharing on or off.


    I get between a 10-20 second delay in file open or save dialog boxes across a range of programs but it's not consistent and I can't seem to pin down what triggers it yet.


    I saw someone else with the same issue here:


    I've just trashed the finder preferences ( and relaunching Finder and will see if this helps and report back.


    EDIT - ok, no it didn't!   As soon as I went to Safari, it spun for 12 seconds.  Went to Mail and tried an attachment and got the same thing.


    On a MacBookAir 13" 2012 model that's blazingly fast, so it's not for horse power or down to disk access.

  • atpyburn Level 1 Level 1

    ****, this is frustrating. i'm having the exact same issue.

    2012 macbook pro 9,1 2.3GHz quadcore 16GB ram 240GB SSD

    no reason for anything to ever take 20 seconds or more to load.

    trashed .plist, repaired permissions, nothing.

    not sure where to go but i've got a few experiments i'm gonna run.

    hope we get to the bottom of this soon.

  • MooshMan Level 1 Level 1

    Anyone solved this issue.  I am going mental here. I probably lose about an hour of working time a day because of this and am starting to drink far too much coffee as a result... (***Medical Bill in the post to Apple***).


    Do Apple read this forum?  We need an updated version pronto

  • HumphreyDavy Level 1 Level 1

    Same here: frustratingly slow population of dialog boxes in all applications. Competely slows down normal work flow. (MacBook Pro early 2011, 256 Gb SSF Samsung, 750 Gb HD in former opitical drive bay.


    Hoping Apple will fix this problem soon.

  • cjcj Level 1 Level 1

    If this is affecting more than just one or two people, then it's best to start to file feedback at this address:



    I imagine the more reports that come through the 'official' door about the same issue, the more it is pushed up the stack, so it's probably the best way to get it noticed.  I've logged it once, but be good if you all did the same.

  • d60Dave Level 1 Level 1

    I spoke too soon. I thought turning file sharing off had fixed it but it seems to have come back.


    I'll fill in the feedback form at the above link.

  • jflow Level 1 Level 1

    Having the same issue here.  Haven't been able to consistently reproduce.  But it is happening is several different apps.  I am running a 2011 13" Macbook with an SSD.  Will update if I am able to narrow this down any more.

  • brilor Level 1 Level 1

    Same issue here. Another thread ( here ) suggested a possible fix by toggling the Show scroll bars option ( System Preferences===>General pane ) between "always" and "when scrolling" but most folks said it didn't help ( but one did ). I've posted a feedback note to Apple but wondering if anyone has posted a bugreport ( rdar ).  btw/fwiw: this is on a: 27-inch iMac 3.4 GHz Core i7 quad-core with 16 GB Ram.

  • jorhh Level 1 Level 1

    Absolutely the same thing happening on my MacBook. None of the suggested "fixes" helps. The issue always returns after a reboot - or an extended "nap".

    This is getting really annoying.

  • St. Clair Software Level 1 Level 1

    I'm the author of Default Folder X - an enhancment for Open and Save dialogs - and have been fielding reports from my users complaining of this same problem in Mavericks, asking if my software's causing it. Are you folks running Default Folder X, or are you experiencing the same delays without it?


    I've done a bunch of performance testing and cannot for the life of me get Default Folder X to cause any additional delays - however, I'm seeing some fairly long waits with Mavericks on its own, and want to confirm that you folks are seeing the same thing.


    For what it's worth, it seems to happen for some folders the first time you access them, but after their metadata gets into the disk cache, response is almost instantaneous. If you experiment with a folder on an external disk drive, you'll find that unmounting (ie. ejecting) the drive and then remounting it will reset this behavior and the first access to the folder will be slow again.

  • MindFad Level 1 Level 1

    I am not running Default Folder, but I will experiment further.

Previous 1 2 3 Next