5 Replies Latest reply: Nov 10, 2013 9:19 AM by SkipLesion
Jacob Magnusson Level 1 Level 1 (0 points)

With Mountain Lion I had no problem with the printer. In 10.8 I installed it by going to Printers & Scanners, clicking the plus sign and then clicking Samsung CLX-6220 Series. Then Apple software update would install the required driver automatically and printing and scanning would just work.

In Mavericks when I click on my printer under the popup that clicking the plus sign opens up, I get the following message:


Screen Shot 2013-10-28 at 15.54.44.png


Clicking "Use Generic" works, but only with printing. Clicking "Open Scanner..." gives me the following:


Screen Shot 2013-10-28 at 15.56.05.png


I've tried installing the drivers from Samsung's official web site (Samsung_CLX-6220_Series_PrinterDriver.zip and Samsung_CLX-6220_Series_MACScanner.zip). But then printing would not work, only scanning.


Any help would be greatly appreciated!

MacBook Pro with Retina display, OS X Mavericks (10.9)
  • sterling r Community Specialists Community Specialists (5,970 points)

    Hey there Jacob,


    It sounds like your printer is not functioning correctly after having updated to Mavericks. I was researching what is happening and found this article to help troubleshoot what is going on named:

    Troubleshooting printer issues in OS X


    1. Make sure that the printer is powered on, has ink / toner, and that there are no alerts on the printer’s control panel. Note: If you cannot clear an alert on the printer's control panel, stop here and check the printer's documentation or contact the manufacturer for support.
    2. Ensure the printer is properly connected to a USB port on the Mac or AirPort base station / Time Capsule. If the printer is a network-capable printer, make sure that it is properly connected to your home network.
    3. Use Software Update to find and install the latest available updates. If an update is installed, see if the issue persists.
    4. Open the Print & Scan pane or Print & Fax (Snow Leopard) pane in System Preferences.
    5. Delete the affected printer, then add the printer again.

    If the issue persists, try these additional steps:

    1. Reset the printing system, then add the printer again.
    2. If the issue still persists, reset the printing system again.  Download and install your printer's drivers. Then, add the printer again.
    3. Contact the printer vendor or visit their website for further assistance.


    Thank you for using Apple Support Communities.



  • Tony T1 Level 6 Level 6 (8,830 points)

    I'm also having trouble with my scanner (an HPc3180)

    I have the scanner set up as a shared scanner on my home network.

    Image Capture worked fine with OS X Mountain Lion, but no longer works with OS X Mavericks.


    Image Capture cannot "find" the shared device.

  • uthamre926 Level 1 Level 1 (0 points)

    Jag har problem med min scanner HP Scanjet 4890 efter det jag graderade upp till Mavericks. Följande text kommer upp när jag försöker spara det scannade dokumentet: "Ett fel uppstod när filen sparades eftersom det inte gick att skriva till den. Kontrollera att filen inte är skrivskyddad i egenskaperna för filen."

    Jag har försökt använda bildinsamling, men scannern tycks inte vara ansluten, trots att att det går att scanna (men inte spara dokumentet)


    Björn Karlsson

  • panta7 Level 1 Level 1 (0 points)

    PROBLEM SOLVED: same problem with CLX-2160. I called Samsung and they said me there is not available driver right now. So I tried "VueScan" and my scanner works. VueScan in a scanner software.

  • SkipLesion Level 1 Level 1 (0 points)

    I had the same problem with my Samsung SCX-4200 which is no longer available under Image Capture, although it still prints fine.

    VueScan is very pricy. I installed ScanThru from Samsung and then found I could scan using GraphicConverter - I've only got version 6.7.4 but it works fine.