Previous 1 2 3 Next 319 Replies Latest reply: Aug 19, 2015 7:13 AM by neongrau Branched to a new discussion.
HalexPereira Level 1 Level 1 (0 points)

Since updating my 13" mid-2013 MacBook Air to Mavericks, there's this issue that's been happening when I wake the computer up from sleep. A proccess called kernel_task uses 100% CPU (a whole core) and hangs there until the computer is restarted. This doesn't make the computer unresponsive, but it kills battery life.


So far, I've tried the following:


1. Resetting SMC, NVRAM and PRAM: no effect.

2. Safe Boot: the issue doesn't happen.

3. Deleting old apps/plugins: issue persists.

4. Closing all apps doesn't solve issue after it takes place.

5. Repairing permissions: no effect.

6. Apple Diagnostics: no issue found in hardware.

7. No kernel extensions from third-parties are installed (there are 120 kext, according to Terminal, but they all come from Apple).

8. Everything is up to date.

9. Only external plugin installed is Flash.


Given these, I reckon it's something software-related. Any tips on solving this would be welcome — things to look for in Console logs would be greatly appreciated.

MacBook Air (13-inch Mid 2013), OS X Mavericks (10.9)
  • twinn888 Level 1 Level 1 (0 points)

    I also have this issue on the new Macbook Pro Retina 13. Only a restart would help. Its killing battery life and annoying to restart after sleep.

  • espressodre Level 1 Level 1 (5 points)

    I'm in the same boat. No issues before installing Mavericks.


    I did the same tests, even disabled the 3rd party kext I had (pace driver, related to some vst plugins I have) with no luck.


    I ran sysdiagnostics and can see the following interrupts, taken from powermetrics.txt:


    ****  Interrupt distribution ****



    CPU 0:

              Vector 0x49(MacBookAir6,2): 31.67 interrupts/sec

              Vector 0x92(IGPU): 408.07 interrupts/sec

              Vector 0x96(HDEF): 216491.54 interrupts/sec

              Vector 0x98(ARPT): 11.06 interrupts/sec

              Vector 0x9e(SSD0): 25.10 interrupts/sec

              Vector 0xdd(TMR): 367.54 interrupts/sec

              Vector 0xde(IPI): 161.86 interrupts/sec

    CPU 1:

              Vector 0xdd(TMR): 32.17 interrupts/sec

              Vector 0xde(IPI): 56.18 interrupts/sec

    CPU 2:

              Vector 0xdd(TMR): 934.68 interrupts/sec

              Vector 0xde(IPI): 1103.50 interrupts/sec

    CPU 3:

              Vector 0xdd(TMR): 165.04 interrupts/sec

              Vector 0xde(IPI): 242.83 interrupts/sec



    I feel like that is not normal(see bold) Anyone know what HDEF is referring to, might help tracking this down.

  • HalexPereira Level 1 Level 1 (0 points)

    This smells like a good lead. Here's a snapshot of when kernel_task is acting up:


    Screen Shot 2013-10-28 at 20.41.12.png


    For comparison, here's what's going on when everything is normal:


    Screen Shot 2013-10-28 at 20.40.43.png


    Now, what the heck is (HDEF)?

  • espressodre Level 1 Level 1 (5 points)

    Hard to find anything concrete, but found some references to it on and tonymacosx86 which seem to indicate that it's related to handling the inbuilt audio device - AppleHDA.kext is the kernel extension responsible (/System/Library/Extensions/AppleHDA.kext/)


    Google search results


    Might be entirely wrong though!

  • HalexPereira Level 1 Level 1 (0 points)

    Regarding what espressodre said, do you have a headphone connected when this issue comes up? I have an old Apple In-Ear always connected. Might try to see what happens if I pull it out.


    It's interesting to note that Safe Boot disables sound, so it might be related, after all (I would never have guessed, though).

  • Stan_ Level 1 Level 1 (0 points)

    I hope Apple does something about this. The bug is definitely there. I get the exact same super high number of interrupts for HDEF after waking up on OS X Mavericks. Mid-2013 Macbook Air 13". It's not what I paid for, Apple!

  • miwelc Level 1 Level 1 (0 points)

    Hi guys. I was experiencing exactly the same issue, after sleep kernel_task always used 100% cpu. While reading HalexPereira post I realized I was using earphones! I recreated the problem and then fixed it just unplugging the earphones, closing the lid and opening it again... The problem must be related with AppleHDA for sure...

  • Stan_ Level 1 Level 1 (0 points)

    I'm not using any headphones btw and I'm sure there is no reliable way of fixing it even temporarily. It's a complete mess this one, at least for me. Fix it, Apple, now! Why push out an OS X update which breaks things for God's sake huh? I'm not a darned beta tester.

  • HalexPereira Level 1 Level 1 (0 points)

    I feel your pain, Stan_.


    Until further investigation, I advise sending bug reports to Apple with this info and a link to this thread. A close friend started experiencing this same issue, so I guess it's not a random problem.


    Let's document the issue, send reports and hope for a fix in a 10.9.x update.

  • Stan_ Level 1 Level 1 (0 points)

    One more thing that would confirm that something is wrong with the HDA driver - today the sound stopped working without any apparent reason. The audio enable/disable and volume keys on the keyboard show a greyed out HUD on the screen. But the kernel_task issue on wake up is gone!!! Now I think I'm not gonna restart it, hehe I prefer it without sound and without kernel_task lol.

  • IE_Armand Level 1 Level 1 (5 points)

    I have the same issue happening, kernel_task ramps to 100% and only a restart will fix it. Seems to only happen after my MBA (mid-13) has had teh lid down and comes back from sleep.


    I do use headphones but I have not nailed it done to that fully. I am also getting an issue where sound will competly stop if the system goes into deep sleep.

    praying for a fix soon...very very annoying.

  • HalexPereira Level 1 Level 1 (0 points)

    This doesn't sound good (pun not intended). If things here escalate to this, I won't have any option other than taking it to technical assistance (we don't have Apple Stores in my country).


    The addiotional evidence that things related to sound might be awry in Mavericks is interesting, though. Keep us updated on how things evolve, Stan_.

  • kanedaboy Level 1 Level 1 (0 points)

    I have the same issue. But for me, the weird thing is. It happens only when I keep my headphones plugged in. WHen i remove my headphones, it stabilizes i.e Kernel_task goes back to using just 4-5% CPU. I resetted PRAM SMC etc but to no avail. Now I dont feel like using my headphones a lot because of this when I am travelling because battery life reduces to 6 hours

  • Cyber Wu Level 1 Level 1 (0 points)

    Exact same problem for me. And I unplug the headphone, sleep, then wake up, it's gone!

    I really hope apple can solve this quickly.


    ****  Interrupt distribution ****



    CPU 0:

              Vector 0x92(IGPU): 1241.09 interrupts/sec

              Vector 0x94(XHC1): 71.54 interrupts/sec

              Vector 0x96(HDEF): 216026.79 interrupts/sec

              Vector 0x98(ARPT): 20.87 interrupts/sec

              Vector 0xdd(TMR): 460.07 interrupts/sec

              Vector 0xde(IPI): 469.01 interrupts/sec

    CPU 1:

              Vector 0xdd(TMR): 60.61 interrupts/sec

              Vector 0xde(IPI): 227.55 interrupts/sec

    CPU 2:

              Vector 0xdd(TMR): 372.63 interrupts/sec

              Vector 0xde(IPI): 1658.43 interrupts/sec

    CPU 3:

              Vector 0xdd(TMR): 185.82 interrupts/sec

              Vector 0xde(IPI): 763.14 interrupts/sec

Previous 1 2 3 Next