Previous 1 2 3 Next 30 Replies Latest reply: May 26, 2014 2:54 AM by gioloi
JamesMac Level 1 Level 1 (15 points)

I just started using 6.0 after upgrading to Mavericks, with a new presentation.

 

Every few minutes, an alert pops up to say that the document "...could not be autosaved. The file has been changed by another application. Click Save Anyway to keep your changes and save the changes made by the other application as a version, or click Revert to keep the changes from the other application and save your changes as a version."

 

I haven't opened Keynote on any other machines or devices, or made any changes elsewhere. I did originally check the 'documents' box on iCloud's setup preferences, so it could sync across devices. Thinking this might be the culprit, I have unchecked it - but the error keeps coming.

 

This must be an embarassingly obvious cloud/keynote newbie error. Does anyone have any suggestions?

  • Kalsta Level 1 Level 1 (25 points)

    I'm having the same thing with the new version of Numbers, which I also just started using after upgrading to Mavericks. After a bit of Googling I can see that we're not the first—it's been affecting users since Lion it seems—but so far I haven't stumbled onto the solution, or found out what is causing it. But if I do, I'll let you know! It's pretty annoying.

  • JamesMac Level 1 Level 1 (15 points)

    I found a solution that seems to have worked for me, from another post in the community:

    https://discussions.apple.com/message/22703496#22703496

     

    Basically, the culprit was in Fontbook: a bunch of duplicate and/or corrupted fonts. The fix involved opening fontbook, selecting all, validating and deleting miscreants - and then emptying the trash and rebooting for good luck.

     

    I don't understand why the problem would be described as another app making changes (unless it was fontbook working in the background). But I haven't had another alert (yet) in Keynote. I have no idea whether the same issue would apply to other iWork apps, but it might be worth a try. So might shaking some chicken bones and chanting.

  • Kalsta Level 1 Level 1 (25 points)

    That's awesome to hear this worked for you! After my last comment, I too found that thread. Normally I don't even use Fontbook—I use FontExplorer X Pro to organise all my fonts. That warns me if I try to turn on a duplicate font. But hearing that this has worked for you has given me some extra incentive to look for font problems. Thanks for taking the time to come back and post.

     

    Yeah, it seems like a crazy kind of alert if it's related to font issues. Looks like something Apple needs to fix. I often submit feedback via this page when I come across things like this: http://www.apple.com/feedback/macosx.html

  • davidepope Level 1 Level 1 (0 points)

    Just started experiencing this problem, too, but only on a newly-configured Retina Macbook Pro. I was not experiencing this problem on my previous Macbook Pro for the 5 to 7 days I had been using Keynote 6 (build 1473) on Mavericks.

     

    One thing I tried was to "pause Dropbox syncing", and the hour or so that I had it paused, this dialog no longer seemed to appear. When I turned on Dropbox syncing again, the dialog returned.

     

    Are any of you using Dropbox with the affected files?

     

    -- David

  • davidepope Level 1 Level 1 (0 points)

    Oh well, it's not Dropbox; the error happened again today repeatedly with Dropbox syncing off.

     

    -- David

  • Kalsta Level 1 Level 1 (25 points)

    Yeah, I'm not using Dropbox syncing either.

     

    Last night I finally got around to cleaning up my fonts a bit. FontExplorer X doesn't let you activate duplicate fonts anyway, but to be on the safe side I've removed all the duplicate fonts Microsoft and Adobe stuff into the /Library/Fonts folder. I'm busy with other stuff today, but I'll see how I go and let you guys know if it fixes the problem for me.

  • davidepope Level 1 Level 1 (0 points)

    As an aside, I removed all "duplicate" fonts in Font Book (~45 of them) and it didn't change anything.

     

    -- David

  • davidepope Level 1 Level 1 (0 points)

    It's now a few days later and I am working with a copy of my original Keynote file plus my Mac has been restarted a couple of times for other reasons, and I am no longer seeing this auto-save error. Not sure what caused the error to stop occurring...

     

    (I suppose it's possible that removing duplicate Fonts solved the problem, but a reboot was required in order for it to take effect?)

     

    -- David

  • Kalsta Level 1 Level 1 (25 points)

    I'm still none the wiser myself. I saw the error yesterday (with Numbers) since cleaning up the /Library/Fonts folder, which was discouraging. But I've not seen it today. Can't remember when I last restarted. If I have anything more useful to report back with later I will.

     

    Well I hope things stay fixed for you!

  • davidepope Level 1 Level 1 (0 points)

    Problem returned in full force today -- autosave errors in Keynote every 2 or 3 minutes. I tried turning off Spotlight and that didn't change anything.

     

    Need to figure out how to turn off auto-save via the command line -- off to search the support forums, but if anyone knows how to do this, please chime in.

     

    Regards,

     

    -- David

  • davidepope Level 1 Level 1 (0 points)

    I have been searching futilely for other people having this problem, to no avail.

     

    Today I noticed that Jean-Louis Gassee (former Apple CEO) mentioned this problem happening with Pages in his latest blog: http://www.mondaynote.com/2013/11/10/new-iwork-another-missed-opportunity-to-set -expectations/

     

    I have also filed this issue at apple.com/feedback

     

    Is there anything else that can be done to get Apple support to acknowledge this issue? Or do we just wait for someone to wander into this thread by chance?

     

    -- David

  • Kalsta Level 1 Level 1 (25 points)

    I suppose you could always take your Mac down to an Apple Store, but that takes a fair investment of time. Leaving feedback at apple.com/feedback/macosx.html is probably the best way to go. I use that page a lot!

     

    It's still happening to me, but only sometimes. I had a Numbers document open for ages, and a couple of times early on it gave me the autosave error, but at other times it just sat there happily in the background. So I'm still clueless I'm afraid.

  • davidepope Level 1 Level 1 (0 points)

    Keynote 6.0.1 released today appears to have solved my autosave problem. What a relief to not be interrupted every 2 to 3 mins with that infernal dialog!

     

    Over and out,

     

    -- David

  • davidepope Level 1 Level 1 (0 points)

    Ack! Literally 1 min after posting the above, the autosave dialog popped up after being gone for the last 6 hours. Someone shoot me...

     

    -- David

Previous 1 2 3 Next