Previous 1 2 3 Next 31 Replies Latest reply: Feb 13, 2014 9:45 PM by Toastedcheesy
Gerry Shy Level 1 (0 points)

I have quite a few rules all of which were created from scratch in Mail under Mountain Lion.  None of them appears to work in Mail under Mavericks.  Any ideas?


MacBook Air, OS X Mavericks (10.9), Mail 7.0 1816
  • noonehasthisname Level 1 (0 points)

    Similar issues here- I create new junk rule in preferences, hit apply, but mail remains in my inbox.

    New junk keeps coming in from same address.

    Some existing rules seem to be ignored, too, but main issue is all the new rules I create do not seem to work.

  • terriergal Level 1 (10 points)

    I have tons of ads that direct to an ad folder for merchants I buy from.  Some of the rules work and some just quit and don't work. Then if I add more rules they also don't work.  It's as if only rules created before a certain random date work now.

  • Randall York Level 1 (15 points)

    I posted elsewhere....

     

    Under ML, I had several rules that divert mail lists into specific folders (On My Mac)… they still work fine, but a new rule I created afterward with the same settings seems to copy (rather than move) the mail into those folders. Even though the rule says to MOVE. That is cluttering up my Inbox.

     

    I have tried to Duplicate the old rule and just change the variable (the rule is based on a word in the Subject line) but it does not change.

     

    Randall

  • patka1024 Level 1 (0 points)

    Same here. Move doesn't work and it's getting really annoying. Any work around?

  • Jimers Level 1 (0 points)

    I have the same issue with Rules.  I try to edit a rule and it won't apply the rule, just stays in my inbox.

     

    I have Mountain Lion on another Macbook Pro and it works fine, but Mavericks on a Macbook Air is having the junk mail issue.

     

    Hope they can get this fixed soon....very annoying!

     

    Jimers

  • rb290169 Level 1 (0 points)

    I am having exactly the same problem.  My rule is simple.  I selected a mailbox and set the rule to mark all messages as read.  I have tried to rebuild the mailbox, delete and rewrite the rule all to no avail.

     

    RB.

  • Bernard Brown1 Level 2 (150 points)

    Exactly the same issue here with Mavericks...rules absolutely will not work any more...VERY frustrating!

  • noonehasthisname Level 1 (0 points)

    Installed update of 11 14 13, mail rules still not working...same issues as above.

  • DCIFRTHS Level 1 (20 points)

    Add me to the list of people having mail rule problems in Mavericks. Any new rules I create are simply not functioning.

  • Barney-15E Level 8 (46,304 points)

    patka1024 wrote:

     

    Same here. Move doesn't work and it's getting really annoying. Any work around?

    Is it not moving the message at all, or is it just leaving a copy in the inbox?

    I am seeing that and thinking it is related to the Gmail problem, but it happens on non-Gmail accounts.

  • jeannette from north truro Level 1 (0 points)

    For me, it is (absurdly) doing *both*. Some messages (it appears to be random) will follow the rule i've set, some won't. FOR THE SAME RULE. The ones that are moved are sometimes moved and sometimes copied. There is no thymre or reason to it.

     

    I do want to emphasize that the above only affects a small number of emails. Most ignore the rules altogether.

     

    Is Apple aware of this problem? Is there a fix on the way?

  • Barney-15E Level 8 (46,304 points)

    Is Apple aware of this problem? Is there a fix on the way?

    They tried to "fix" the Gmail issue, and I'm not sure if that broke other stuff, or if it was always broken.

  • JWKessler Level 1 (0 points)

    This may be a hint. I too have noticed my rules do not seem to work in Mavericks Mail. None of my rules seem move an incoming email into the mail box it is supposed to go to. However, I have one rule that also plays a system sound when it runs. When I get mail from that sender, the sound plays but the message doesn't move. That tells me the rule is being invoked, but the move is broken.

  • Fred Nelson Level 1 (0 points)

    I have the same problem. All of my rules are ignored for incoming mail, even if I create a new rule. Instead, all incoming mail goes into a folder under "Junk" named "On My Mac". Mail that I have identified as junk is put into the appropriate folder under "Junk" and if I invoke "Erase Junk Mail" all of the junk mail is deleted along with all of new incoming mail put into "On My Mac" folder. I can go through the incoming mail in the "On My Mac" folder and manually file the mail before invokeing "Erase Junk Mail", but I spent years refining my rules so that I would not have to spend about an hour a day manually doing what previous versions of the OS would do automatically.

    I read through the discussions of this issue and it seems that the only solution will have to come from Apple. Does anyone know when Apple will fix this bug????

Previous 1 2 3 Next