2 Replies Latest reply: Oct 29, 2013 3:32 PM by Kremfresh
Kremfresh Level 1 Level 1 (0 points)

One of these days my mac suddeny froze while browsing the web, and restarted without wanting me to log into my admin account. only the guest user is successful at this point. So I am having trouble with access to my admin account and have been trying to follow a guide that leads me to restart my Mac in SingleUserMode. However, when pressing cmd+S it leads me to the root area as supposed to, but my keyboard stops responding.

 

The last line I see is :/ root# and a white marker that stands still. I have tried writing, pressing esc, arrows, enter and even the mouse(!) without anything happening. The keyboard was initially plugged to an external USB-extension that went into the machines USB input, but I also tried to plug the keyboard USB directly to the Mac. 

Does anyone have any idea on how to get my keyboard functioning again, so that I can get on with my fixing of the admin issue, please? I am lost for what to search for, and desperately need some input from someone that has knowledge on this field.


iMac (24-inch Mid 2007), Mac OS X (10.6.8)
  • andyBall_uk Level 7 Level 7 (20,490 points)

    I can only suggest trying another keyboard for SUM, although if you can access Guest, it may be possible to su into the admin user, then sudo from there - or to create a new admin account from system preferences - users & groups...

  • Kremfresh Level 1 Level 1 (0 points)

    Thank you for The tips AndyBall_uk!

    I did try another Apple branded keyboard, without success. However, I did manage to creative a new admin user through my guest user account, exploiting the initial admin user account details. Although, my time machine told me my HD hadn't got enough space, so in the end I got hold of a reinstall programme from a friend who also has a Mac, using that to start from scratch again. Doing it right now, and it seems to be working!

    It got me on the trail of something, which I am grateful for!

    Thanks!