13 Replies Latest reply: Jul 19, 2014 9:47 PM by matildsky
nmivey Level 1 (0 points)

Outlook 2011 -  the first was merely a nuisance - it changed my name, title and company in my signature to a red font.  Nothing else, just those three things.  Strange to say the least.


The bigger problem is with my instant search in Outlook.  No matter what I search for (such as my own name) it comes back empty.  I tried rebuilding my identitiy with no luck.  Same goes for contacts.  Any ideas?

MacBook Air (13-inch Late 2010), Mac OS X (10.7.5)
  • gregport Level 1 (10 points)

    Just posting to say that I have the exact same issue with Outlook for Mac 2011 after upgrading to Mavericks:  no search results within Outlook.    This includes the instant search, my pre-existing Smart Folders, etc.


    I've tried rebuilding my Identity using the MS Database Utility and re-building the Spotlight index on my main volume, to no avail.  

  • JoeMontibello Level 1 (0 points)

    I have the same problem, and tried the same things as gregport, with no luck. I then tried another step: I created a new user account on my mac, and within that user opened outlook. Once I connected outlook in that user account, I was able to search my mail no problem.


    But I don't want to do the hard work of figuring out which preferences/settings/etc. that I've built up over a couple of years that I need to recreate in this user account. I haven't had good results with Apple Mail and iCal, but I may not have any other choice. If someone comes up with a solution, please let us know!

  • gregport Level 1 (10 points)

    Well, I've figured out my particular issue, hopefully it will help someone else.


    A couple years ago when I originally installed Office 2011 for Mac, I was not happy with the location that Microsoft chose for storing my local mail database, inside my Documents folder: "~/Documents/Microsoft User Data".    As a result, I moved the "Microsoft User Data" directory into ~/Library/ where I thought it should belong, and created an alias (symlink) in my Documents folder to point at the new location.


    Since I knew that Outlook uses Spotlight indexing for it's search, I had a hunch this was a Spotlight indexing problem.


    This morning I shutdown Outlook (and killed the Microsoft Database Daemon that runs in the background), removed the alias in Documents and moved the "Microsoft User Data" folder back into Documents, after which Spotlight started indexing the folder.   After about 45 minutes, search was working again in Outlook.


    So it appears that with the Mavericks upgrade, Spotlight stopped indexing "~/Library/Microsoft User Data", and by moving my email database back into "~/Documents/Microsoft User Data", Spotlight indexed my email again.   There could be other ways to fix this, but I haven't investigated further at this point.

  • nmivey Level 1 (0 points)



    DId you solution enable you to see search results  in Outlook Instant Search or through Spotlight?  My issue is searching with in the Outlook program itself - no results appear.  They do appear in Spotlight.  I am trying your solution, fingers crossed.

  • gregport Level 1 (10 points)

    It was my Outlook search that was broken, and yes, this fixed it.    I had not even tried searching email directly from Spotlight.


    Just to be clear:   my Outlook search was broken because I had moved my "Microsoft User Data" directory from it's default location in Documents.   The only reason you would try this solution is that at some point in the past you had also moved your "Microsoft User Data" directory.    Otherwise you'll just be breaking stuff.



  • Eric Root Level 8 (44,795 points)

    Try looking/posting in the Microsoft support web site.


    Microsoft Support – Office for Mac


    Microsoft Support – Office for Mac (2)

  • userfromhongkong Level 1 (0 points)

    i cant believe i actually figured out the solution to a major bug.


    i tried everythign - permissions, reindexing, etc etc.


    then i noticed the problem: the file association on emails was wrong. i loaded outlook on 2 machines and it defaults to trying to open email messages in NOTES.


    So the solution for me was really simple: find an email in your User Data folder, and go to Get Info, and change "Open With" to Outlook - and apply the change to all emails.


    Amazingly everythign startted to work instantly and all the problems described here magically went away. Hard to believe its just my issue   

  • JoeMontibello Level 1 (0 points)



    Thanks for posting. This didn't fix the issue for me, but I'm glad to see some folks are still working this problem.


    I've stopped using MS Outlook and gone back to Apple Mail / Calendar. There are still some weird things there, but overall it's working reasonably well. But if someone came up with a(nother) way to fix the search problem, I'd still be super-appreciative.


    Joe M.

  • PlusOn Level 1 (0 points)

    My solution for this issue was to delete the account in Outlook and add it again. After I did that I was able to use Search as usual.

  • kstachowiak Level 1 (0 points)

    Brilliant. I tried so many things, spent so many hours re-indexing, rebuilding, resetting permissions, reinstalling outlook, reinstalling OS, and nothing worked, until this did it.


    Thank you, thank you, thank you.

  • Pickle7661 Level 1 (0 points)

    I tried this as I had moved my identity folder from this location to.  I moved it back using the steps you did and still no luck for me. 


    If you or anyone has any other suggestions please let me know. 


    Also tried adding the folder to the prviacy tab, restarting and removing it and all of the other things people have suggested excepted for checking permissions on indexing.

  • shoegazer4 Level 1 (0 points)

    i tried everything suggested, nothing worked.


    Created a new identity and repaired disk permissions and it started working again

  • matildsky Level 1 (0 points)

    I had imported my contacts from outlook from 2004 to 2011 and have had the same issue for a while - VERY ANNOYING! This is what worked: I exported all of my contacts to my desktop as an .olm, then I got rid of all my old "identities" (.rge) which were in Documents>Microsoft User Data>Office 2011 Identities. Then I restarted my computer. I reopened Outlook, imported the .olm file and everything was searchable. But the folder was a new one called "Address Book Outlook for Mac Archive", so I selected all contacts and put them in "Address Book" (drag and drop). Now it is perfect. I hope this helps someone. This is the first time I have ever posted a success story on a forum, ever.