Skip navigation

Redemption Codes "null" or "already used"

4912 Views 47 Replies Latest reply: Feb 4, 2014 7:29 PM by schoolofluck RSS
  • KTechNE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2013 2:34 PM (in response to FMoryn)

    I have 3 different cases logged to Apple about this issue and havent heard anything back yet, interested to know if anyone else has made any progress with this :/

  • Kristina77 Calculating status...
    Currently Being Moderated
    Nov 20, 2013 2:45 PM (in response to TPinson)

    It took 7 working days but I got a reply and new redemption codes. I did have a case number in my request after spending 20 minutes on hold and 60 minutes working with a rep to set up the iPads. The instructions and process weren't as clear as I wished they could have been.

  • KTechNE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2013 3:18 PM (in response to Kristina77)

    That's a lot of time wasted on hold then, glad you got somewhere with it though, i just wish they would fix these problems with a software update! still no indication when this will happen tho :/

  • Slates26 Calculating status...
    Currently Being Moderated
    Nov 21, 2013 10:40 AM (in response to TPinson)

    I have had the exact same problem.  Using configurator 1.4.2.  Purchased 5 apps, 25 licenses per app and every single one had issues, either (null) or 'already redeemed'. I've tried a few things but can't seem to work around it.  Has anyone found a way to fix it without waiting and waiting for a configurator update? 

  • CRodriguez03 Calculating status...
    Currently Being Moderated
    Nov 21, 2013 10:48 AM (in response to Slates26)

    Hi Slates,

     

    They still have not given any of us a solution yet. Currently all that we can do is inform VPP about the key's that we've lost (Specifically how many) and they will recover those keys. I'm waiting on them to recover keys for a group of App purchases that we placed.

     

    From my experience I'm assuming the issue is how Configurator is handling redeeming keys as it places an app onto an iPad. Somehow or someway more are being redeemed than should be before they are placed on the devices.

     

    Has anyone had this issue in Mountain Lion? I just want to verify since all of our computers have been updated to Mavericks.

     

    Regards,

     

    Casey

  • gavin.kennedy Calculating status...
    Currently Being Moderated
    Nov 21, 2013 11:39 AM (in response to CRodriguez03)

    Yes, we are seeing this issue in Mountain Lion.

     

    I still haven't heard back from Apple in 5 days.

  • slopezFCSD Calculating status...
    Currently Being Moderated
    Nov 21, 2013 12:47 PM (in response to TPinson)

    I'll add my voice to the choir.

     

    OS 10.9

    Configurator 1.4.2

     

    Exact same symptoms as described elsewhere.

     

    I've spent HOURS on the phone with AppleCare Enterprise Support over the course of the past 3 weeks.

    Case # 525011601

    No response in over 7 days. Their last communication simply stated:

    "The fix for this will be in the form of an update to iTunes or Apple Configurator.  Please keep an eye out for any updates.  If they have a solution I will certainly inform you of it.  It may be late next week before I get an answer."

    Extremely frustrating.

     

    I've tried creating multiple new users (and therefore new Configurator databases) but the same problem happens every time.

  • CRodriguez03 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 21, 2013 3:31 PM (in response to slopezFCSD)

    Hi SlopezFCSD,

     

    Once the code has been flagged as being "redeemed" there is no way for that key to be recovered. Therefore, if you're creating separate databases/logins, it still will not obsolve the issue. Its unfortunate that we can, pretty much, guarantee that on every cart we add new apps we will always have broken codes.

     

    In the mean time they are only handing out new keys while the old keys are broken.

     

    I would suggest this link so that you can send them the information on how many keys you need recovered if they have not discussed this with you yet.

     

    https://ssl.apple.com/support/itunes/vpp/

     

    - Casey

  • slopezFCSD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 5:35 AM (in response to TPinson)

    Oh yes, I'm well aware.

    I've received over $1,000 in VPP refunds in the past 3 weeks.

     

    I always used new codes (new VPP purchases, new VPP spreadsheets, codes never redeemed) when I was testing this with new users. The same issue was present with a new user, new database, and new codes. Twice.

  • CRodriguez03 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 22, 2013 8:29 AM (in response to slopezFCSD)

    I definitely apprecaite the time you've taken with testing the new users, and applying new codes. It supports our theory that the main issue is with the software.

  • KTechNE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 3:31 PM (in response to TPinson)

    If you delete a paid for app in AC and re-add it, the codes automatically appear again, does anyone know where these are stored in the back end to manually clear them out or delete any that are imported by mistake?

  • TxAg07 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2013 7:56 AM (in response to TPinson)

    Same issue here. We're purchasing codes via VPP and pushing via Configurator. On Mavericks and Configurator 1.4.2. Some codes work, others give either null or already been redeemed error

  • KTechNE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2013 3:07 PM (in response to TxAg07)

    took me a couple of weeks but i eventually got new codes from Apple for the apps i had the same problem with!

  • ictipad Calculating status...
    Currently Being Moderated
    Dec 16, 2013 2:34 AM (in response to TPinson)

    I'm having the same problem, i've also been issued with replacement codes and these worked for 3 ipads and then i got the exact same error as before, codes null or already used. I imagine i'll be re-issued more codes but without an update for the software the problem will continue. I talked to apple enterprise guys and they said it's a known issue and they're sorry but didn't give me any word on when an update or fix would be released.

  • joergradler Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 16, 2013 12:05 PM (in response to TPinson)

    Same here, bought 50 codes each for 5 apps. the first 30 iPad, no problem, the next 10 iPads, headeache. Some apps had no codes available, some had 1 or 2 available. Unbelievable.

     

    And again Enterprise support says, yes we know about it, and we are working on it.

     

    Very frustrating.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.