Previous 1 2 3 4 Next 47 Replies Latest reply: Feb 4, 2014 7:29 PM by schoolofluck Go to original post
  • HRMSASD Level 1 Level 1 (0 points)

    I have exact same problem. Started troubleshooting with Apple Care and was directed to iTunes support who will work with me to get codes re-issued. iTunes support also said this is a Configurator problem and directed me to AppleCare Enterprise Support team with who I am now on hold. Feel like a dog chasing its tale. Very frustrating.

  • TJTechPara Level 1 Level 1 (10 points)

    I have Apple Configurator 1.4.2 (370)

    And Mountain Lion - OS X 10.8.5

     

    I just realized I had this problem yesterday updating my 6th of 6 ipad carts.  I know I was working with 2 brand new apps yesterday.    Now I need to check all my other apps and carts and see where I stand on "lost" licenses.

     

    Glad I found this thread!

  • TxAg07 Level 1 Level 1 (0 points)

    I'm sitting in an Apple Tech Update now and one of their engineers stated that they are aware of the issue and it will be addressed in a VPP update in the future, but there's no timeline for release yet.

  • jefhed Level 1 Level 1 (0 points)

    Apple Configurator 1.4.3 released.

    Apple Configurator 1.4.3 improves redemption of VPP codes when installing App Store Apps.

     

    It also includes the following changes from Apple Configurator 1.4.2:

    <snip>

     

  • TJTechPara Level 1 Level 1 (10 points)

    thank you for the heads up.

     

    I'll report back tomorrow on my experience!

  • jefhed Level 1 Level 1 (0 points)

    For me 1.4.3 resolved the problem if I hadn't already tried to push the apps to the iPads.

     

    Earlier this morning, I deployed 3 carts with 1.4.2 and got the errors messages like in OP. I noticed 1.4.3 drop before I did a 4th cart, so I installed the upgrade, deployed that cart and it was smooth sailing.

     

    My 3x 1.4.2 iPad carts still do not deploy the problematic codes after upgrading to 1.4.3. Instead, I got more verbosity in the errors for both refresh statuses and in the redemption code lists.

  • SamJDavis Level 1 Level 1 (0 points)

    I can confirm that 1.4.3 does not fix the problem for iPads that you have already tried to push the codes to. I don't have any spare codes to test, so I couldn't confirm that much.

  • Stich59 Level 1 Level 1 (0 points)

    After installing 1.4.3, I had 9 out of 15 iPads fail on the first pass. I tried re-downloading the codes from the VPP website and re-injecting them into ACU, all that did was grey out the codes that said were already redeemed. We'll see if Enterprise Support has any suggestions.

  • TJTechPara Level 1 Level 1 (10 points)

    I have 6 carts and 150 ipads that I am taking care of, and I have done so many different things, so I am never quite positive what results I am getting.

     

    BUT, I am pretty sure that today I could install licenses that had a check mark (as if assigned), but didn't have a serial number or device name stored.

     

    I am also pretty sure that I was installing 25 licenses for the first time on one cart, but "lost" 5 of them to the "This license has already been redeemed."  Now, the cart that happened to did have a number of ipads updated earlier individually without the configurator.  I'm not sure if it was those 5 or not.

  • slopezFCSD Level 1 Level 1 (10 points)

    1.4.3 seems to have fixed the problem for new codes and new apps (aka, apps that have never been imported into Configurator).

    I spoke too soon. I just plugged in another iPad and tried to continue my deployment and I lost all the remaining codes on 5 new apps. Approximately $250 worth.

     

    For those apps that were already in Configurator and already giving me trouble, the problem is still there and it's exactly the same. The only difference is that the code list now shows the full error message rather than simply "((null))" or whatever else it used to show.

    Deleting the app from Configurator and re-adding it does not solve the problem. I've blown over $100 today testing this... and I've submitted separate refund requests for each of the errors. If Apple/VPP is going to make me suffer, I'm not going to give them any breaks.

     

    Back to the drawing board.

  • Todd Fernandez Level 2 Level 2 (215 points)

    Configurator 1.4.3 cannot fix codes that are already marked as already redeemed (you will need to get replacement codes from AppleCare for these codes), but new, unused codes should no longer fail to redeem successfully using 1.4.3 and we have heard from many customers who were experiencing the problem with pre-1.4.3 versions that 1.4.3 solves the problem for them. If you are importing spreadsheets containing new, unused codes into version 1.4.3 and some are still failing to redeem successfully like they were with pre-1.4.3 versions of Configurator, please enable logging as shown below and provide the logs here or via AppleCare Enterprise (contact info: http://support.apple.com/kb/HE57).

     

    To enable logging, execute the following defaults commands in Terminal, then quit and relaunch Configurator. We will need to see logging from a session where you attempt to redeem new, unused codes and they are rejected as already redeemed.

     

    defaults write com.apple.configurator LogLevel ALL


    Logs from this Configurator logging are written to Console.

     

    defaults write ~/Library/Containers/com.apple.configurator/Data/Library/Preferences/com.apple. storeagent AllowDevSign -bool YES
    defaults write ~/Library/Containers/com.apple.configurator/Data/Library/Preferences/com.apple. storeagent DebugLevel -int 3
    defaults write ~/Library/Containers/com.apple.configurator/Data/Library/Preferences/com.apple. storeagent LogXML -bool YES
    defaults write ~/Library/Containers/com.apple.configurator/Data/Library/Preferences/com.apple. storeagent LogIncomingHeaders -bool YES
    defaults write ~/Library/Containers/com.apple.configurator/Data/Library/Preferences/com.apple. storeagent LogOutgoingHeaders -bool YES


    Logs from this storeagent logging are written to ~/Library/Containers/com.apple.configurator/Data/Library/Logs/storeagent.

  • Stich59 Level 1 Level 1 (0 points)

    It appears to matter when the codes were actually purchased. I had some spreadsheets that were purchased in early December but had not injected them into Configurator untill today, and they still had failures. However, codes that I purchased this morning seemed to install without issue, hopefully that continues. Now I just have to go over all my old spreadsheets and send the order numbers back to Enterprise Support to get some refunds.

  • Todd Fernandez Level 2 Level 2 (215 points)

    It should be irrelevant when the codes were purchased. Are you certain that no one else redeemed the codes from the older spreadsheets since you downloaded them?

  • tech-itunes-MDS Level 1 Level 1 (10 points)

    I had the same problem with a few codes. What fixed several of my isses was to go back to the VPP store, redownload the code shets, and reimport the newly downloaded codesheets.

     

    This was at the suggest of an Apple VPP support person. It fixed a few of my non-usable codes.

  • Stich59 Level 1 Level 1 (0 points)

    Yes, that was a temporary fix that Apple was suggesting, but it did not always reclaim all non-usable codes. The update to Configurator ver 1.4.3 did solve this problem, but as I mentioned a few posts back, it depends on when you purchased your codes. If the codes were purchased before ver 1.4.3 came out (approx. Dec.20 ), you could still have failures, as I did. Enterprise support told me that new codes purchased since 1.4.3 came out should be fine.