1 2 3 Previous Next 111 Replies Latest reply: May 4, 2014 1:15 PM by papalapapp Branched to a new discussion.
rxstuve Level 1 Level 1 (0 points)

Installed Mavericks and Aperture 3.5

 

since the installation only issues I am having are with Aperture.

 

Aperture crashes fairly often, couple times an hour while veiwing, rating or adjusting pictures.  Does not seem to happen if looking at projects or looking at photos in the large grid view.

Occurs in multiple libraries.

 

Actions I have taken that have not solved it!:

 

Repaired Disk

Repaird disk permissions

 

repaired Library permissions

repaired library

rebuilt library

trashed plist

deleted and reinstalled aperture.

 

Opened all libraries in Iphoto latest version.  No crashes.

 

HELP!

 

Rick


iMac, OS X Mavericks (10.9), 24" 2009 iMac, 8 gig ram, GT120
  • 1. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    léonie Level 9 Level 9 (51,740 points)

    Does it happen, when you are using Aperture from a different user account? For example signed in from the Guest account?

     

    Is your Aperture library on your system drive or on an external drive? How full is the disk? Is the library referenced or managed? raw images or jpegs?

  • 2. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    Great Questions:

     

    1.  I am currently working with it on a guest account and no crashes yet.  Only been 5 minutes or so.  will keep trying.  UPDATE:  Crashed a few minutes after writting the first email.

    2.  All libraries are on an external Firewire 800 GRaid drive 4 terabytes in size

    3  It is about 1/2 full

    4  The library is managed

    5  I import Raw and JPEG from my camera (Olympus OMD EM5)

     

    I will update this if it crashes on a guest account.

    Assuming it does not, what does that tell anyone?  I already deleted the PLISt for aperture as that is the personal settings right?

     

    Rick

     

    Updated as it crashed a few minutes after writting this.

     

    I am going to create a library on the system drive and load up some pics and see if that helps.

     

    any other ideas are welcome.

  • 3. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    léonie Level 9 Level 9 (51,740 points)

    Assuming it does not, what does that tell anyone?  I already deleted the PLISt for aperture as that is the personal settings right?

    There are more settings to be considered.

     

    In addition to removing  "com.apple.Aperture.plist" from the "Preferences" folder, remove  ~/Library/Containers/com.apple.Aperture/  from the User Library.

     

    And the presets for your user account in the user library might be broken - have a look at

     

    ~/Library/Application Support/Aperture/

    and move the presets to a folder on the Desktop.

     

    Sometimes the ImageCapture Preferences (~/Library/Preferences/ImageCapture) are broken and need to be removed.

     

    To remove presets and preferences quit Aperture; and log off and on again before relaunching Aperture.

     

    Also compare the Login items in the "System Preferences > Users&Groups" pane for your account ant Guest account. Are there differences?

    Also compare the last row of the System preferences. This shows custom preferences panes. Have installed anything that is not active in the Guest account?

     

    Other things that might be installed for your account, but not for others, and have been known to cause troube with Aperture:

    • (duplicate) fonts
    • Aperture plug-ins
    • quicktime and video codecs
    • Haxies
    • Camera.app

     

    For more ideas look at this document. Have we missed something, that you have not yet tried?

    Aperture 3: Troubleshooting Basics

     

    Léonie

  • 4. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    Thanks Leonie,

     

    Update!!!

     

    It did crash using a guest account.

     

    Id did NOT crash yet using a library on the system drive vs. the external firewire 800 drive.  It has been a good 30 minutes and i will continue to use it.

     

    In the past I have read that Firewire is an issue with some OS updates.

     

    I also use final cut off that drive.  I might try it to see if that causes errors too.  Would like a way to test it with out doing that.  FCPX files / library has proven to be less robust when the system crashes in the past.  Don't want to pooch any files.

     

    Any ideas on how to test if the Fire wire is the issue?

     

    Rick

  • 5. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    léonie Level 9 Level 9 (51,740 points)

    Rick,

     

    You have a version of Final Cut installed? Do your crash logs contain something similar to:

     

    Dyld Error Message:

     

      Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

     

      Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

    Reason: no suitable image found.  Did find:

     

    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager: no matching architecture in universal wrapper

     

    As to your drive; what does Disk Utility say, when you check the filesystem on the drive?

  • 6. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    yes I also use the latest version of final cut pro X

     

    where do i find the crash logs?

     

    after every crash I repair permissions on the system drive and the attached drive.  no errors.  Once in a while one would pop up due to to the crash I assume on the system drive but the attached firewire drive has not had any issues when I run diskutility.  I can not repair permissions on teh attached drive as the option is greyed out.  I assume because it is a raid drive.

     

    so far no crashes using my test library on the system drive vs. the firewire attached drive.

  • 7. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    found the crash logs.

    no hits on a  search for those strings

  • 8. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    léonie Level 9 Level 9 (51,740 points)

    Do the crash logs look similar? Then post the first 50 lines of a recent Aperture crash log. Perhaps we can find a clue.

  • 9. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    it does not catagorize it as an aperture crash but a systemuiserver crash

     

    I also think unless it crashes to a black / then white reboot screen in many languages (kernal panic?) it does not create a crash log.  When the screen just freezes and I have to hard reboot with the power button it does not come back with a log to report to apple and does not create a log in the crash logs area.

     

    I attached the log below.

    this is all jibberish to me, but no crashes since I put the library on the system drive.

     

     

    Process:         SystemUIServer [3063]

    Path:            /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer

    Identifier:      com.apple.systemuiserver

    Version:         1.7 (395)

    Build Info:      SystemUIServer-395000000000000~2

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [197]

    Responsible:     SystemUIServer [3063]

    User ID:         501

     

     

    PlugIn Path:       /Library/Application Support/iStat Menus 4/*/iStatMenusNetwork

    PlugIn Identifier: com.bjango.iStatMenusNetwork

    PlugIn Version:    4.10 (432)

     

     

    Date/Time:       2013-10-28 09:01:45.529 -0500

    OS Version:      Mac OS X 10.9 (13A603)

    Report Version:  11

    Anonymous UUID:  8A65BC2F-0BFC-909C-6D69-2AB0916C14E3

     

     

    Sleep/Wake UUID: 6028FF93-BECC-4684-B717-25B60BA4E333

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: EXC_I386_GPFLT

     

     

    Application Specific Information:

    objc_msgSend() selector name: getPrimary

    com.apple.menuextra.battery

    com.bjango.iStatMenusCPU

    com.bjango.iStatMenusTemps

    com.apple.menuextra.TimeMachine

    com.apple.menuextra.bluetooth

    com.apple.menuextra.airport

    com.apple.menuextra.volume

    com.apple.menuextra.clock

    com.apple.menuextra.appleuser

     

     

     

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

    0   libobjc.A.dylib                         0x00007fff92710097 objc_msgSend + 23

    1   com.bjango.iStatMenusNetwork            0x000000010e1b3943 iStatServerNetworkCallback + 73

    2   com.apple.SystemConfiguration           0x00007fff937257dd rlsPerform + 150

    3   com.apple.CoreFoundation                0x00007fff882048f1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17

    4   com.apple.CoreFoundation                0x00007fff881f6062 __CFRunLoopDoSources0 + 242

    5   com.apple.CoreFoundation                0x00007fff881f57ef __CFRunLoopRun + 831

    6   com.apple.CoreFoundation                0x00007fff881f5275 CFRunLoopRunSpecific + 309

    7   com.apple.HIToolbox                     0x00007fff8a8edf0d RunCurrentEventLoopInMode + 226

    8   com.apple.HIToolbox                     0x00007fff8a8edcb7 ReceiveNextEventCommon + 479

    9   com.apple.HIToolbox                     0x00007fff8a8edabc _BlockUntilNextEventMatchingListInModeWithFilter + 65

    10  com.apple.AppKit                        0x00007fff90e8328e _DPSNextEvent + 1434

    11  com.apple.AppKit                        0x00007fff90e828db -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 122

    12  com.apple.AppKit                        0x00007fff90e769cc -[NSApplication run] + 553

    13  com.apple.systemuiserver                0x000000010a37dec6 0x10a379000 + 20166

    14  libdyld.dylib                           0x00007fff89ca15fd start + 1

     

     

    Thread 1:: Dispatch queue: com.apple.libdispatch-manager

    0   libsystem_kernel.dylib                  0x00007fff9483f662 kevent64 + 10

    1   libdispatch.dylib                       0x00007fff9500f43d _dispatch_mgr_invoke + 239

    2   libdispatch.dylib                       0x00007fff9500f152 _dispatch_mgr_thread + 52

     

     

    Thread 2:

    0   libsystem_kernel.dylib                  0x00007fff9483aa1a mach_msg_trap + 10

    1   libsystem_kernel.dylib                  0x00007fff94839d18 mach_msg + 64

    2   com.apple.CoreFoundation                0x00007fff881f6315 __CFRunLoopServiceMachPort + 181

    3   com.apple.CoreFoundation                0x00007fff881f5939 __CFRunLoopRun + 1161

    4   com.apple.CoreFoundation                0x00007fff881f5275 CFRunLoopRunSpecific + 309

    5   com.apple.AppKit                        0x00007fff910231ce _NSEventThread + 144

    6   libsystem_pthread.dylib                 0x00007fff8ae8d899 _pthread_body + 138

    7   libsystem_pthread.dylib                 0x00007fff8ae8d72a _pthread_start + 137

    8   libsystem_pthread.dylib                 0x00007fff8ae91fc9 thread_start + 13

     

     

    Thread 3:: com.apple.CFSocket.private

    0   libsystem_kernel.dylib                  0x00007fff9483e9aa __select + 10

    1   com.apple.CoreFoundation                0x00007fff88241d43 __CFSocketManager + 867

    2   libsystem_pthread.dylib                 0x00007fff8ae8d899 _pthread_body + 138

    3   libsystem_pthread.dylib                 0x00007fff8ae8d72a _pthread_start + 137

    4   libsystem_pthread.dylib                 0x00007fff8ae91fc9 thread_start + 13

     

     

    Thread 4:

    0   libsystem_kernel.dylib                  0x00007fff9483ee6a __workq_kernreturn + 10

    1   libsystem_pthread.dylib                 0x00007fff8ae8ef08 _pthread_wqthread + 330

    2   libsystem_pthread.dylib                 0x00007fff8ae91fb9 start_wqthread + 13

     

     

    Thread 5:

    0   libsystem_kernel.dylib                  0x00007fff9483ee6a __workq_kernreturn + 10

    1   libsystem_pthread.dylib                 0x00007fff8ae8ef08 _pthread_wqthread + 330

    2   libsystem_pthread.dylib                 0x00007fff8ae91fb9 start_wqthread + 13

     

     

    Thread 0 crashed with X86 Thread State (64-bit):

      rax: 0x00007fff92710080  rbx: 0x00007fff92710080  rcx: 0x0000000000000008  rdx: 0x00000000a1a1a1a1

      rdi: 0x00007ffd3b098600  rsi: 0x00007ffd3a4b4a10  rbp: 0x00007fff55885530  rsp: 0x00007fff55885508

       r8: 0x0000000000000001   r9: 0x00007ffd3a67bda0  r10: 0x00007ffd3a4b4a10  r11: 0xb000000000000000

      r12: 0x0000000000000000  r13: 0x000000010e1b38fa  r14: 0x00007ffd3a50c940  r15: 0x00007ffd3b098600

      rip: 0x00007fff92710097  rfl: 0x0000000000010246  cr2: 0x000000010a506000

     

    Logical CPU:     1

    Error Code:      0x00000000

    Trap Number:     13

  • 10. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    léonie Level 9 Level 9 (51,740 points)

    O.k., so if I understand you correctly,

    • Aperture does not crash, but hangs and is unresponsive.
    • You find crash reports for the SystemUiServer.
    • And you are experiencing kernel panics.

     

    We need a system expert and not an Aperture expert.

     

    Have you read this support article?

    OS X: When your computer spontaneously restarts or displays "Your computer restarted because of a problem."

    http://support.apple.com/kb/TS4636

     

     

     

    From what little I know, the SystemUIServer is a background process. It controls the graphical user interface, and is for that reason constantly running. It will restart automatically, if it crashes.  Problems with the SystemUIServer indicate hardware trouble; your suspicion, that your FireWire drive is causing problems seems to be justified. If you have not done so already, it is high time to check the backups of your Aperture library on that drive, if they are really working, and I'd make an additional backup, just to be on the safe side. The kernel panics are also an indication of hardware trouble.

     

    However, kernel panics can also be caused by incompatible software. Have you checked the items that I listed?

  • 11. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    Leonie,

      I agree now that I have gotton to the heart of the matter.  it appears that Aperture is causing the system to crash for some reason.  No other crahses other than when I used Aperture lead me to this forum.  I really appreaite all your help.

     

    As far as the software you listed.

    • (duplicate) fonts  
      • I don't know how to check this but will investigate
    • Aperture plug-ins
      • removed
    • quicktime and video codecs
      • none installed other than what aperture or FCP installed
    • Haxies
      • I don't know what this is.
    • Camera.app
      • I don't have any camera apps installed

     

    Thanks for all your help.

     

    I am going to be contacting apple.

  • 12. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    SierraDragon Level 4 Level 4 (2,695 points)

    Over decades of database (DB) work I have found that anything that limits DB throughput reduces stability. In general, databases seem to perform best when on an underfilled internal drive and without limiting factors like RAM page-outs or connections to FW/USB external drives. Stronger CPU/GPU also makes a difference, and smaller DBs outperform larger DBs.

     

    Managed Masters/Originals always make for much larger databases; not ideal. In my opinion, Managed Masters are appropriate only for smaller Libraries or for tech-sophisticated users with large SATA/eSATA or Thunderbolt mass storage setups in place.

     

    To minimize DB size I strongly recommend Referenced Originals with the Library on an internal drive.

     

    Hard disk drives (HDDs) slow as they fill, so if one chooses to stick with old HDD technology I recommend HDDs be kept underfilled;  always less than an arbitrary 70% full. But in any event for best operation the Library should have SATA/eSATA/Thunderbolt access to the CPU rather than be limited by FW or USB.

     

    In 2013 IMO no one seriously working a pro images workflow should be booting from HDD. Instead I recommend Referenced Originals with the Library on an internal solid state drive (SSD). SSDs are just far, far superior. Just my 02.

     

    In the past usage of an SSD for boot and for the Aperture Library was often financially challenging because SSDs were so expensive per GB of mass storage. However in early 2011 it was doable (128 GB SSD was a $100 add when I bought my MBP), and today it is very doable. E.g. I recently upgraded my MBP to a 512 GB SSD for $425.

     

    Note too that although 8 GB RAM is generally considered a sort of standard for Aperture, some workflows (such as Aperture/Photoshop) will page out with just 8 GB RAM on board. And page outs are one kind of slowdown that may provide just enough hiccup that when combined with some other throughput-limiting parameter like FW or slow CPU may crash the app.

     

    You can evaluate whether or not you have adequate RAM by looking at the Page Outs number under System Memory on the Activity Monitor app before starting a typical work session; recheck after working for an hour and if the page outs change (manual calculation of ending page outs number minus starting page outs number) is not zero your workflow is RAM-starved. Ignore page ins, the pie charts and other info in Activity Monitor.

     

    -Allen

  • 13. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    léonie Level 9 Level 9 (51,740 points)
    (duplicate) fonts

     

    You can check for duplicate fonts using the "Font Book" Utility. Select "All Fonts" in the side bar and scroll down.  Duplicate fonts will be marked by a yellow allert triangle.

    Screen Shot 2013-10-29 at 19.53.54GMT+1.png

    Haxies

    Haxies are cute utilities, like "Fruit menu" or "window Shade". hey exploited special system features, that were not stable, and were causing all kinds of problems with each new system update. If you never heard of them, you are probably on the safe side.

    Camera.app

    That is a helper, that selects the application to open, when a camera is connected, and it caused problems with the Aperture 3.4 update.

     

    I am going to be contacting apple.

    A good plan. Show them the kernel panic reports.

    And be prepared, that they will want to wipe the system drive for testing. Don't go there without two working backups of your system drive.

     

    Good Luck.

     

    And let us know what comes of it.

     

    Léonie

  • 14. Re: Solution for Aperture 3.5 and OSX 10.9 Maverick's crashing
    rxstuve Level 1 Level 1 (0 points)

    Allen,

         Thank you for all the information.  I would not be using the older machine with many of the shortcommings if I had another choice at this time.  Certainly on my wish list.  I chose the external raid / FW drive because it was ever so slightly slower in the throughput area than the internal drive using black magic to test throughput.  I don't really notice the difference between the two in speed.  I keep an eye on memory usage and have never run out that I have noticed.  I do not run to many things in the background when I am in Aperture or final cut.  I also create a new Library every year to help keep it on the smaller size.  They average about 150gb each year. 

     

    Leonie,

         I apprecaite all your help.  I have reset the SMC and will be testing to see if that fixes it.  That was one suggestion from an apple support person as well as starting in safe mode.

     

    i will certainly let you know what the outcome is from my efforts with apple.

     

    Rick

1 2 3 Previous Next