Announcement: Get Ready for macOS Mojave


With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. Prepare for macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mavericks won't boot my internal SSD in main bay

I have been running Mountain Lion from an SSD in the main internal bay of my 2011 Mackbook Pro without problem. Now I am unable to install Mavericks. I have tried multiple methods of installing to this drive but they all result in the same problem: the Mackbook appears not to see the SDD in the main bay.


I first tried installing per usual. It got part-way through the install process, but at the point where you tell the installer where to install Mavericks, the SDD fails to show up on the list.


I have now tried several methods of installing Mavericks, including a fresh install via Rescue Disk, and most recently, installing Mavericks on an external drive and then cloning the drive to the SSD. All to no avail. Mavericks runs my computer just fine off of any other drive I install it on, but it refuses to acknowledge the existence of my SSD in its main bay. If I boot from a prior version of OS10, the SSD shows up in the disk list in Disk Utility. Running Mavericks from an external disk, I am able to see the SSD in disk utility. But it simply won't boot from it.


There is nothing wrong with the SSD. I can revert to my back-up and it runs just fine off of it. I've run disk first aid and found no errors. I've done complete wipes before re-installing. The problem is specific to booting in Mavericks.


I've read online that I am not the only one with this problem, but I haven't seen a single work-around that actually works. At this point I think I have tried them all, and have wasted a whole day.


Any other ideas? Please help...! Thanks.

iMac, Mac OS X (10.4.10), iPhone, MacBook

Posted on

Reply

Page content loaded

Oct 28, 2013 10:55 PM in response to John Galt In response to John Galt

Hmm...once I get Mt Lion reinstalled from my backup (for the umpteenth time in the past 3 days,) I could try a firmware update via windows via Parallels. At least an old firmware is a logical explanation for why the new OS can't see the drive. Think that might work?

Oct 28, 2013 10:55 PM

Reply Helpful

Oct 29, 2013 7:44 AM in response to Playapixie In response to Playapixie

No I don't. Mavericks is designed to work with the components Apple supplies with their Macs. Modifying a Mac with non-Apple hardware such as an SSD not supplied by Apple or a vendor known to supply Apple - compatible hardware puts the responsibility on you to determine their compatibility. When and if Intel decides to supply a Mavericks - specific SSD firmware update is up to Intel.

Oct 29, 2013 7:44 AM

Reply Helpful

Oct 30, 2013 7:34 PM in response to John Galt In response to John Galt

I ended up installing a newer SSD. It didn't appear that intel was supporting my older SSD so I couldn't find an approrpiate firmware update. Working fine with a new/bigger SDD. But it's still lame that I had to throw more money at hardware to get back up and running.

Oct 30, 2013 7:34 PM

Reply Helpful

Nov 9, 2013 10:45 AM in response to Playapixie In response to Playapixie

Thank you very much for pointing me in the right direction - for me the problem was the firmware of the SSD! It was all fine while running Lion, but updating to Mavericks, my SSD wouldn't be recognised anymore. I installed the current one from the intel support site and now it works perfectly. For more details you can check my blog where I wrote about the whole process. Thanks again!

Nov 9, 2013 10:45 AM

Reply Helpful
User profile for user: Playapixie

Question: Mavericks won't boot my internal SSD in main bay