2 Replies Latest reply: Oct 31, 2013 8:54 AM by a brody
JSCJ Level 1 (0 points)

Can G5 OSX 10.4 upgrade to OSX Mavericks


Mac Pro, Mac OS X (10.4), Power Mac G5
  • mende1 Level 10 (92,236 points)

    Welcome to Apple Support Communities

     

    You have got a PowerPC Mac, which can only run Mac OS X 10.5. OS X 10.6 and later are only compatible with Intel Macs.

     

    If you want to use OS X Mavericks, get a new Mac, but if you want to upgrade your Mac to the most recent version, see if your computer is compatible with Mac OS X Leopard > http://support.apple.com/kb/sp517 You can buy Mac OS X Leopard at Amazon

  • a brody Level 9 (65,765 points)

    Note upgrading to 10.5 or later will disable Classic applications on your G5.  Those relate to pre-2001 applications that run when you use the Classic System Preference.