Previous 1 2 Next 23 Replies Latest reply: Apr 9, 2015 2:33 PM by ThePerfectLine
Chale Boy Level 1 Level 1 (40 points)

Installed Mavericks on MBA and use a VPN connection to connect to work.  Since upgrading to Mavericks, I will click connect to VPN in the menu bar and it appears that nothing happens.  After EXACTLY 30 seconds [reproducible every time], the vpn clock in the menu bar with then show up and start counting from 30 seconds upward.  However, it is not usable for the first 30 seconds.  If I try to connect to drives, etc before that, it is not connecting.  Prior to Mavericks, it only took 1-2 seconds to connect.  Strange behavior.  Ideas why the reproducible delay of 30 seconds?

  • Charles Campbell2 Level 1 Level 1 (120 points)

    I have exactly the same problem both with a new MacBook Pro and a 2009 MacBook Air. So one meachine has a clean new Mavericks system and one was just upgraded to Mavericks. The connection was previously made by the MBA within a second or two...

     

    I don't know a lot about the VPN set-up at the office, other than it's supposedly a plain vanilla Cisco platform.

     

    Any ideas?

  • dlangh Level 1 Level 1 (0 points)

    I am experiencing the exact same problem.  30 second delay before VPN counter begins.  This started right after upgrading to Mavericks from Mountain Lion. 

     

    What I have discovered is that the vpn connection is made immediatel.  I can ping internal IPs and get a response but until 30 seconds elapse, any internal DNS requests will fail.  More specifically, when I connect to my vpn server, the vpn server provides an internal DNS server for the various internal machines.  Those DNS requests will return failure until after 30 second have passed.

     

    This isn't the end of the world, but it is annoying,  hoping Apple will get to this sooner than later.

  • joewilson81 Level 1 Level 1 (0 points)

    Same issue on my 2012 MBP Retina - connected almost instantly on Mountain Lion but says "Connecting..." for 30 seconds after upgrading to Mavericks.

  • poikon Level 1 Level 1 (0 points)

    I'm having this issue with only one VPN provider, and the connection type is L2TP + IPSec. Connecting to other VPNs works as expected. Really weird...

  • astropig Level 1 Level 1 (0 points)

    Well, for me the delay is about 40 seconds, also with a connection type of L2TP +IPSec.  It's quite annoying.  I hope this gets addressed soon.

  • aviavi Level 1 Level 1 (0 points)

    I have the same issue.  A delay of 30 to 40 seconds.  Again, annoying.

  • msmyj Level 1 Level 1 (0 points)

    We've seen this issue at work and tested a few versions of OS X. We are not seeing the issue on either our Windows(XP-SP3, 7-SP1) or Linux (RH6.2) clients. Starting with a clean 10.7.4 install and running select incremental updates we found that the problem seems to be related to a change in how Mavericks handles L2TP VPN connections:


    Mac OS 10.7.4 -- no delay


    Mac OS 10.7.5 -- no delay


    Mac OS 10.8 -- no delay


    Mac OS 10.8.5 -- no delay


    Mac OS 10.9.1 -- 30 second delay


    Mac OS 10.9.2 -- 30 second delay

     

    Testing completed on a 2010 MBP 17, 4GB RAM, 240GB SSD.

  • jayvee0718 Level 1 Level 1 (0 points)

    I actually have the same issue connecting MBP 13 to a Sonicwall NSA 4500 using L2TP. It used to work prior the upgrade. I'm able to ping the sonicwall router in the remote network but not the LAN.

  • msmyj Level 1 Level 1 (0 points)

    Jayvee, we are seeing this issue while connecting through a Sonicwall E8510.

  • jayvee0718 Level 1 Level 1 (0 points)

    yeah it is the same concept. no difference on the l2tp setup from tz 100 up to the highest e class model. Are you able to access hte LAN network where the sonicwall is at?

  • msmyj Level 1 Level 1 (0 points)

    After the 30 sec delay we have full access to the network.

  • LupotheButcher Level 1 Level 1 (0 points)

    Good Day All...

     

    I found a solution to this. With a little log monitoring I found that, in my situation, the delay was due to IPv6 waiting for a reply. It tries for 30 seconds, then times-out.

     

    To turn IPv6 off on your VPN service, you will need to open the Terminal and enter the following:

     

    "networksetup -setv6off <vpn service name>" where <vpn service name> is the friendly name of your vpn service.

     

    You will be prompted for an administrator password to make the change. You can double-check the setting by going into the advanced settings of your vpn service and selecting the TCP/IP tab. The Configure IPv6 option will display Off.

    VPN IPv6.png

  • Chale Boy Level 1 Level 1 (40 points)

    Doesn't work for me.  I was able to turn off IPv6 for the VPN service as you describe above but I still have to wait till 30 seconds goes by.

  • astropig Level 1 Level 1 (0 points)

    This solution worked worked for me and I no longer have the delay!  THANK YOU!!!

Previous 1 2 Next