Previous 1 2 Next 21 Replies Latest reply: Jul 20, 2014 1:19 AM by peterfromwesthausen
davshirley Level 1 (0 points)

I administer many wordpress blogs and since updating to mavericks I have had to use firefox or chrome to admin almost all of the blogs that I used to use safari for.  Safari 7 seems to sit and spin in various places in the wordress admin panel.  New pages, new posts, etc.  Anyone have any idea why?

  • Carolyn Samit Level 10 (103,365 points)

    Might be an incompatible Safari extension or plug-in ...

     

     

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. I

     

    If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

  • gregsul Level 1 (0 points)

    Hi Carolyn,

     

    I'm having the same problem. Editing Wordpress on Safari has become impossible. I turned off extensions and deselected 'Allow Plug-ins' option in the Security preferences tab. No effect whatsoever. I've changed my default browser choice to Firefox. If I could uninstall Safari, I would.

     

    ~ Greg

  • odissey Level 1 (0 points)

    Hi Guys,

    This has become a big problem for me too, Safari is really slow when adminstrating any word press site, it lags and I get the rainbow wheel for a to a minute. I have disabled all plugs ins and there has been no change. I have no choice but to change my default browser, to firefox, it is just more dependable.

  • shockr Level 1 (5 points)

    Same problem over here. Using Woothemes and originally thought it was a server problem. No problems when using Chrome. Only Safari Version 7.0 (9537.71).

  • kickstarter Level 1 (0 points)

    same issue.. using firefox now as it is basically unusable on several sites. Disabling extensions has no effect.

  • bobo99 Level 1 (0 points)

    At the Genius bar right now about this - see what they say. The solution is to turn off javascript, then everything works. Then you have to turn it back on to have certain parts of the website work for you as a user.

     

    Total screw-up in mind.

  • shockr Level 1 (5 points)

    I gave up... started using Chrome again...

  • iknowdjz Level 1 (0 points)

    Same thing for me Any update???

  • TonyLima Level 1 (0 points)

    This is awful.  I was forced to use my ancient Windows XP machine running Firefox to add a new entry to my blog today.  Apple, please don't force me to go back to the Microsoft universe!!!  This is important!

     

    Speaking as the spouse of an Apple stockholder,

    Tony Lima

  • RTECK Agency Level 1 (0 points)

    Having the exact same problem in Safari 6.1. The dashboard for wordpress that used to work great, has been spinning beach ball lately when trying to admin any of the various blogs that I manage. Switched to Chrome and all is well. APPLE PLEASE HELP!

     

    (Also a stockholder)

    Tom

  • Tatel Level 1 (0 points)

    Same here, I don't know exactly when starded, also with Safari 6.1 and Mac OSX Mountain Lion 10.8.5.

     

    Not a permissions problem, neither an extensions one.

     

    We'll be checking...

  • H4nd5omeR0b Level 1 (0 points)

    +1

     

    Switched for Safari in Mavericks because Chrome was so sluggish. Now Safari is sluggish on Wordpress.

     

    SMH...

  • RTECK Agency Level 1 (0 points)

    The latest update to Safari (6.1.1) has solved this issue for me. Thanks, Apple! Cheers to a new year!

  • dads disco Level 1 (0 points)

    Running version 7.0.1 - i dont see any improvement, Chrome it is then.

Previous 1 2 Next