6 Replies Latest reply: Aug 30, 2014 11:00 AM by daledab
GaryKing Level 1 (10 points)

I have a PC with Windows 8.1 and a Mac with Mavericks. I have a folder on the Mac that is shared with the PC. When I'm on the PC and I try to open a file that is shared by the Mac, such as a PDF file, then I get a message saying that I cannot open the file, or the file is in use (it depends on the app/filetype). I have the same problem when I open a video file or a disk image. Strangely, text files are just fine. And if I copy any of the problematic files to the local Windows disk, then I can open them just fine.

 

The specific error messages are:

 

- AVI files opened in VLC: "Your input can't be opened. VLC is unable to open the MRL."

- ISO files opened by Windows Explorer: "Sorry, there was a problem mounting the file."

- PDF files opened with FoxIt: "Failed to open the document. It may already be opened or in use by another application."

 

This only started happening after I upgraded to Windows 8.1 on the PC and Mavericks on the Mac. Mavericks upgraded its SMB version from SMB1 to SMB2, so perhaps that is related?

Does anyone know what the problem might be, and how I could fix it?

 

Thanks in advance!


Mac mini (Late 2012), OS X Mountain Lion (10.8.4), 2.3 GHz i7, 16 GB RAM, 256 GB SSD
  • GaryKing Level 1 (10 points)

    I'd like to note that PDF files are actually fine. Text files are fine too. I have a problem with video files like .avi and disk images like .iso in particular.

  • alinefx Level 1 (0 points)

    That makes two of us. cant believe there isn't a solution out there yet

  • PaulS Level 2 (195 points)

    I looked at your post and did some research.

     

    I have a MacPro that can run two virtual machines at the same time - Mavericks and Windows 8.

    I confirmed the ISO issue.

     

    The .avi file issue, I was able to use the file where Mavericks was the host and Windows 8 was the user.

    It opened in XBox viewer and Windows Media Player.

    The file was encoded using iSkySoft Video Converter.

  • alinefx Level 1 (0 points)

    Ok this worked to solve the error.

     

    Use cmd prompt in windows 7 or 8 and run as admin:

     

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

    sc config mrxsmb20 start= disabled

     

    No need for all that power shell nonsense as shown elsewhere for windows 8.

     

    That's it. Also force smb2 disabling on the apple side for good measure.

     

    With the above I was able to network mavericks and windows 8.1 pro flawlessly. He issues I had before where I could not read video, ISO and audio files (but could open documents and pictures from the windows machine connected to an apple network share folder went away.

  • NanisMac Level 1 (0 points)

    works for me!!!

    tnx

  • daledab Level 1 (0 points)

    I have a problem connecting to smb shares on my Mac mini running OSX server.  I found that with nothing shared that all my physical drives were showing up  on my Windows 8.1 but I could not connect as expected.  When I shared the drives it would still not connect. I tried everything I could think of but nothing helped. I noticed that the folder shares would connect so I tried something radical i created a folder on the root of each drive with the same name as the drive and moved all the content of the drive into that folder and shared that folder and now I can connect to the shares and get to my content from my Windows 8.1 computer.  See if this works for any of you. If it does I hope Apple reads this and can fix the physical drive shares.