Previous 1 2 Next 14 Replies Latest reply: Nov 18, 2014 5:21 AM by lgda
Mysticfm Level 1 Level 1 (10 points)

This has happened to me twice now, both times in exactly the same sequence of events I will describe below, since I installed Mavericks and OS X Server 3.0 on my Mac Mini server:

 

After running fine for a while (up to a day or two), I will attempt to do a share screen of the server from my laptop (something I do regularly with success), but this time it just says "connecting" forever and never gets any further.  So I quit the Screen Sharing app and go to the console of the server to attempt to login there instead, but every time I key the correct password, the password field shakes from side to side as if the password was keyed incorrectly (which I know it wasn't ... and no, caps lock wasn't on or anything of that sort).  Finally, out of some desperation I go to click on the "Restart Computer" button on the bottom of the Login page, which then clears the server's screen to a flat gray background as if it is rebooting ... ... and proceeds to stay that way forever until I finally have to forcibly shut down the hardware by holding down the physical power button.  Then I restart the server using the power button, and everything seems to be fine again ... I can once again login, share the screen remotely, etc.

 

I have little info to go on thus far, since 10.9 has been out for such a short time, but it is at least possible that this behavior began after I enabled the Xcode Server functionality in the Server app (at least I observed that the first time it happened was only a few hours after I initially enabled Xcode Server).  The other reason I am suspicious is that, during the time that the server is unresponsive and before I forcibly shut it down, just about all of the messages in the system log appear to be from Xcode Server.  Either that, or it may have something to do with the failed screen share attempt, I suppose.

 

Is anyone else having the same problem?  If so, do you have Xcode Server enabled?  Or are you perhaps seeing a relationship to screen share attempts?


MAC MINI SERVER (LATE 2012), OS X Mavericks (10.9), OS X Server 3.0
  • Mysticfm Level 1 Level 1 (10 points)

    Update: I now feel more and more confident this is an issue with Xcode Server.  I disabled it again several days ago, and haven't had the problem again since.  It's quite disappointing because I was primarily interested in the upgrade to Mavericks because of the ability to run a continuous build integration server, and now it appears that I won't be able to do so after all. 

  • MarkeMark Level 1 Level 1 (0 points)

    I too am having the same issue and only since I upgraded to Mavericks Server.

     

    I find this issue happens if I try and screen share when no on is 'logged on' on the physical server.

    - attempt screen share from laptop on network to server

    - screen share hangs

    - then unable to physically log in on server (rejects correct password)

    - server becomes unresponsive / grey screen

    - need to do hard reboot

     

    My work around has been

    - before commencing any screen share session to physically log on to the server

    - disable automatic log out / sleep on the server

    - am then able to share the screen while ever a user remains logged in on server

  • Josef_SA Level 1 Level 1 (0 points)

    Try safe mode. reboot holding shift and test in safe mode.

  • Awgeorge Level 1 Level 1 (0 points)

    I am also experiencing this issue. Is there any light on the subject. Really dislike restarting the server everytime i wish to use the GUI.

     

    Whats the offical word on this from apple?

  • Mysticfm Level 1 Level 1 (10 points)

    For me, the problem was definitely connected to my having been running the XCode service on the server.  I have not had the problem recur at all ever since I gave up and disabled that service six weeks ago.  If you are not running this service, then your issue may not be the same thing that I observed, although I suppose it is possible that different things are triggering some common underlying misbehavior in Mavericks.

  • Dimme Level 2 Level 2 (280 points)

    Any updates on this. I have been having a simular problem. I have a mini server and usally connect via Apple remote desktop. Sometimes when I connect from the outside world ARD stops and I get reconnecting then goes off line. When I physically get to the server I find the finder crashed and need to do a hard reboot. Oddley enought services like FTP and transmission still work when the finder is crashed.

  • Mysticfm Level 1 Level 1 (10 points)

    No further updates from me, I'm afraid.  I basically have given up on running Xcode Server in order to have a stable server in other respects.  I haven't had the problem recur since I shut that service down.

  • PaulStacy007 Level 1 Level 1 (0 points)

    You have probably seen, but there is an update for OS X Server - Xcode

     

    - Fixes an issue that could cause Xcode server bots to hand and logout the active user.

     

    ^^ Seems to be the problem we are experiencing.

     

    I am just installing it now, let hope it solves this.

     

    W

  • Mysticfm Level 1 Level 1 (10 points)

    Apple's docs for OS X Server 3.03 (the latest released version) don't mention any such fix, nor do the previous updates.  Can you include an URL where I can see this documented?

  • Awgeorge Level 1 Level 1 (0 points)

    Screen Shot 2014-03-04 at 14.12.40.png

    It was listed in the AppStore under `Updates Installed in the last 30 Days`

     

    `Xcode Update for OS X Server` v1.0

     

    W

  • Mysticfm Level 1 Level 1 (10 points)

    Oh!  I didn't see the Xcode Update for OS X Server ... just the Server update itself.  My Software Update service isn't working properly, so I've been downloading updates manually.  I guess I should see if I can find a manual download of that one.

     

    Update: argh!  Looks like it is not available as a manual download (in spite of what the following page says), and it still doesn't show up as an automatic download on my server.  So I remain out of luck, it seems.  Discouraging.

     

    http://support.apple.com/kb/HT6139

  • jakobmlm Level 1 Level 1 (0 points)

    I have the exact same issue with the latest updates from Sep 23, 2014.

    I have both the Xcode update and the server update. Also the one that says "Fixes an issue that could cause Xcode Server bots to hang and logout the active user".

     

    In addition to this, I loose my entire Xcode server setup, and I can't set it up again.

     

    I have not been using screen sharing, I have set up every thing on the actual server machine

     

    This is what happened:

    * I set up the OSX server and enabled it with Xcode 6.0.1

    * I run a few bots and stuff

    * Restarted server machine

    * Could not log in with correct password

    * Attempted to restart computer

    * Got grey screen that stays forever

    * Forced reboot

    * Logged in successfully

    * Launched OS X server app

    * Xcode service is turned off, and no Xcode is selected any more

    * I click choose Xcode and selects Xcode 6.0.1 again.

    * I get a box saying "Waiting for Xcode to setup to complete" that stays for a long time

    * The box dissapeares, and the Xcode server is still not setup and the button "Choose xcode to begin" is still there.

    * Stuck!!!

  • cyrus_b_uk Level 1 Level 1 (0 points)

    I've been having similar problems with xcode server.  I decided I'd try using it at the weekend.  It's been nothing but grief.

     

    Like the others, after a restart screen sharing stopped working. 

     

    As suggested above, it's possible to log in manually at the machine first, then go back to screen sharing.

     

    However, once in, the finder is crashed, it's not possible to restart, shutdown, force quit etc.  The only way I could get it to restart long press on the power button, or issuing a sudo shutdown -r now command.  This reboots immediately.

     

    It is possible to select restart direct from the login screen.  If I do this, the machine hangs up on shutdown.

     

    Once I finally get in to the machine, ignore the finder crash, start osx server, the previously configured xcode service is back to off with no xcode selected.  Once I select xcode and start the service, finder seems to sort itself out, and it's possible to restart, and back to square one. 

     

    While it was running, i was trying to get the bots to work on my project, but the bots always fail on code signing issues.  Xcode is supposed to manage your developer profiles, but signing identities are different between the development machine and the server.  There's a few blogs and answers on stackoverflow on the issues, I still haven't resolved them fully before running in to this problem.  I wish I'd never started.....

  • cyrus_b_uk Level 1 Level 1 (0 points)

    Seems like the xcode service still leaves things running even after turning off the service that borked my server.  Noticed in my system log that something was trying to laund xcsbuildd every 20 seconds or so, despite the xcode serivce being turned off.

     

    Looking around on the apple dev forums, some helpful soul posted the following command to reset xcode on the server:


    sudo xcrun xcscontrol --reset

     

    I can now log in remotely again, the server can be shut down and restarted as normal and things look like they're back to normal.

     

    It was frustrating enough that the service seems extremely flaky when it comes to setup, but having it screw up other apsects of the server compounds the already significant problems.

Previous 1 2 Next