Previous 1 2 Next 20 Replies Latest reply: Oct 25, 2014 10:36 AM by thebrecks Branched to a new discussion.
Niallfromgbr Level 1 Level 1 (0 points)

Is there anyway to get the net flix app on iPad 1 running 5.1.1 as that is the maximum update I can get for this iPad?

iPad, iOS 5.1.1
  • King_Penguin Level 10 Level 10 (115,220 points)

    All apps are tied to the account that downloads them, so you would need to have your own copy of a iOS 5.1.1 compatible-version somewhere - did you download it when it was compatible with iOS 5.1.1 and still have it somewhere ?

  • Niallfromgbr Level 1 Level 1 (0 points)

    I didn't have the app at all, just started using Netflix today so thought I would get the app but it says I have to update to iOS 6 or above which ipad 1 won't go to.

  • King_Penguin Level 10 Level 10 (115,220 points)

    Only the current version of each app is in the store, so you won't be able to download a 5.1.1 compatible version from there (unless the developers of the app change its requirements or put an older version back in the store) - and as each app is tied to the account that downloads it nobody will be able to give you a copy as it will be tied to their account. You could try contacting Netflix and see if they have any plans to do put a 5.1.1 compatible version back in the store :

  • Mike Richards1 Level 1 Level 1 (35 points)

    Just ran into this with a client of mine.

    Since the release of iOS 7, Apple has quietly added a new feature to the App Store. When you connect to it on the device in question, running iOS 6 or IOS 5, (not sure about iOS 4 yet) and you click on an app that has been around since those older IOS's, the store will tell you:

    "Download an older version of this app?  The current version requires iOS 6 or later, but you can download the last compatible version."


    Click Download and all is good. You are now running the last version they made for iOS 5.


    What is not clear is if you had to have purchased it previously or not. I have heard yes and no from others.


    I aready had downloaded Netflix long ago. I just now deleted it from my iPad 1st gen. I then went back into the App store and downloaded it with the above message popping up.


    Keep in mind, you have to do this on the iPad itself. If you download it in iTunes on your Mac or PC, you will only get the current version.


    I just wish Apple would release a tech note or anything explaining exactly how this works and what iOS versions are ssupported.


    Hope this helps.



  • hoffmang9 Level 1 Level 1 (0 points)

    I can confirm that the Apple ID must own the app before you can get the iTunes store to let you download the older version of e.g. Netflix.


    The work around for that is to sign into a copy of iTunes software on a desktop/laptop with the Apple ID you're using on the iPad 1 and download a copy of the Netflix App to the computer from the App Store in iTunes desktop. Then, you can got to the App Store pn the iPad 1 and it will offer to allow you to download the older but compatible version.



  • scshaffer Level 1 Level 1 (0 points)

    Many thanks for your instructions. I recently purchased a used iPad 1 for my mother with the express intent of her accessing Netflix.  Much to our dismay, the App was incompatible.  Tried it today with your method, and it worked!

  • amin1030 Level 1 Level 1 (0 points)

    this did not work for me... Any other suggestions?

  • cleverlyl Level 1 Level 1 (0 points)

    Worked for me. Boought my wife a refurbished iPad1, and her new Apple ID just says it can't be downloaded. Log out of her account, into mine, and then it prompted me to download the older version.

    FAIL Apple.

  • Mike Richards1 Level 1 Level 1 (35 points)

    Purchased applications are tied to the Apple ID account. You just said that your wife's ID was new. So there is no purchase history on her account.


    It took me days to figure this out. You have to have purchsed, even if it is free, the app using the same Apple ID on a newer iDevice or Mac/PC. Then use that same ID on the old iPad 1.


    Is this a perfect, seemless way to do this? No, but far from  FAIL.

  • cleverlyl Level 1 Level 1 (0 points)

    "It took me days to figure this out."

    The very definition of fail.

  • Mike Richards1 Level 1 Level 1 (35 points)

    Ah, yes. Was thinking of the process, once known is easy.

    Apple needs to make an official statement or put it in the support site for users to see.

  • King_Penguin Level 10 Level 10 (115,220 points)

    You mean like this page : ?

  • scoutington Level 1 Level 1 (0 points)

    Make sure that netflix is not already half-installed on the ipad, or the prompt will not show up. Once I deleted the (nonfunctional new version) app from the ipad, the prompt showed up and it's working!

  • rbrylawski Level 6 Level 6 (11,850 points)

    King_Penguin wrote:


    You mean like this page : ?

    It's always amazing how people blame Apple when it's they who didn't check their user guide in the first place........

Previous 1 2 Next