Previous 1 2 Next 22 Replies Latest reply: Mar 27, 2014 1:59 PM by Eric Root
Estigarribia Level 1 Level 1 (0 points)

Can't Print after OSX Upgrade


MacBook Air, OS X Mavericks (10.9), Can't Print after OSX Upgrade
  • Larry0154 Level 1 Level 1 (0 points)

    I just upgraded to Mavericks 10.9 from 10.8 last night on my MacBook Pro. I have lost all printing capabilities. Not sure what else.

  • John Blanchard1 Level 5 Level 5 (5,030 points)

    Details? Type of printer?

     

    Is it supported?

     

    http://support.apple.com/kb/HT3669

  • Larry0154 Level 1 Level 1 (0 points)

    The MacBook Pro can not connect to the Printers. (These worked fine until I loaded Mavericks last night.

     

    After talking with Apple Care Support, it looks like HP has no drivers for the 2 (HP940C & HP9800) printers to Mavericks.

    I just purchased a Brother MFC-4710JDW which they think will work when I hook it up.

  • Linc Davis Level 10 Level 10 (155,585 points)
  • JohnS85 Level 1 Level 1 (0 points)

    I have a Brother MFC-J825DW that I used fine before the upgrade to Mavericks.  I have a MacBook Pro Retina and now have lost all printing capabilities.  The scanning works for some reason from both ends but no printing. Brother came out with a bunch of drivers last month, but none have any effect.

     

    I did a reset to factory defaults, re installed drivers, ....reset the printer, still no joy.  Hopefully Brother figures something out soon.

  • Larry0154 Level 1 Level 1 (0 points)

    I was able to obtain a Brother Driver for my new Brother MFC-4710JDW and their customer support was excellent. It works well with my MacBook Pro and Mavericks.

     

    HP was not going to provide drivers for my old 940C & 9800 Inkjets. I'll never go back to HP.

  • fireflymd Level 1 Level 1 (0 points)

    I just purchased a new iMac, migrated everything from my old iMac, and downloaded Mavericks and it did not find my printer wirelessly.  I had to turn off my old iMac which was connected through WiFi to the printer.  When I turned the printer on (with my older iMac on), Mavericks identified the printer only as part of my old iMac.

     

    Once I turned my old iMac computer off, turned off the new computer, then turned the wireless printer on, then turned my new Mac back on, it discovered the printer and scanner and I was able to print wirelessly.  It took awhile, however--it found the scanner part of my printer before it found the printer. 

     

    It's bizarre that I had to turn the old iMac off and "re-find" the printer.  Also bizarre that it took some time to find the printer portion of the multi-function printer--it found the scanner before finding the printer.

  • stangale Level 1 Level 1 (0 points)

    I too, cannot print to network printer (pc on XP) after installing Mavericks. Resetting, deleting, and reinstalling doesn't help. Drivers are correct. The printer says its paused but it won't respond to"resume". this configuration worked perfectly for two years before installing Mavericks. (This happens to be a Brother printer but I don't think it matters.)

  • EliasKuk Level 1 Level 1 (0 points)

    After installing Mavericks i cannot print Canon MF4018 anymore on my network printer.

    The printer has connected to a Windows XP pc, i see it under settings Windows printer but when i launch a print the printer goes into "pause" state. The message i see is "unable to connect to printer".

    I had this connection since Snow Leopard > Mountain Lion and it has always worked print Canon MF4018 - Ghostscript.

    MacBook Pro, OS X Mavericks (10.9)

     

    Please, help me!!

  • ileanell Level 1 Level 1 (0 points)

    One of my users is having the same problem. After the latest update she's not able to print to our Canon iR3230 UFR II. I deleted the printer, Resseted the Printer Systems, re-installed the driver and still she is getting the same error message "unable to connect to printer" and then it goes to 'pause' state. There's gotta be a workaround to this issue. Can some one help? Thanks!!!

  • Josue17 Level 1 Level 1 (0 points)

    Hi i am also having the same problem, i have been connected wirelessly to an HP laserjet 1020 for over a year and ive had no problems but since the update to Mavericks i am getting the same problem saying "unable to connect", then i click resume and the same error message over and over, regardless of whether it is a wireless or wired connection. We've reset the printing system, reinstalled the printers etc. and still nothing has worked. Does anyone have any idea what to do? I've tried everything on the troubleshoot websites and done all the things suggested but nothing has worked at all. If anyone can help id be really appreciative thanks!!

  • jokacola Level 1 Level 1 (0 points)

    Me too. I have two printers. One (a newish Oki) is connected to router and connects ok from iMac over wifi. The other is a Samsung hosted on an XP PC on network connected via PC USB. This has worked fine up til now from iMac, but I cannot connect to this one anymore since installing Mavericks. I've tried the whole reset / re-add routine and downloaded the latest drivers from Apple.

     

    Seems like lots of people are having similar problems.

  • cdalpiaz Level 1 Level 1 (0 points)

    For me is the same. I always printed on a HP DeskJet over wifi (the printer was on a xp PC), but now, since the Mavericks upgrade it does not work anymore...

     

    I hope that Apple will solve this... I really don't want to change this printer (an old, strong and always working one).

Previous 1 2 Next