5 Replies Latest reply: Oct 30, 2013 12:46 PM by Jerrold Green1
Fritz Anderson Level 1 Level 1 (0 points)

This is a disaster.


I just downloaded two .xlsx Excel documents, and attempted to open them in the new (2013) Numbers.


These were the simplest possible documents. 101 rows, 17 colmns, no header/side labels. I don't think it included any calculations at all. My coworker used Excel simply to format her data as a table.


The imported Excel table is almost completely blank. A column of dates, and a couple of columns of literal numbers survived. It lost all of the text. I'm sure the column widths were lost. If you try to edit a cell, the editing bar at the bottom does nothing; it has no content, it does not respond to keys or clicks, it stays blank and unresponsive when you select a cell. If you type an = in a cell, there is no expression builder, and clicking in other cells to add them to a calculation merely changes the selection to those cells.


In iWork 2009, the apps posted a notice when they couldn't make a 100% faithful import — and in my usage, those were for missing fonts, not absent functionality. No such notice here.


My question:


Is there any way I can read at least a spreadsheet that makes no use of Excel features?



Further remark, but not a question


I had heard that the days were gone when people had to install Office because that's what they use at work. I managed to get away without using Office from 1989 to this day. I think it's ironic that at the moment Microsoft lost its lock on productivity tools, I am now forced to install Office.

MacBook Pro with Retina display, OS X Mavericks (10.9)
  • Jerrold Green1 Level 7 Level 7 (29,950 points)



    If Numbers worked for you in the past, it will continue to work for you for at least the short term by continuing to use version 2.3. Maybe things you can't do without will be added back into version 3.0. You don't have to board that ship right away.



  • Fritz Anderson Level 1 Level 1 (0 points)

    Forgive me, this is not practical advice.


    I installed Numbers 3. From the Mac App Store, there being no other way. As is its practice, MAS, wipes out every trace of previous versions of the software it replaces. Numbers 2.3 simply does not exist on my machine.


    Yes, I have Time Machine backups. Have you tried drag-installing iWorks applications? They will not run. They rely on system-level frameworks that I am not confident I can dig out of Time Machine.


    No, I do not have my original distribution media for iWorks. I bought iWorks nearly six years ago, when computers still had optical drives. It happens I have a couple of 3.5" floppies from the first developer-tools releases in 1984, but those are relics. I don't have the DVD (or CD?).


    If I did have the DVD, it would not contain version 2.3. 2.3 came from an Apple update I downloaded from the support site five years ago. I challenge you to give me a live URL for that updater.



    P.S. Perhaps I am oversensitive, but I think the implication is gratuitous, that only a fancy-pants rocket scientist would want to import a spreadsheet that contains 100 lines of dates, text, and numbers in 17 columns.


    When one double-clicks an .xlsx file, Numbers opens it. Import of Excel files is not an advanced future direction. It is an intended function of the application today. Numbers responds to double-clicking .xlsx files today. If it were not an intended function, it would not attempt to open the file; or at least it would post some kind of alert that the operation is not yet implemented.

  • keg55 Level 5 Level 5 (7,030 points)

    Fritz Anderson wrote:


    If I did have the DVD, it would not contain version 2.3. 2.3 came from an Apple update I downloaded from the support site five years ago. I challenge you to give me a live URL for that updater.


    Here is a link to download iWorks 9.3 update which includes v2.3 of Numbers. Hope this helps!

  • Fritz Anderson Level 1 Level 1 (0 points)

    I regret the testiness of my earlier posting.


    I found the iWork '09 folder in my Time Machine backup, and pulled it back in. I didn't have to do anything about the system components — they were still installed.


    When I opened the problem file in the old Numbers, I had the same problem. That eliminates Numbers 3.x from the equation.


    I'm downloading the current NeoOffice (Java, sigh). I've filed a bug report rdar://15351913.


    I'll mark this answered (I see someone else has posted while I wrote this, and I'm interested to see what he says.)

  • Jerrold Green1 Level 7 Level 7 (29,950 points)



    Unless you moved or deleted the old version it is still right where it used to be: Applications > iWork '09. It is not true that there was an automatic deletion.


    Take a look there.