Previous 1 4 5 6 7 8 Next 519 Replies Latest reply: Feb 16, 2015 8:08 AM by Sarah24 Go to original post Branched to a new discussion.
  • olaspequenas Level 1 Level 1 (0 points)

    My wifi issue is a little different. Since upgrading my 2012 Macbook Pro to Mavericks, the computer loses signal in my office whenever I'm bring the laptop between different wifi router signals. Even though our network is universal through the building (same name and key), and I've saved it as a preferred network, the computer acts as if it's searching for a new network, dropping all connection and going into an endless search. Selecting the right network from the list does nothing to help it handshake.

     

    The only way I'm able to get back online is turning off the wireless and then turning it back on, at which point it grabs on no problem. I also don't have an issue when putting the computer to sleep as long as it is on the same router access point when wakign up, or when I go to a different network completely (like when I bring the laptop home).

  • SARCON Level 1 Level 1 (0 points)

    Foolishly clinging to the belief that Apple would have fixed the Maverick wifi problems if it was MacOS related, I replace my Linksys E2000 router--no luck. Then, misguided in a post that blamed all Cisco routers, I installed an Airport Extreme. The disappearing network phenomena is now worse than it was with the Cisco routers. It all started when I installed Maverick, but I did not even consider that it was a MacOS problem that is being ignored. Disabling Bluetooth (and therefore the wireless keyboard & Trackpad) did not change a thing. Why are so many customers spending months trying to figure out a fix while Apple appears to remain silent on the issue? Did they mass-recruit out of Microsoft?  Twitter #macwifiloss needs more entries.

  • DaverYYC Level 1 Level 1 (0 points)

    Unchecked "Keychain" in System Preferences>iCloud, restarted the router, and restarted my 11" Air a couple weeks ago and have been good with WiFi ever since (MacBook Air 1.3 GHz Intel Core i5 with Mavericks and all updates).  I turned Keychain back on last night and the problem returned instantly, so it's off again.  Nothing to do with ye olde router; several other devices in the house connecting fine as usual.

  • Steven Dunn2 Level 1 Level 1 (0 points)

    As a reminder, Apple does not check these forums. If you want Apple to resolve an issue, submit your feedback directly to Apple using their feedback link:

     

    http://apple.com/feedback/macosx.html

     

    I want this fixed as much as anyone, so please join me and submit feedback so something can actually be done! Thanks.

  • Harvey 137 Level 1 Level 1 (0 points)

    Yes I have a similar problem. My transmission rate droped in half after installing Mavericks. I turn off the wifi and turn it back on and it is OK. But I have to do it after the computer is idle everytime. I called Apple Care and was told that they are aware of the problem and are working on a patch to fix it. Not everyone ended up with this issue. So they said I could wait until the patch comes out, hopefully by the end of the year or I could re-installl Mavs. which is a 9 hour process. Seeing that the computer is working fine and I can turn off the wifi and then back on to bring it up to speed I decided to wait on Apple to fix it.

  • scottfromhigh peak Level 1 Level 1 (0 points)

    I have had the same problem and it is now resolved. I requseted assistance from an Apple Adviser (this is free as it is an issue they know about) - arguement to say they should universally solve it then! anyway the adviser was great and took me through a couple of steps removing some .plist files and a restart, only took 10 minutes and now all is fine. Sorry not very techically minded but wanted to share this as I know there is hope. Get hold of Apple and they will solve it for you.

  • SpecialBlend Level 1 Level 1 (0 points)

    I am having the same problem and it is quite annoying.  I have submitted a bug to Apple.

  • supersleb Level 1 Level 1 (0 points)

    I have a definitive guide from apple how to fix the problem. The following is the email received from apple support this afternoon i hope this helps :-) :

     

    First, apply the update from http://support.apple.com/kb/DL1672 and restart the mac


    If after testing you still have trouble do the following:


    Go into


    Finder>go>computer>Mac HD>Library>Preferences>sistem configuration


    and remove to the trash the file named com.apple.AutoWake.plist


    restart the mac and test.


    If these steps didn’t help, please give us a callback so that we can solve the problem with you


    thank you for calling AppleCare

  • Chisleu Level 1 Level 1 (0 points)

    That patch doesn't apply to Mavericks...

  • supersleb Level 1 Level 1 (0 points)

    OK so I have been emailed a bunch of times apprantly the patch from Apple doesnt work it is not for Mavericks... Sorry, dont shoot the messenger! Apple, shame on you for tying to palm me off! i will be trying the other suggestion tonight though, I will report back with any progress. I will also be contacting Apple support again to complain about the duff advice!

     

    cheers :-) keep smiling - at least our macs make great looking paperwights!

  • Harvey 137 Level 1 Level 1 (0 points)

    I am sorry I did not mean to shoot the messenger. By the way Apple Care is telling people to try this patch also: so they do not even know it does not work on Mavs. Duh Apple are you guys home? 

    I talked to Apple Wireless last night and this is their  take. There is more than one issue with Mavs and wireless.

    There are connectivity problems where people cannot connect at all to the net via wireless or they connect and then it drops 5 minutes later.

    And the there is the issue like I am having. When my Mac returns from a prolonged sleep or shut down it starts up on the 2.4 GHz with a low transmission rate when it should start up in the 5 GHz band with a high transmission rate.  So lucky for me at least I have something working.

    And all I have to do is shut off and turn on the wireless one time and it  works in 5 GHz. And it will go back and forth between bands as I go thoughout the house moving far from the base station and then returning to the base station. As long as the Mac is live and not sleeping it will stay on 5 GHz and or go into 2.4 if I get at the other end of the house.

    Now apparently according to the Apple Care (I was talking to a wirelss tech and not a regular AC tech) they are working on multiple condectivity problems wtih Mavs. I am curious that I do not have com.apple.AutoWake.plist in preferences. I should be able to remove it and then reboot and my Mac should rebuild this program. So maybe that is my problem??? Was autowake delted in download???

  • Chisleu Level 1 Level 1 (0 points)

    They can see it is for Mountain Lion, but they didn't notice when they were telling people. My tech support gentleman suggested the same thing and noticed it wasn't for 10.9 after I tried to install it (again.)

     

    I've sent in a packet capture showing the ping latency. Running a constant ping (5 times per second) solves the network latency issue. I agree that it sounds like power saving features of mavericks used to get it over the 12 hour hump.

     

    Hopefully, they enable us to fix that.

     

    I still can't Airplay without disconnection however... I suspect that the update to the apple tv is to blame for that...

  • msitgroup Level 1 Level 1 (0 points)

    I think I've found the root of the problem and a solution (well, it works for me anyway).

     

    If Bluetooth is enabled and you have a Magic Mouse (as I do), I have issues with wireless recovering correctly after waking up IF the Magic Mouse isn't switched on ready to reconnect. If the mouse is switched on, wireless reconnects to the wireless network flawlessly.

     

    This isn't always convenient as I don't always carry my Magic Mouse with me thus need to ensure Bluetooth is disabled in order to overcome the erratic reconnection of wireless.

     

    With a combination of a couple of utilities, I've configured my macbook pro retina to disable bluetooth on sleep and to reenable it on wake after 5 seconds.

     

    The utilities I have used are: blueutil and controlpanel v1.4.0

     

    This has FINALLY given me a tolerable workabout for an horendous problem.

     

    The solution of manually disabling bluetooth or toggling wi-fi on and off is an annoying workaround, at least this method is automated.

     

    Thinking more about it also, it's probably not just the Magic Mouse, it's probably anything bluetooth related. I noticed that if i removed the pairing of my mouse and ensured NOTHING was listed in bluetooth devices, even with bluetooth switched on, wi-fi reconnects flawlessly, it only faultered (pretty persistently I'll add) when a bluetooth item was paired (presumably attempting to connect to it and clashing with the wi-fi activity).

     

     

    Downloaded utilities from:

    blueutil - http://www.frederikseiffert.de/blueutil/

    control panel - http://www.controlplaneapp.com

     

    I then created two shell scripts called bluetooth-on.sh and bluetooth-off.sh containing the following

     

    bluetooth-on.sh

    #!/bin/sh

    blueutil on

     

     

    bluetooth-off.sh

    #!/bin/sh

    blueutil off

     

     

    I then used the Sleep/Wake features of the ControlPlane application to run the scripts at sleep/wake. You'll need to chmod u+x the script files to make them executable.

     

    I really hope this helps someone! If it does help, please give credit where it's due to the developers of the software and to me for hopefully (and finally) finding an half decent and non-intrusive workaround.

     

    Thanks

     

    Mark Smith

    msitgroup

     

    P.S. Incidentally, the SMC and PRAM resets + other tricks such as adding network locations did nothing for me, only the bluetooth disabling seems to fix it on my MBP. I've a feeling it may have only affected other people coincidentally with a combination of their magic mouse being switched on already, bluetooth already being disabled already etc etc. This has been through hours of different scenario testings and I can now guarantee using the above software packages that my MBP starts up with wireless working every single time whereas before, it was problematic at least 3 in 4 wakeups.

  • Nikolaus Heger Level 1 Level 1 (15 points)

    I wonder if 10.9.1 fixes it?

  • msitgroup Level 1 Level 1 (0 points)

    No, it doesn't for me Nikolaus! After speaking to Apple, I don't think they actually consider this a wide-spread problem. They seem to treat each report as an isolated incident and give the same support for an ineffective fix!

     

    Severely disappointed with Apple on this one and this will probably be the last Apple product I'll buy to be honest.

Previous 1 4 5 6 7 8 Next