4 Replies Latest reply: Oct 30, 2013 5:11 PM by colingoree
EllieBieberx3 Level 1 Level 1 (0 points)

I dropped my iPhone 4s down the toilet because I saw a spider on the seat and jumped, causing me to drop it down the loo. I fished it out and dried it off. The phone was on so I tried to turn it off so it didn't fry the inside of it. I held down the power button and the usual "Slide to power off" slider came up. I tried to swipe it and the phone wouldn't do it. I kept trying to swipe but it wouldn't let me and the screen started to do something like this: http://www.youtube.com/watch?v=Ij7r2dyqBMg

 

It then stopped and stayed on the homescreen but slowly faded to a plain white screen and wouldn't do anything. I took out my SIM Card and dried it off because I didn't want it getting damaged. Then it turned to a black screen and once again did nothing, so I plugged it into my Macbook and it vibrated, indicating that it was being charged. Also, my iTunes & iPhoto icons started bouncing. The screen was still black so I unplugged it and left it on my bedside drawer to do whatever. About an hour or so later my boyfriend pressed the home button and the screen turned on, but it looked like a cloudy sky. It wouldn't do anything else so again, I left it for about an hour.

 

I then tried turning the phone on and the Apple logo appeared. The buttons work fine and the home screen with the date & time appeared, but the only thing that wasn't showing up was my screensaver, it is blurred out. I put my SIM Card back in and it says "SIM Faliure" on the screen & at the top where it usually says your network etc. (T-Mobile, 3G and all that) it just says "Invalid SIM" instead. Also, I can't use the touchscreen. I can't swipe up for the options or camera, I can't swipe to turn it off & I can't unlock the phone. I don't have any rice in this house as me & my father are allergic to it so there is no point in buying it.

 

It's a replacement phone & I've had it for less than three months. What else can I do? Also, there's a strange smell by the power button, but nowhere else on the phone.

 

 

Help? Thanks - Ellie xo


iPhone 4S, iOS 5.1.1