Previous 1 2 3 Next 218 Replies Latest reply: Dec 7, 2015 6:50 AM by jdonshik
realtwang Level 1 Level 1

I have been having an issue with Mavericks unmounting my external USB disk suddenly, followed by a Finder notification that the disk was ejected improperly.  This has only started since upgrading to 10.9.  I have tried unchecking "Put hard disks to sleep when possible" in System Prefs, but it has not helped.  Weirdly, the drive icon does not disappear from the desktop when this happens, so I don't know if it's actually ejecting, or if the system just thinks it is.  At any rate, it does appear to be a bug.


MacBook Pro (17-inch Early 2011), OS X Mavericks (10.9), 8GB RAM
Reply by eM_NL on Nov 10, 2013 8:31 AM Helpful

I have the same problem (after upgrading) on Mac OS X 10.9 (iMac 27' late 2013, Fusion Drive 1TB).

The hard disk is 2TB / USB 3.0. (directly connected)

 

Here you can see the problem in action http://youtu.be/Zzss358cfKk

All replies

  • mikev123 Level 1 Level 1

    I am having the same problem its a 4TB Fantom drive and it keeps randomly ejecting

  • Brian Bauer Level 1 Level 1

    I'm having the same same issue.

    3 volumes (in 2 usb HDs) disappear from the desktop,

    but they remailn in the Finder sidebar.

     

    However, after sleep, the USB2 Time Machine drive does not

    return to the desktop or the sidebar.

     

    Anyway to report this to Apple?

     

    OS X 10.9

    27" iMac, late 2012

  • PlotinusVeritas Level 6 Level 6

    nope, random HD ejects have been common for years on faulty drives but usually SATA bridge cards in HD enclosures.

     

    common occurrence of a failing SATA bridge card

     

    see here:

    Your dead external hard drive is likely fine! Great hope for your 'faulty' external HD

  • realtwang Level 1 Level 1

    Hey Brian - Glad to hear its not just me. You can report it to Apple here:  http://www.apple.com/feedback/macosx.html

    The more of us that do, the faster it will get fixed.  I've already done it, but please add yours if you have time.

  • realtwang Level 1 Level 1

    Good thought, but this behavior started immediately when I upgraded to Mavericks, so I doubt it's anything to do with my hardware.

  • kharisma Level 1 Level 1

    I'm still running Mountain Lion, which has had the same problem with ejecting external drives with a message saying it had not been disconnected first.  Turned out it was a faulty upgrade in early September.  They finally released a patch which settled things down for a couple of weeks, but now it's happening again.

     

    I have all new equipment - new Mac Mini, new external drives (Seagate, one powered, one unpowered).

     

    So I also cannot see that this is because of faulty cards.  I have been holding off upgrading to Mavericks on the grounds of "better the devil you know".

     

    Not happy.  all very well saying that random problems have been common for years, but this isn't random - it's frequent, on new equipment.

  • PlotinusVeritas Level 6 Level 6

     

    kharisma  but now it's happening again..........So I also cannot see that this is because of faulty cards.

     

     

    Seen it countless times, .....9 times out of 10 this occurrence is a faulty SATA card.  Owned many 100s of HD and still own just under 100 of them.

     

    You also just answered you own question with "now its happening again"

     

    But if you dont believe me, thats ok

  • kharisma Level 1 Level 1

    Brand new equipment less than two months old.

    Mac mini replaced after three weeks, so this one is only one month old.

     

    Powered drive only two months old (Seagate).

     

    Problem started with upgrade of ML released early September.

    Stopped for a couple of weeks after recent patch.

     

    Now it's happening again.

     

    So the SATA cards on both the Mac minis are bad ... is that what you're saying?

  • kharisma Level 1 Level 1

    I may have the solution to my own problem - about a week ago I bought a powered hub (USB3). 

     

    The powered external drive (USB3) is plugged directly into the computer (also USB3), but the unpowered drive (USB2) has been plugged into the hub.

     

    I know from experience that some devices don't perform well through a hub.  I'm going to leave the small drive unplugged unless I need it, and see if that helps.

  • realtwang Level 1 Level 1

    Keep us posted on what you find.  For me, it happens without a hub, with the drive directly hooked to the computer.  And PlotinusVeritas, thanks, but it would be the coincidence of the century if a drive that was working perfectly an hour before suddenly went bad the very moment I installed Mavericks.  So thanks for the input, but you're mistaken on this one.

  • hick9 Level 1 Level 1

    Same problem here..Drobo Thunderbolt on Mac Mini worked perfectly until 10.9 upgrade. Now I am getting the same "the disk was ejected improperly" when waking from sleep.

  • eM_NL Level 1 Level 1

    I have the same problem (after upgrading) on Mac OS X 10.9 (iMac 27' late 2013, Fusion Drive 1TB).

    The hard disk is 2TB / USB 3.0. (directly connected)

     

    Here you can see the problem in action http://youtu.be/Zzss358cfKk

  • realtwang Level 1 Level 1

    Thanks for the YouTube link.  That's exactly what I'm seeing.  Are you plugged in direct, or through a hub?  Also would be interested to know if hick9 is plugged in direct.  If you are still under AppleCare, it would be great if you could chop that video down and email it to Apple support.  Is that a possibility?

  • eM_NL Level 1 Level 1

    Yes, it is directly connected on the back of the (iMac) screen.

    On OSX 10.8 everthing was just working fine. I also tested it, without any problems, on my old macbook pro (OS X 10.7).

    I'm not sure what to do next.

Previous 1 2 3 Next