Previous 1 2 Next 22 Replies Latest reply: Jul 9, 2015 10:39 AM by mgshoutman
Marvin Price1 Level 1 (10 points)

The problem manifests after a Time Machine backup.


I have an iMac 24-inch, Early 2008. iMac 8,1

Intel Core 2 Duo, 4GB RAM.


Last week I purchased two  4-Terabyte G-technology G-Drives. Each drive is equip with FireWire 800 and USB 3.0/2.0. In general use they seem to work fine on the iMac.


I designated one drive as a Time Machine Volume. This is where the problem happens.


Time Machine will do the initial backup just fine. Then it runs once per hour with no problem. Intermittently however, Time Machine will fail and report :


“Time Machine couldn’t complete the backup to “hard disk name”.

Unable to complete backup. An error occurred while creating the backup folder.”


Interestingly enough if I try to open a folder on the Time Machine volume using the Finder I get:


“The operation can’t be completed. An unexpected error occurred (error code -50).


If I try to eject the volume I get the irksome “Cannot eject volume because it’s currently in use by one or more programs.”


To resolve this I’ve tried everything, from the banal verifying permissions, to swapping the two G-Drives around, swapping out all the cables, etc.. When the error occurs I go into the shell and check with lsof and always find no software apparently holding or using that volume.


Very frustrating


I can force eject the volume, then remount the volume and things are back to normal. Same with restarting.


This happened under OS X Mountain Lion and is now happening under a clean install of Mavericks.


I thought that even though I don’t see any MDS  related processes using the drive, it might be spotlight, so I told spotlight not to index the volume. Problem still happens.



I’ve found that one person had almost this exact same problem at:


His solution turned out to be replacing the G-Drive with another brand new G-Drive.


Unfortunately, I cannot return the drives to the Apple store because the boxes were tossed out. I also don’t relish trying to explain that the drives work just fine until some glitch that occurs either just before or just after a Time Machine backup.


Does anyone have any suggestions?

Mac OS X (10.7.2), iTunes
  • Marvin Price1 Level 1 (10 points)

    Thank You.


    From the problem description you might not get that I've done a full reset of TM, both manually, and via the fact that I completely wiped existing Mountain Lion system, installed Mavericks, and initiated TM backups from there, to a freshly formatted drive.


    Also, though the problem is manifested by Time Machine, the problem is external to Time Machine. Finder cannot create a folder on the drive and the drive cannot be ejected.


    When the drive is in this problem state, it also cannot be repaired.


    Yet, strangely, lsof show no files are open by any applicaitons on that drive.

  • etresoft Level 7 (27,410 points)

    You can return the drives to the vendor without a box.

  • Monica618 Level 1 (5 points)

    You can also contact G-Drive while the drives are under warranty (one year I believe).


    I have the same problem using Time Machine with the 2T G-Drive and my MacBook Pro. G-Tech emailed me a Firmware Update Utility app and, when that didn't solve the error message problem, they sent me a replacement drive and new cables, twice. The problem persisted; I get one or two backups each day and then the error message. I also can't copy anything to the drive and have to force eject it, so G-Tech suggested I see how well it worked with the USB cable.


    Time Machine works flawlessly with the USB cable and the G-Drive, so G-Tech suggested it is a problem with my Firewire 800 port. I worked with Apple Care over the phone, doing all the tests suggested in Eric's post - testing with Disk Utility, Time Machines interface with my User Accounts, the Operating System, then resetting Time Machine, etc. and then I took it to the Genius Bar so they could run the tests themselves. All looked like it should be fine (but they were using a 1T G-Drive and all testing was done within 30 minutes)...when I got home, after two good backups, I got the error message again.


    Apple Care finally suggested I make a Genius Bar appointment and sit at the store working with my MacBook, the G-Drive and Time Machine running until I got the error message, to prove the only thing left that could possibly be the cause of the problem, is the port.  I did this last Wednesday.


    It is 9 days later and I got my computer back this afternoon...the logic board was replaced because the Firewire 800 port is attached to it...I got my first Time Machine back up at 5:34pm...and the error message again at 7:34pm.


    The only solution, it seems, is to use the USB cable instead of Firewire. USB and Thunderbolt seem to be the direction Apple is taking, which is why so many people have been posting about this problem, here and elsewhere, with no real solutions from Apple. See this article:


    I hope the USB works for you too.

  • Marvin Price1 Level 1 (10 points)

    It is definitely something screwey with the G-Drives and FireWire 800 implementations. The odd thing is that the drive works fine indefinitely for all other purposes, except Time Machine. Something happens, and it appears to be at the end of a Time Machine backup, that leaves the drive in this weird state of being inaccessible. You can read it, but not write to it. Time Machine gives no indication that there was any sort of problem. This could be a Time Machine problem, but it doesn't happen on brand new LaCie Drives I tested today.


    Since you're not inclined to use your Time Machine backup drive for anything other than Time Machine, you don't notice anything is wrong until Time Machine attempts to run again. Then Time Machine fails due to the state of the drive from the previous Time Machine backup.


    I tested this by watching Time Machine backup successfully 7 time in a row. Each time after the backup I'd attempt to write to the disk. Finally, after the 7th successful backup, I got the error. I could not open a file on the disk or eject. Attempting to open a file on the disk generates an error -50 (what the heck is that?) Attempting to eject the disk gives me a disk in use by one or more programs error. Searching for any application that is accessing the disk in any way provides nothing. Apparently no software is accessing the disk.


    So it is something that happens intermittently, specifically to new G-Drives, right after a Time Machine backup. New meaning the drives with USB 3.0.


    The Vendor (the Apple Store) will not accept the drives back without the box. They will exchange the drives for like devices, but at this point I have no faith in G-Drives for this installation. Apple of course tries to send me through the "Is your hard drive plugged in" script for support.


    So I might have to eat the G-Drives and buy the client new drives from a different manufacturer. I wish he hadn't thrown the boxes away.

  • Monica618 Level 1 (5 points)

    Thank you for the information about your tests on the LaCie Drives, Marvin. I share your frustration.

  • Marvin Price1 Level 1 (10 points)

    Yeah. Bottom line, for some strange reason, LaCie's worked, G-Drives did not...


    Final note:


    I swapped my LaCie drives with my client's G-Technology G-Drives.


    He's had no more problems.


    I also have no problems with the G-Drives on my iMac, but my iMac is a 27" January 2013 iMac13,2, while his is an iMac 24-inch, Early 2008. iMac 8,1. The other person above having the same problem was on an older iMac as well.

  • tunesmith82 Level 1 (0 points)

    I have the same problem with a late 2006 24" iMac and a G-Drive 4 TB. I tried hooking up to the firewire 800, firewire 400, but the drive locks up after one time machine backup with both Firewire methods. I have had to revert to USB even though the USB2 is relatively slow.


    I still like the drive for its more durable construction and that it runs very cool; and eventually I will use it with USB3 on a newer computer. Kind of lousy that I can't use the Firewire 800, since they advertise it as TimeMachine Ready, but I don't really need speedy hourly backups anyway. It just doesn't take that long to backup.

  • ScottD8303 Level 1 (0 points)

    I wanted to let the forum know that switching to the USB port also solved my issue with Time Machine backups.  I have an early 2008 iMac running OSX 10.8.5 Mountain Lion.  Recently my Time Capsule died and I bought a 2TB G-drive to replace it as the dedicated Time Machine backup disk using the FireWire 880 connection.  As with so many others, my initial backup went fine, but after 3 hourly backups, I got the infamous "error creating backup folder" message.  After scouring the numerous threads on this issue, I tried many of the suggestions and the Pondini troubleshooting steps:  rebooting drive and iMac, refreshing the Time Machine plist, verifying/repairing the drive, checking the drive and partition map format types, and unchecking the Energy Saving setting for putting drives to sleep.  Nothing solved the problem for long. I was able to back up manually by force-ejecting the drive, unplugging the FireWire cable from the iMac port, plugging it back in, and running "Back Up Now" on Time Machine.  This became a pain, so I did more research.  I became convinced that this error is usually not caused by a hardware failure, based on numerous post about trying new cables, new drives, and different brands of drives, and even a new logic board (on the theory that the FW port was bad).  The most likely culprit appeared to be a sleep/wake timing issue between Time Machine and the external drive, and the solution that worked consistently was using the KeepDiskSpinning app to keep the drive from going to sleep.  I did not want to use this as it seemed likely to significantly shorten the life of the external drive, but the discussion led me to the G-drive forum. Based on a thread there, I added the G-drive to the exclusion list for Spotlight.  (Interestingly it would not let me exlude the backups.backupdb file on the external drive, saying:  “Backups.backupdb is a Time Machine backup folder. You cannot add it to the privacy list.")  In any event, the backup error soon recurred.  Finally, after reading the above thread, I switched from the 800-800 firewire connection to the USB3-USB2 connection, and that has finally solved the problem.  I've now gone through 3 weekly backup cycles without any errors.  I'm not thrilled that I had to ratchet speed down to USB2's rate, which is why I hadn't tried this earlier, but USB2 works fine for incremental backups and one can always run a manual backup on the 800-800 connection if necessary.  It's just nice to have backups running on automatic again.

  • Brookhaven Level 1 (0 points)

    Thanks for the heads up on G Drives.


    My 2TB G Drive bought from an Apple store here in the UK in September, worked perfectly, until I came back from leave, did some updates to mavericks on my MacPro last month, and then the dreaded "error creating backup folder" message kept appearing.


    After each 'fix', initial backups worked, but it was the subsequent hourly backups that always failed.


    Switching to the USB cable seems to have cured my problem - so far, so good...

  • Alan Chocolate Level 1 (0 points)

    I am also having this problem (same symptoms) with a Toshiba 1TB USB drive, and late 2013 27" iMac 3.2GHz running up-to-date Mavericks 10.9.2.


    The first backup works fine, but the incrementals fail.


    I tried different disk formats (including encrypted and not encrypted), but it didn't matter.


    In the finder, an attempt to create a new folder gives the error in the thread above.


    I cannot eject the drive gracefully; I have to force eject it.


    Any thoughts?  It doesn't seem to be a drive problem...





  • kdphelps Level 1 (0 points)

    I am having the same problem as Alan. Hoping for ideas on how to fix this.




  • Alan Chocolate Level 1 (0 points)

    A "solution" is posted by someone else on a different thread about this problem:  do a Time Machine reset.  It worked for me, and I now have incremental backups working as expected.


    It seems like this is a Time Machine bug.  Apple?



  • kdphelps Level 1 (0 points)

    Great, thanks!



Previous 1 2 Next