5 Replies Latest reply: Jul 16, 2014 11:56 AM by thumproast
hooh Level 1 Level 1

On a new client machine with a clean 10.9 Mavericks install it's not possible to create the calendar account on the 10.6.8 server. When adding the account in iCal client I choose 'Add CalDav account', then choose 'Manual' at account type.

After clicking 'Create' I get 'An unknown error occured'

I also tried choosing 'Advanced' and entering the full search path, port number, etc. Also doesn't work.

 

On a different client, after upgrading from 10.8 to 10.9 Mavericks, the existing calendars on the 10.6.8 server work. I cannot however, add extra server calendars. I then get the same problems as on the clean installed client.

 

Hoping for help, hooh


Xserve, Mac Mini Server, MBP, MP 8core, Mac OS X (10.6.2)
  • ShelterwoodSchool Level 1 Level 1

    I think I got it working.  I could not add the account from iCal directly but it worked when I added it from internet accounts.  Make sure the account is completely deleted, go to Internet accounts in System preferences.  On the right hand side at the very bottom you can Add Other Account.  Choose the add caldav account and choose advanced.  I was able to set everthing up and it added perfectly.  Too bad we can not add the accounts from iCal but at least it worked.

  • pulot pulot1 Level 1 Level 1

    did not work for me.

    still searching......

  • goldensteve Level 1 Level 1

    I can see a difference, but can't think of a workaround.

     

    Clean Mavericks Server - ML or other client, when connecting the client will ask about the security certificate. Accept the cert and the process completes fine.

     

    Mavericks client does not generate that certficate question and hence that's where it is hanging up.

     

    So, if anyone knows how to provoke that cert acceptance, then we have a workaround maybe.

  • thumproast Level 1 Level 1

    I got it to work by adding a new account first in ical

    then capitalizing the url

    then using the username lowercase (it always was lowercase)

    then using /principals/__uids__/xxxxxx/

    then selecting port 8008

  • thumproast Level 1 Level 1

    btw no cert on that server.