Previous 1 2 Next 23 Replies Latest reply: Aug 7, 2015 6:04 PM by jie_ramirez
Dutchboy777 Level 1 Level 1 (30 points)

I am unable to open a Numbers file.  I get the "The index.xml file is missing" window.  I see that this has happened a lot on Pages and some on Numbers.  Trying all the recommendations posted here and other places, none of them work.  I could open the file with Numbers 2.1.  I pulled an older copy of the file from Time Machine and tried to open it with Numbers 2.1, but I get the same result.  How very odd.  I've also tried Numbers 1.0.3, to no avail. 

 

Using "Show Package Contents" I can see this:

 

Screen Shot- Numbers.png
I've tried unzipping the index.zip fike, does not help.
I hope someone has some suggestions.  Thanks in advance.
  • Kevin Brock Level 4 Level 4 (2,380 points)

    I'm having the same issue now and also have had no luck with the tips posted elsewhere about adding the .zip extension so as to look into the packet.

     

    My file *had* been (and still is) on iCloud. I download it, attempt to open it and that when I'm greeting with this alert. I don't know that iCloud is the culprit per se, seeing as how so many people have encountered this problem—with no mention of iCloud. I just thought I'd add that to the details though.

     

    Hopefully, there's a workaround or fix for this. But my packet looks identically to yours.

     

    That index.xml file is terribly critical though. I extracted the index.xml file from an older, offline, version of this same spreadsheet. I inserted this xml file into the "newer" version of the Numbers documents. The result is that the new file now looks like the old one. So the index.xml file is really the heart of the spreadsheet. Without it—we essentially have a packet of nothing.

  • Big_j Level 1 Level 1 (0 points)

    I'm having same problems since upgrading to Mavericks. Before upgrade no problems ...... since upgrade having problems with opening all pre-existing 'Numbers' files - getting pop up merssage   "The Document "XYZ" is Invalid . The index.xml file is missing".

    This must be connected to something in Mavericks upgrade - I have created a new 'Test' Pages document, and saved as a new filename - this one reopens fine....... so whatever the problem is (APPLE Developers !) it is affecting Numbers files that existing in previous IOS.

     

    Could we see some acknowledgement to this problem from APPLE please ?!

  • Big_j Level 1 Level 1 (0 points)

    Had any responses with tried / tested ideas on how to fix ? Have you recently upgraded to 'Mavericks' ? Please see my post in thread.

  • Big_j Level 1 Level 1 (0 points)

    Quote from APPL:E Support web site below re New iWorks - this may have something to do with the cause of our problems ....... I don't have the new iWorks version, only the IOS upgrade. Not sure from reading this whether it should make any difference if not upgrading to the new iWorks version.

     

    "Reverting documents created in the new iWork for Mac applications to the previous version’s file format

    New or existing documents you open in the new versions of Pages, Numbers, and Keynote use the new unified file format. These files can’t be opened in the previous versions of the iWork applications. To revert the document file format to the previous version, you can do one of the following:

    1. Documents that you haven't edited can be reverted to the iWork ’09 version by selecting File > Revert To.
    2. If you have edited the document and want to preserve the edits, you can save it as an iWork ’09 document by selecting File > Export To, then choosing Pages ’09, Numbers ’09, or Keynote ’09.
  • Big_j Level 1 Level 1 (0 points)

    Sorry .... any reference to IOS in my posts above should read OSS (slip of the fingers !)......

  • Kevin Brock Level 4 Level 4 (2,380 points)

    Sorry for my absence in the conversation. I've got a lot going on right now.

     

    But hopefully the iWork team won't mind me saying that I have been contacted directly, by them, to get more info. about my usage and the circumstances leading up to this issue. I've given them as much information as I could. Hopefully it will help them to find a fix for this issue.

  • Lars Soerensen Level 1 Level 1 (0 points)

    I just had a similar problem. Yesterday I created new spreedsheat in Numbers and saved it in Dropbox.

    Today when I wanted to access it, I got the errormessage "Index.xml file is missing".

     

    To jump to the conclusion, it turns out, that installing Numbers 3.x from App Store does not uninstall the previous version from iWork'09, so I actually had both running in my Dock, and didn't notice that I tried to open my new spreedsheat with the old Numbers. Now that I manually deleted the old iWork'09 folder from Programs, the problem is gone.

  • tipsam Level 1 Level 1 (0 points)

    Having the same problem but am afraid to uninstall iWork '09.  Frustrating!  I wish I could uninstall the new Pages and Numbers that I upgraded to last week....  Also, on the attached screen shot, I am unsure of which button to push... I thought I wanted to preserve the original, but I guess that brings me back to the original problem of what this thread is about!!

     

    upgrade pages '09.png

  • SGIII Level 5 Level 5 (6,845 points)

    No need to uninstall iWork '09. 

     

    If you're confused by the buttons, you could keep your old documents in a safe place in case you want to open them in the future with the old version.

     

    Then in Finder just make a copy of any document you want to open in the new version, move it somewhere else, and open it with the new version (the one in your main Applicatons folder, not in the iWork '09 subfolder), choosing the default  'Upgrade' option.

     

    The same effect (leaving the original untouched and starting a new document) is achieved by choosing 'Edit a Copy' above. But if you want to be sure...

     

    SG

  • tipsam Level 1 Level 1 (0 points)

    I spoke at length with tech support yesterday and this is a problem that Apple is very much aware of and working on.  They plan on having it up and running smoothly in a few months.  He said that it would be a good idea to keep both icons for the old and the new in the dock.  If a doc or spreadsheet won't open in one, close it and try the other. So yes, for the time being, hang on to the old Numbers and Pages!

  • PeterBreis0807 Level 7 Level 7 (33,720 points)

    You are trying to open a new Numbers 3 file with an older Numbers 2 application.

     

    See the following advice for Pages it is virtually the same for Numbers:

     

    https://discussions.apple.com/thread/6043690?tstart=0

     

    Peter

  • Arnorf Level 1 Level 1 (0 points)

    Ive had a similar problem.

     

    Wrote a Numbers file on my Macbook saved it to my Desktop, transferred to a Flash Drive and tried to open on the iMac.

     

    IMac responded with the "numbers index.xml missing file" message. Cutting out all the useless steps that didin't work, I read this and other posts. Through them I realised that when I upgraded applications, OSX overwrite the old ones.

     

    A search using Spotlight revealed I had two versions of Numbers on the Macbook and three versions on the iMac.

     

    The file I wrote on the Macbook was in verson 3.2. My iMac has a Numbers icon on the Dock. In my ignorance I didn't realise that this icon was linked to a version 2 Numbers. It would appear that applications running in the Dock are seen by OSX as the 'preferred' applications.

     

    If you try to open a version 3.2 file directly the OS doesn't go looking for the correct application, it defaults to the Dock application!!

     

    I haven't tried putting both versions on the dock (?) but opening the version 3.2 application on the iMac and then opening the file written on the Macbook (also versin 3.2) worked!!

     

    Maybe taking applications off the Dock would force the OS to look for the correct application? Get back to you later on this.

  • bick-aus-bremen Level 1 Level 1 (0 points)

    Someone sent me a numbers-document. I tried three different ways to open it:

    1. by double-clicking

    2. with right-click File/Open with...

    3. Starting the program first, then "open file..."

    Nothing worked for me, 2. and 3. neither with numbers 2.0.1 nor with 3.2.

    1 to 3 produced the same error message: "Das Dokument ist ungültig. Die Datei "index.xml" fehlt."

    This http://nzgeek.org/topic/38882/iwork-pages-tip-for-missing-indexxml brought me on the right track. These are the steps to open these corrupted files:

    1. Duplicate the offending file (just in case)

    2. Rename the file, either in the finder, or in the information window (command + i)

    3. Double click on the .zip-file, this produces a .numbers document.

     

    In my case, I couldn't open it with numbers 2.0.1 but only with 3.2, so I guess it was made using the newer version.

     

    Hartmut, Quedlinburg/Germany; MacBook Pro, 10.9.2

  • rexlast Level 1 Level 1 (0 points)

    My solution if it's useful is to download the latest version of Pages 5.1.1. Then use Finder to locate your pages file and right click on it. Open With 5.1.1 and it should work. Nul points to Apple for that.

     

    Rex Last

Previous 1 2 Next