4 Replies Latest reply: Jan 15, 2014 11:59 AM by traveller1976
0pinionated Level 1 Level 1 (0 points)

Background:

Ok i have 2 iPads and both suddenly developed wifi dropout problems when I updated to iOS7 (which i think is a great OS btw).

BUT my wife loves watching streaming TV on them, so she asked that i try and fix the problem.

I've seen hundreds of posts and everyones blaming the OS or the router.

Both iPads worked fine before the iOS7 update, and now they dont.  Says to me its the problem is in the iOS7 update...

BUT i played around with the router to see if i could compensate for the problem until Apple release a fix.

 

The FIX:

What is working for me is - go into your router admin, go to WMM (Wireless Multi Media).

In my router I had the following three options all turned ON when i was having problems.

     - WMM support

     - No Acknowledgement

     - PSS (Power Save Support)

I turned all of these OFF.

Problem fixed for me!! on BOTH iPads.

 

Probable issue:

One or more of these special Multi Media settings is being mishandled by the update, so somehow the update either shuts down the wifi after a few minutes to save battery life, or loses the plot relating to WMM settings.

 

Interested to hear from you and see if you benefit from this or its not the answer for everyone.

 

Cam


iPad 2, iOS 7.0.2, Wifi dropout
  • acesinica Level 2 Level 2 (155 points)

    Hi Opinionated,

     

    Glad it worked for you. I remembered reading http://support.apple.com/kb/TS3727 that says WMM has to be on or else idevices would have trouble joining 802.11n. Somewhere else I've read that WMM is necessary for Airplay.

     

    But I've tried changing WMM on and off, it didn't make a difference for me. I can join regardless.

     

    My router is from Netgear and I just checked again, it doesn't have the other two settings (No acknowledgement and Power Save Support) as options.

     

    It's tough troubleshooting for folks about wifi here, because the forum is free text format. Most reports come in as "wifi doesn't work" with not much further details about the current settings of the router.

     

    One scenario I can think of is the iphone, right after an update, has lost its IP address.

    It goes to the router with a dhcp request, the router looks up its dhcp table but finds this iphone's mac address still in there, lease not expired yet, and so doesn't give a new ip address.

     

    In this situation the iphone will keep requesting for a dhcp ip and the router will continue to ignore it until the existing lease expires.

     

    Usually this type of issue can get cleared up if the router is power cycled first, followed by a reset-network-settings on the iphone. I don't know how or why this limbo state is arrived at in the first place. I've been hit by it on rare occassions, where the wifi network can be seen but not joined.

     

    My Netgear router is a new one, purchased after my existing routers not being able to keep up with VoIP apps like Skype and Vonagae (VoIP calls getting dropped). After tinkering around with different settings, I realized that my time is more valuable than the cost of a new router. Got the Netgear on sale, and no more problems with VoIP apps.

     

    Sometimes I wonder if idevices work better with Apple branded wifi routers?

  • 0pinionated Level 1 Level 1 (0 points)

    Hi acesinica,

     

    Nice note.  Yes, i've got a brand new netgear router too. My issue was that since iOS7, the iPads always drop their wifi connection after a few mins, not that they wouldnt connect. You then need to go to the settings and manually activate the right wireless network again.

     

    That link you provided is fairly definite that it should be on...  I also have AirPlay and AppleTV.  Both of these seem to still work fine with those 3 settings turned off (streamed a full HD movie last night) althought i agree by WMM's own description these settings are made to improve streaming media performance!  As i said im my first post, i think iOS7 has messed up how these are being handled up somehow.

     

    Your DHCP network logic seems spot on as it aligns with many comments made about resetting wireless settings to factory defaults while in airplane mode and rebooting router.

     

    There's no question that for years these iPads worked fine, but post iOS7 they couldn't hold a wifi connection for more than a few mins.  And for several days now, they've had stable connections with those settings off.

     

    Note - just went and turned those WMM settings back ON andddd....... the iPads lost wifi connectivity when streaming after 3-5 mins.

     

    As changing just the WMM setting didnt work for you I'll try various combinations of those 3 settings and see if I can narrow it down.

  • 0pinionated Level 1 Level 1 (0 points)

    Ok I've played around with these three settings further and narrowed it down.

     

    The fix works with just the "No Acknowledgement" setting being turned OFF.

    my Netgear router help describes this feature as "No acknowledgement, which is useful for real-time apps such as voice and streaming media, which can't afford to re-transmit packets because of lower latency and jitter tolerance. And the re-tried data will arrive too late and become meaningless anyway."

     

    So you can leave WMM on (consistent with Apple's advice above) and you can leave PSS on.

     

    Apple - you should look at how iOS7 handles this setting!!  Maybe fix it for 7.0.4 

  • traveller1976 Level 1 Level 1 (0 points)

    I saw this fix on another post and can attest that it works.  I suffered from dropped connections and forgotten passwords, on both an Ipad1 and Ipad2, on both a Netgear and a TPlink router.  Solution - Always use the Other option to manually enter network name, security type and password.