1 Reply Latest reply: Nov 2, 2013 1:25 PM by Blueberry
Shelvinho Level 1 Level 1

I've just installed Mavericks from snow leopard and every app works except for Logic studio 8 won't launch as it says it's incompatible with this mac. Do I have to re-install Logic studio again or does it not work with mavericks. I'm pretty annoyed if it doesn't.


Logic Studio, OS X Mavericks (10.9)
  • Blueberry Level 4 Level 4

    You are correct:  it does not on Mavericks. It was released many many years ago, replaced by Logic Pro 9 and Logic Pro X, doesn't support 64-bit, etc. It is very old software, that doesn't work with the latest OS X version. Not a total surprise...