Previous 1 2 Next 19 Replies Latest reply: Mar 18, 2014 6:45 PM by Kaemaahl
Rour Level 1 Level 1 (0 points)

Hi everyone:

 

Background: I changed my Apple Id password after updating to OS X Mavericks. Soon after that, OS X sometimes asks me for keychain password (not always), sometimes at the beginning and when I use Safari, or try to access to Icloud (which I can only access online on safari) through system preferences.

 

Problem #1:

-  When I use First Aid Keychain and enter my User name and password, two options appear: Verify and Repair.

- If I hit verify, some things appear in black, some other in red and some in blue, the following things appear:

    In red:

         ~/Library/Keychains/login.keychain (is not a valid keychain file).

   In Blue:

        Keychain password of  ~/Library/Keychains/login.keychain (100022) not verified

       Adjustments of  ~/Library/Keychains/login.keychain (100022) were not read (couldn´t been read)

  In Red

        ~/Library/Keychains/login.keychain (-25295) was not opened (couldn´t been opened)

  Problems have been found. Select repair.

  Verification error.

 

- Then, if i hit repair It will ask me "for keychain agent password".

And honestly I never (that I remember) created a keychain agent password. Where can i find that?, what kind of password is that? What I know is that it is not my Apple Id password or anything close to it.

 

Problem #2

- If try try to restore my default keychain by selecting Preferences - General, it will tell me that the "keychain has not been found". And wont restore anything.

 

I must say that I have read many of the discussions available and many of Apple suggested solutions, and nothing seems to help.

Any help would be deeply apreciated.

 

Best regards. (Sorry for my english, not a native speaker, my computer is in spanish and did my best to translate what I have seen)

 

Macbook Air, OS X 10.9, 2 GHz Intel Core i7, 8GB 1600 Mhz DDR3


MacBook Air
  • John Galt Level 8 Level 8 (37,920 points)

    The login Keychain is corrupt and cannot be repaired. Since it is no longer useful to you, you should delete it.

     

    Screen Shot 2013-11-02 at 8.38.04 PM.png

     

    A new Keychain will be created automatically. You will need to re-enter passwords for any service that requires a password.

  • Rour Level 1 Level 1 (0 points)

    Hi John: Thank you very much for you kind response.

     

    From the photo you have posted I see the following in my computer:
    Captura de pantalla 2013-11-02 a la(s) 19.18.48.jpg
    I dont seem to have the delete option and the icon is not a padlock (why?) I think I am gonna use the following:
    Captura de pantalla 2013-11-02 a la(s) 19.19.11.jpg
    I will go to file an "delete keychain login". Is that the right thing to do?
    One more thing (sorry for asking too many questions!).
    I have had problems with accesing Icloud using system preferences, and I realized that, for example you have an Icloud Padlock icon, and I dont. Is there anything I can do to fix that? Thank you very much for your time and willingness to help.
  • John Galt Level 8 Level 8 (37,920 points)

    Rour wrote:


    I will go to file an "delete keychain login". Is that the right thing to do?

     

    Yes.

     

    You must unlock the padlock first, using your Mac's login password.

     

     

    for example you have an Icloud Padlock icon, and I dont.

     

     

    I believe the only reason I have an iCloud Padlock is that I am using iCloud Keychain:

     

    Screen Shot 2013-11-02 at 9.56.15 PM.png

  • Rour Level 1 Level 1 (0 points)

    Dear John:

     

    - I deleted Keychain login, (and only have left Local items, System and System Root).

    - I did not have the option of unlocking the padlock (because I did not have Padlock icon in Keychain Login.

    - When I deleted It did not ask me my Apple Id.

     

    After I did that, I restarted my computer and I was asked again "Os X keychain to local Items". I could reenter to my computer and I have checked and i see the following:

    - I new keychain "login" but with an icon that is not a padlock.

     

    Captura de pantalla 2013-11-02 a la(s) 20.22.12.jpg

     

    I would appreciate your comments, maybe I did something wrong!

     

    Thanks again!

  • John Galt Level 8 Level 8 (37,920 points)

    You did nothing wrong. Please follow the instructions here:

     

    OS X: Keychain Access asks for keychain "login" after changing login password

     

    It should display in Spanish for you.

     

    Let me know if this works.

  • Rour Level 1 Level 1 (0 points)

    Hi John:

     

    I tried that option at the beginning but it would not let me do it, the function is no available to me (below keychain list I should be able to see it, but I dont)

    Captura de pantalla 2013-11-02 a la(s) 20.32.05.jpg

     

    Why would that be? I deeply appreciate your help.

    Thank you!

  • John Galt Level 8 Level 8 (37,920 points)

    You should delete your login keychain since that is the one with the problem. I do not believe that it is the one you have selected in your screenshot.

     

    I am trying to solicit help from someone who speaks Spanish...

  • Rour Level 1 Level 1 (0 points)

    Hi John (help much appreciated!)

     

    I actually changed the language settings (everything is in english now).

     

    First: This is the image I see now after deleting "login keychain" and restarting my Mac:

     

    Screen Shot 2013-11-03 at 15.02.00.jpg

     

    I have the login but with no padlock, just an empty square!.

     

    Second, if i go to edit and try to change settings for keychain login, I dont have that option available (according to the image below.

     

    Screen Shot 2013-11-03 at 14.49.06.jpg

     

    It still sometimes asks me for the Keychain agent password which I dont know where to find it.

     

    No clue what is going in here! Thank you again!

  • John Galt Level 8 Level 8 (37,920 points)

    Thank you. It helps to read your screenshots in English.

     

    First, please tell me that you are not using FileVault and you did not set a Firmware Password. If you do not know what those are then you probably did not. If you are using one or the other, you will need additional instructions before proceeding.

     

    Otherwise, please start your Mac in Safe Mode:

     

    • Starting your Mac in Safe Mode will take longer than usual, graphics will not render smoothly, audio is disabled on some Macs, and some programs (iTunes for example) may not work at all.
    • To end Safe Mode restart your Mac normally. Shutdown will take longer as well.

     

    While your Mac is running in Safe Mode, please try to repair your Login Keychain again.

  • Rour Level 1 Level 1 (0 points)

    Thanks to you John.

     

    I hadn´t heard about File Vault and I am quite sure I did not set a Firmware password (I actually verified in my computer and it says that "Filevault is turned off for the Disk Macintosh HD").

     

    I will do exactly what you have suggested and will try to repair my Login Keychain again.

     

    I sincerely appreciate your advice, I will let you know what happened tomorrow night.

     

    All the best!

  • Rour Level 1 Level 1 (0 points)

    Hi John (it´s me again sorry!)

     

    I did what you suggested using Safe Mode (I actually did it following http://support.apple.com/kb/PH14204 for oS X Mavericks).

     

    I followed the same steps that I have done before;

    - Before deleting I used First aid Keychain and what I got was the following:

    Screen Shot 2013-11-04 at 0.51.57.jpg

    - Then I hit repair and I got the following:

     

    Screen Shot 2013-11-04 at 0.52.12.jpg

     

    - After that I decided to delete Login Keychain (the empty square), it was gone. I restarted my computer in normal mode. Once I did that what I see now is the following:

    Screen Shot 2013-11-04 at 21.44.26.jpg

     

    - Maybe I missed something, and I still cant see the padlock in login, and no way no decipher whats going on.

     

    PERHAPS THE FOLLOWING IS RELATED:

     

    - If try log into ICloud through System Preferences the following pops up after entering my Apple ID and Password: 

    Screen Shot 2013-11-04 at 0.59.48.jpg

     

    - If I select Reset to Defaults I get the following (even if I select cancel):

     

    Screen Shot 2013-11-04 at 1.00.06.jpg

    - And after that I get the following:

     

    Screen Shot 2013-11-04 at 1.00.32.jpg

     

    Could that be related? Thank you very much again and sorry for too many images.

    All the best!

  • John Galt Level 8 Level 8 (37,920 points)

    Try de-selecting Keychain in System Preferences > iCloud. Then, using Keychain Access, attempt to delete the Login keychain again.

     

    Sorry I have not been of any help. I have attempted to duplicate this problem without success.

  • Rour Level 1 Level 1 (0 points)

    Hi John:

     

    I tried the last option, but I cant move far from the images I pasted, I dont have any way to move from that point (No icloud in my Mac).

     

    You have been of great help! I thank you very much for that.

  • herodotus1 Level 1 Level 1 (0 points)

    I've been reading this string with interest as I'. having exactly the same problem. I'd never even heard of a keychain before Mavericks and now I find that these prompts keep coming up on my Mac to enter a password. I've tried all of the above withough success. Can i ask...would a clean reinstall solve the problem? I have back up so I wouldnt lose much, but I'm tearing my hair out trying to solve this really irritating problem! Thanks for all the advice so far!

Previous 1 2 Next