12 Replies Latest reply: May 19, 2015 7:52 AM by versaillien Branched to a new discussion.
TuAnhLe Level 1 Level 1

Hi,

 

I recently upgraded to Mavericks OS X10.9 on my MacBook Air 2013. Prior to that, my Internet connection remained on at all times. Now, every time I turn my computer on (after putting it to sleep), I have to manually connect to the Internet. It's not the end of the world seeing as I have no problems connecting. I just don't want to have to keep clicking on the Wi-Fi icon and turning off and on the network EVERY time I turn my Mac on!

 

Why can't it just stay connected or automatically connect to Wi-Fi when it wakes up?!?!

 

Also, I cannot seem to change any of the Network Options as everything is "greyed out". Why would this be and is it something I need to look into?

 

Any help will be much appreciated!


MacBook Air, OS X Mavericks (10.9)
  • yaroslavk Level 1 Level 1

    Hi, TuAnhLe!

    Do you use bluetooth? i just found (as i think) same problem here - https://discussions.apple.com/message/23546249#23546249

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    Test after taking each of the following steps. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved.

    2. Follow the instructions in this support article under the heading "Symptom: The network connection drops unexpectedly."

    3. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    4. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    5. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    6. In some cases, the problem has been resolved by repairing permissions on the startup volume.

    7. Turn off Bluetooth and test.

    8. Reinstall OS X.

  • KadenP Level 1 Level 1

    These suggestions are great, but they don't really address the original question of why it disconnects in the first place.  My Mac reconnects automatically just fine whenever I wake it up, but just like the original post states, prior to Mavericks, it never disconnected at all.  THAT is what I wish to fix.  All I have to do is close the lid and move to another room and everything I've been working on disconnects and I have to start all over again.  It's infuriating.

  • A. Ivanov Level 1 Level 1

    I have the same issue

  • yonester Level 1 Level 1

    Same issue here, with a brand new 13" Macbook Air. The connection just doesn't come back after sleep and I need to turn WiFi off and on again to get it back.

     

    Anything else we can try?

  • Soderdahl Level 1 Level 1

    I get really anoyed by the same thing. How can I solve it?

  • sundevil96 Level 1 Level 1

    To Linc Davis - thanks for providing a possible solution.  However to you and Apple, basically what you might have said is "Do this but be really friggin careful or end up with a bigger problem".

     

    Agree with others... and who has this amount of time to dedicate after working to pay the $2k+ for the new computer.   Apple should provide this support.

     

    I believe GM calls it a recall.

  • IHATEMAVERICK2 Level 1 Level 1

    My MacBook isn't worth the trouble since I "upgraded" (what a laugh) to Maverick. Wifi loses connection every time I close the lid. Email stays offline...piece of junk. I was wasting 20 minutes a day dealing with this quirk - finally I am ready to use this piece of S---t as a target for my son's baseball pitching practice in tha backyard. Apple is NOT living up to thier brand when staying online is such a hassle...!!!!!!

  • milomoon Level 1 Level 1

    Same thing here.

     

    What would be really useful if this site was monitored by an Apple tech person, who could help or at least acknowledge this is a problem.

     

    Should have brought a £200 Chrome Book...

  • MacMiguel Level 1 Level 1

    I was having lot of problems while getting my macbook air 2013 to reconnect to Wi-Fi after waking from sleep. The problem is related to bluetooth, and here's how to fix it..it worked for me!!.. I hope it helps you!!

     

    http://www.imore.com/how-fix-mavericks-wi-fi-zapping-bluetooth

  • spartanrob Level 1 Level 1

    Thanks @MacMiguel, that worked for me.

  • versaillien Level 1 Level 1

    My problem was every time my 2013 Macbook Air went into sleep mode it would disconnect from my network, than it would take time to reconnect upon waking. Excruciatingly slow to reconnect and it would do this every time. Frustrating. I solved this problem by going to network preferences and reordering my networks so that my primary network was at the top of the list. Now, when I open my lid/wake from sleep, it's connected. No delays. Hope this helps someone. Its easy and worth a try.