Previous 1 6 7 8 9 10 Next 211 Replies Latest reply: Jan 31, 2015 7:00 AM by peterpaulfromvenlo Go to original post Branched to a new discussion.
  • Unclebadger Level 1 Level 1 (0 points)

    My collegue and I use ARD 3.7.1 to service two sites at a media company, circa 150 Macs. I have been singing the praises of ARD for over 10 years but since upgrading to Mavericks am suffering from the same meltdown as other users describe.

     

    I have this morning deleted the DB from the containers folder as suggested. This indeed cut the crap info out of the display, namely the jumbled DNS entries and jumping-bean computers. HOWEVER, now we are not able to authenticate to any of the machines. This situation is totally unacceptable.

     

    Yet again Apple dont give a toss about their business customers - SAD TIMES!

     

    !! Moderator can't you escalate this to Apple properly ?

  • bobgeo Level 1 Level 1 (25 points)

    How do you authenticate to those machines? Do you have a separate account on those machines, do you use the users' login name and password?

  • Uncle_Badger Level 1 Level 1 (0 points)

    Hi Bobgeo,

     

    Many thanks for responding to my post.

     

    In answer to your question these Macs are not bound to AD, we currently use local accounts and we usuallys (used-to) authenticate using the administrator account (not the user account).

     

    The administrator account is one that has been set up when the machine is built and has full control over the machine.

     

    The user accounts have limited rights.

  • robfromupland Level 1 Level 1 (5 points)

    I was having the same issue in a middle school classroom.  After reading all of these posts, I tried one of the solutions and it has worked well fer several days.  It was resolved by clicking on All Computers in ARD sidebar and then selecting them and going to Edit > Delete.  I had to do this a few times and restart the software, but it is now working just fine.  I can see all of the clients and interact with them as well.

  • tilly777 Level 1 Level 1 (0 points)

    I am in a middle school too. I have 29 computers logged in at this moment. When I scan my network with Bonjour, it picks up 17 computers. I have tried what you have done to no avail.

     

    How do you add computers to your lists after you delete them? I used to scan with Bonjour, highlight and drag them in, but you can see what happens with Bonjour in my first paragraph.

     

    You said you had to delete the list several times. So, when you delete the list the first time, do you reopen ARD and the lists show up again?? This has been a thorn in my side since last November.

  • Robman Level 1 Level 1 (95 points)

    So, for removing computers, jsut go to All Computers select all and delete them. Then quit the app and re-launch, when you go to all computers you will see some entries in there again. Select those and delete them. Keep doing this until get get all the machines you want out of there. You do not seem to need to remove Servers, or machines that have static IP addresses.

     

    Ad for re-adding them in, instead of Bonjour just set it to do a Network Range. If one machine has IP 192.168.1.45 then set your Network Range to be 192.168.1.2  to 192.168.2.254. If it's one house, you will probably just need one range, if it's a building with multiple floors, set each scanner to be a network range of that floor.

     

    To add them in, just drag a group of them to the All Computers list at the top, and if they are all set to the same log/pass to manage, then it's relatively painless. If they are all different, then add them in one at a time..

     

     

    I agree that the problem seems related to DHCP, our office had off Christmas to New Years and when I came back, I had to clear out all the machines and re-add them because many were bad again.

     

    It's not fun, but there is a workaround, and hopefully they will figure out what the root cause is and fix it.

  • tilly777 Level 1 Level 1 (0 points)

    Thanks Robman, I was doing exactly that after my previous post. Looks OK for now, will see what happens.

  • Zack Holmes Level 1 Level 1 (15 points)

    ridiculous. between this, gmail issues and smb2 file sharing, mavericks really feels rushed. such a shame. all these things worked perfectly fine under 10.8.. sheesh

  • Uncle_Badger Level 1 Level 1 (0 points)

    The only thing I have been able to do to "Resolve" this is to trash the database. Which is located in

     

    Users:"Yourname":Library:Containers:com.apple.Remote.Desktop

     

    This has the effect of starting the entire program as if it was just installed. For a time it works but the huge disavantage is you lose any customisations you may hav emade (Colour coding, menus, client authentication). For me this is a real headache as we have a great deal of clients across two local offices.

     

    For the record changing the scan IP protocol from bonjour to a set range has no effect whatsoever with my earlier mentioned problem.

  • Uncle_Badger Level 1 Level 1 (0 points)

    I forgot to add that it has cocked-up again a couple of days later.

     

    Come on Apple, SORT IT OUT!!!!

  • gianic Level 1 Level 1 (5 points)

    In reading other discussions, it looks like not everyone is having the issues we are.  Could it be a function of using the Mac App Store app or not?  I have upgraded from originally installing ARD 3.3 on a CD.  I am having these same issues everyone here is.  Maybe an install from the Mac App Store does not have the same problems?

  • derekthammond Level 1 Level 1 (0 points)

    I upgraded via the App Store and have the same issues. This really *****.

  • gianic Level 1 Level 1 (5 points)

    Bummer.

  • irob_swe Level 1 Level 1 (5 points)

    The only thing to avoid this is to remove 3.7.x and go back to 3.6.x on the Admin. The old admin is compatible with the newer clients. Everything else is temporary fixes that will eventually break.

     

    It's possible to install the old admin on OS X 10.9 but there are other issues so it's better to use a computer which is compatibe with OS X 10.8 (or older).

     

    Must be really confusing days at Apple as they keep letting admins go through this and build up their anger.

  • Bryan Pietrzak Level 1 Level 1 (25 points)

    As I've mentioned before this has nothing to do with Mavericks, but is simply a bug in how ARD 3.7.x handles IP addresses and DNS names. In particular it "remembers" old IPs for machines even when that IP has been reassigned to a different machine.

     

    This can be clearly seen in the com.apple.RemoteDesktop.plist file found in

     

       ~/Library/Containers/com.apple.RemoteDesktop/Data/Library/Preferences

     

    If you open this file in a text editor and search for hostnames or networkaddress you'll very quickly come to see the problem. Keeping an array of every past IP used by the machine or every DNS name each of those IPs resolves to will quickly fail in any environment with short DHCP lease times. In fact, the shorter the DHCP lease times, the more quickly your ARD will become useless.

     

    In my case, deleting the file or deleting the computers is not an option. I have over 3200 computers in my ARD in carefully curated groups, lists and smartlists.

     

    That said I have a found a workaround.

     

    Quit ARD

    Open terminal and enter killall cfprefsd just to make sure all prefs are flushed

    Open the above com.apple.RemoteDesktop.plist file in a text editor, I used TextWrangler

     

    We're going to do 5 find and replace all operations:

     

    find: networkAddress        replace: ignorenetworkAddress

    find: networkAddresses    replace: ignorenetworkAddresses

    find: primaryIdentfier        replace: ignoreprimaryIdentfier

    find: hostname                  replace: ignorehostname

    find: hostnames                replace: ignorehostnames

     

    By doing this, you're essentially making ARD "forget" all this cached detail about the machines because it won't be able to find the normal keys that contain this information. But that's ok, once the ARD scanner sees the machines it'll refresh the records with the current info.

     

    Since I've been doing this regularly to keep my lists clean, I've not had any problem

Previous 1 6 7 8 9 10 Next