13 Replies Latest reply: Sep 21, 2014 3:15 PM by jdcalt
Christian_1973 Level 1 (0 points)

After I have worked on a photo (it is labeled as "modified") Aperture 3.5 does not load it up into iCloud. How can I change this strange behaviour? All other (not modified) photos can be shared easily. Has that something to do with the fact that he is ignoring work copies?


Aperture 3, OS X Mavericks (10.9)
  • léonie Level 10 (91,186 points)

    How can I change this strange behaviour? All other (not modified) photos can be shared easily.

    Are you asking about automatic upload to My Photo Stream?

     

    Aperture will upload a photo the moment it is imported to Aperture, but it will not sync the edits to iCloud. If you want to add an edited image to your photo stream, you have to share it again to iCloud. Select the edited image and ctrl-click it. Then use the command "Share > iCloud > MY Photo Stream" to add the edited version to your Photo Stream.

     

    -- Léonie

  • Christian_1973 Level 1 (0 points)

    Thanks for the first input.

     

    But it is not about automated uploads to my Photo Stream. It is about sharing photos with my friends via iCloud. If I select those photos to be shared, Aperture 3.5 loads up only photos, which have not been modified. Photos I have modified are not been uploaded although I selected them and used the command "Share > iCloud ..."

     

    I do not know how to change this behaviour. Or is it simply a bug?

  • léonie Level 10 (91,186 points)

    I am seeing the same. The edited image I tried to upload to a Shared Photo stream finally appeared, after I forced the creation of a preview for the photo by holding down the ⌥-key while selecting the command "Photos > Generate Preview". Then all of a sudden the image uploaded three times

    But that may be only a coincidence, try it yourself.

  • Christian_1973 Level 1 (0 points)

    Dear leonieDF. I tried your proposal. Result on my side: Now none of my photos (neither my non modified nor my modified) can be uploaded to the iCloud photo stream .

  • léonie Level 10 (91,186 points)

    Have you exceeded a limit? You can only upload a limited amount of images per hour.

     

    iCloud: Photo Stream limits

  • Christian_1973 Level 1 (0 points)

    Hey ... This is a good hint ... Maybe the amount of my trials makes issues ... I will wait some time and try again ...

  • Christian_1973 Level 1 (0 points)

    I tried again after an hour of waiting:

     

    - Unmodified photo can be uploaded to iCloud immediately.

     

    - Modified photo can not been uploaded to iCloud.

    - Photo with updated preview can not been uploaded to iCloud.

     

    Very strange ... Maybe it can be solved by not using the shared iPhoto media center (Mediathek)?

  • léonie Level 10 (91,186 points)

    . Maybe it can be solved by not using the shared iPhoto media center (Mediathek)?

    That might be incnvenient. Only one library (Mediathek) can access iCloud.

     

    How do you edit the image? In an external editor or plug-in, or directly in Aperture? Are the images refernced or managed?

     

    Perhaps your library needs repairing?

  • Christian_1973 Level 1 (0 points)

    Thanks for your questions: I edit images in Aperture. The images are being managed.

     

    How can see that my library needs repairing? How can I start this process? Thanks.

  • léonie Level 10 (91,186 points)

    You can repair the Aperture library with the Aperture Library First Aid Tools. To use the tools, lauch Aperture while holding down the key combination ⌥⌘ firmly, until you are seeing the panel with the First Aid options. Try "Repair Permissions" and "Repair Library". The second option may take a while for a large library.

     

    See "Repairing and Rebuilding Your Aperture Library: Aperture 3 User Manual" for more information.

  • Christian_1973 Level 1 (0 points)

    I did one of your proposed repair steps ("repair library"), but nothing improved. Still I'm not able to upload (all) photos from Aperture to iCloud.

     

    I did another try with iPhoto. So I opened the library which I'm using with Aperture and tried to upload the same photos ... result: All photos uploaded. No issues. So my personal view at this time ist that there seems to be an issue with Aperture.

     

    Besides that I will also try later on your proposal to "repair permissions".

  • léonie Level 10 (91,186 points)

    I'll do some more testing myself. This is really weird. I am seeing the opposite problem. When I share an edited photo to a shared stream, it will upload both - the unedited version and the edited version.

  • jdcalt Level 1 (0 points)

    I am having exactly the same problem.  Has anyone found a solution to it?