5 Replies Latest reply: Sep 18, 2006 11:32 AM by Guychi
George Machen Level 1 Level 1 (20 points)
Recently my Dock show/hide behavior has changed:

1) If "Automatically Hide the Dock" is on, then Option-Command-D brings the Dock out for an instant, but it immediately pops right back in, hidden.

2) If auto-hide is off, then the command key sequence hides the Dock for an instant, but it pops right back out, visible.

In both cases, leaning on the command keys keeps the Dock visible/hidden for the duration, but as soon as I let go, back it goes!

Repaired permissions, trashed com.apple.dock.plist, yadda-yadda-yadda, and no joy.

Ever happen to anyone else?


PowerBook Pismo 500   Mac OS X (10.4.5)  
  • Dr. Smoke Level 9 Level 9 (56,585 points)
    Hi, George.

    I can't reproduce the behavior you describe.

    1. What changes did you make to your Mac before this problem arose? Any new software, widgets, etc.?

    2. Are your running any Dock hacks or add-ons? If so, disable them.

    3. Tried a different keyboard?

    4. Checked for conflicting keyboard shortcuts in System Preferences > Keyboard & Mouse > Keyboard Shortcuts?

    5. An errant Startup or Login Item maybe the cause. My "Troubleshooting Startup and Login Items" FAQ can help you pin that down if such an item is causing the problem.

    Good luck!

    Dr. Smoke
    Author: Troubleshooting Mac® OS X

    ---
    Note: The information provided in the link(s) above is freely available. However, because I own The X Lab™, a commercial Web site to which some of these links point, the Apple Discussions Terms of Use require I include the following disclosure statement with this post:

    I may receive some form of compensation, financial or otherwise, from my recommendation or link.
  • George Machen Level 1 Level 1 (20 points)
    I found the culprit: TextExpander 1.3.1 (autofill completion)

    http://www.smileonmymac.com/textexpander/index.html

    Disable it and the Dock is back to normal.

    (I'll notify the author.)
  • George Machen Level 1 Level 1 (20 points)
    From: textexpander@smileonmymac.com
    Subject: Re: TextExpander support
    Date: July 22, 2006 9:08:08 PM EDT

    Hi George,

    Thanks for your feedback. This appears to be a general Mac OS X bug, as we were able to write an application which simply enables key logging for assistive devices yet causes the same problem independently of TextExpander. We reported this bug to Apple (RADAR bug #4544742). We hope they fix it soon, as it certainly diminishes the experience of any application which uses assistive devices key logging.

    Thanks for using TextExpander from SmileOnMyMac!

    Regards,

    Greg
    TextExpander Support


    PowerBook Pismo 500   Mac OS X (10.4.5)  
  • bgkarma Level 1 Level 1 (75 points)
    I too am experiencing this problem, which started this morning. A day or two I installed the TypeIt4Me app and everything was working fine. Now when I turn this program off, the dock is working properly once more.

    Any ideas?
  • Guychi Level 1 Level 1 (0 points)
    Same problem here.

    Any ideas for temporary solutions before an official bug fix?