14 Replies Latest reply: Apr 8, 2014 2:49 PM by Hackintuner
dzauha Level 1 Level 1 (0 points)

I am in need of your assistance as the new version of Keynote appears to be causing issues, and I am not sure where to go or what to do to report this.


Here is the situation.


We have a Sharepoint server running WebDAV services.  Our students use WebDAV capable applications on their iPads such as Pages, Numbers, Keynote, WebDAV NAV +, etc.   They create files using these apps on their iPads and then save them to their "WebDAV" folder on the SharePoint server.  This is necessary so that students may access their files via the iPad in our LMS and turn in assignments via a digital dropbox.  This has worked fine in the past until the update of Pages, Numbers, and Keynote.  In the past these apps on the iPad have always placed a single file on the server to which the students could go in and retrieve the file or send it to a digital dropbox in our LMS through a WebDAV connection between the LMS and the SharePoint server.


With the update of these apps on the iPad to the newest version, Pages, Numbers, and Keynote now place a folder on the SharePoint server of which it contains the following items:  folder titled "Data", folder titled "Metadata", icon titled index.zip, icon titled preview-micro.jpg, icon titled preview-web.jpg, icon titled preview.jpg.


The issue is that now with this being a folder, students are no longer able to retrieve the file nor are they able to go into the LMS and send the file to a digital dropbox as it is now a folder and not a packaged file.


This is a serious setback to us as it renders Pages, Numbers, and Keynote useless since they can not use their iPads to retrieve or submit their assignments to a dropbox in an LMS or bring it back to the apps on the iPad. 


As I said earlier, this worked perfectly fine prior to the new version of Pages, Keynote, and Numbers.


I believe this to be a Pages, Numbers, Keynote issue as when I send the file from Keynote to the WebDAV folder as a PPT, everything works fine.  Kind of hard to get the staff to use Keynote when all they see is the "PowerPoint" verson works with no issues.  Also, this would be a poor work around for something that use to work in the past.


Anyone else experience this or have suggestions?


Thank you in advance.

iPad, iOS 7.0.3
  • Guilherme Boechat Level 1 Level 1 (10 points)

    I don't know if I have the exact same issue but I might be related. When I'm working on a Keynote file saved in a shared Dropbox folder, it keeps syncing properties.plist, pasted images, index.zip, etc. Started happening after updating to the new Mavericks OS and apps.

  • Adizzel Level 1 Level 1 (0 points)

    I have the exact same issue and its messed our workflow all up.  When I save a Keynote to dropbox to share with our media people to set up our weekly presentation it saves it as a messed up zip file.  It worked flawlessly until the latest update.  Anybody getting any answers on how to fix it???

  • Adizzel Level 1 Level 1 (0 points)

    Let me add...its being craeted on my Mac Book Pro (10.9) in the latest version of Keynote.  I reloaded dropbox as well to my laptop.  I've also tried working around the App and just uploading from Safari...didn't work either.

  • Kasperleo9605 Level 1 Level 1 (0 points)

    Got the same problem! Dropbox is just updating all the time. For me it´s also started when I were saving Keynote to the Dropbox. Zip files and properties.plist???


  • SchimeraSupport Level 1 Level 1 (0 points)

    I'm the developer of the WebDAV Nav apps.

    I've been working on adding support for the new package format to the app, which will be released with the next version within a few weeks.


    If you are running iOS 7 there is a "hack" I've found that you can use to create a single file format.


    When in Pages, use the Share function to "Open in Another App". Select the Pages format, then select WebDAV Nav+ ( or another installed app) as the other app.

    Pages will create a zip file with a name like Example.pages.zip and copy it to the other app.


    If you then remove the .zip extension and just leave the file as Example.pages then you can view the file as a single file Pages document as you could before.

    Unfortunately this will only work on iOS 7 and not iOS6 as the internal structure of the package has changed.

  • olsena2 Level 1 Level 1 (5 points)

    I have the same problem, it's on my Macbook Air not on iOS.

  • Kasperleo9605 Level 1 Level 1 (0 points)

    I also meant that I´ve got the problem on my Macbook Air!

  • evoeco Level 1 Level 1 (0 points)

    same problem with the new keynote version: my keynote presentations are completely messed up and I cannot recover them as older versions from the dropbox folder because there they do not exist as one keynote presentation but as a collection of data, metadata folders and other files.

  • olsena2 Level 1 Level 1 (5 points)

    I'm not sure if this is exactly what your original post is about but I saw the comments under it talking about

    getting the same notification over and over again that dropbox files were updated, like it's in a loop and won't stop. I also am seeing the properties.plist, index.zip and preview-micro.jpg as the updated file names when I click on my little dropbox icon on the top of my desktop. I am on a Macbook Air OS X 10.9 (Maverick). I've been using dropbox for a while and this seems to have started after I upgraded to Maverick.


    I wrote to Dropbox and here is the process they had me follow to correct this problem, and it worked perfectly, so I thought I'd share (**the only step that I didn't do is step 4 because I couldn't find the dropboxhelpertools folder in my library):


    Thank you for contacting Dropbox Support!


    There appears to be a problem with the Dropbox software currently installed on your computer. I'm going to have you do a full reinstall and resync to attempt to fix the problem.First, make sure you save and quit ALL programs that access files in the Dropbox folder.


    Here are the steps:

    1. Download the newest version:

    - http://www.dropbox.com/install/


    2. Stop the Dropbox desktop application (if needed)

    - Click on the Dropbox icon.
    - Choose Quit/Stop/Exit


    3. Delete Dropbox meta-data folder:

    - To delete this folder open a Terminal (Located at /Applications/Utilities/Terminal for Mac OS)
    - Copy and paste the following lines into the Terminal and press RETURN:

    mv ~/.dropbox ~/.Trash/dropbox.old

    - This will move the folder to the Trash and make it visible.


    4. Delete the Dropbox Contextual Menu Item Plugin

    - Open the Finder and select Go to folder... from the Go menu (or press Shift-Command-G)
    - A dialog box should appear. Now copy and paste the following line into the box and press the return key:


    - Finally drag the DropboxHelperTools folder to the Trash and enter your Administrator password if prompted to complete this action.


    5. Reinstall the Dropbox desktop application

    - Open the Dropbox .dmg file and double click the Dropbox icon.
    - Dropbox should appear in your menu bar.
    - Relink your account.

  • friedEggTechnik Level 1 Level 1 (0 points)

    I just came across the same issue.  I managed to fix it by forcing the server to re-index itself using Spotlight.  I had to change a few of the excluded folders in the Privacy section of the Spotlight Preferences (which had been set to remove issues with Time Machine a while back.  These have been resolved).


    Once Spotlight has picked up the metadata for the new iWorks files (folders as packages), WebDAV NAV + treats them as packages.  The indexing of individual items can be tested in Terminal using:


    mdls -name kMDItemContentTypeTree /Path/To/Directory

  • automatikbizooty Level 1 Level 1 (0 points)

    What is supposed to be in place of /Path/To/Directory?

  • friedEggTechnik Level 1 Level 1 (0 points)

    Sorry, I meant the path to any folder or file that may have been indexed by Spotlight.  You can drag in from finder to save re-typing.  This will show whether its now indexed, by listing the file types, as seen by Spotlight (for example, "com.apple.package").  The problem that I encountered (clients not being able to see new Pages files as packages) was fixed when I forced the server to re-index the folders containing the Pages files.

  • kbutter Level 1 Level 1 (0 points)

    This issue needs to get fixed asap. It is so inconvenient. It isn't just dropbox it happens when I try emailing Keynote files in google mail as well. I love apple, but this is basic files sharing gone horrible. A keynote file should be able to be sent as a simple keynote file. Apple Please fix this quickly.

  • Hackintuner Level 1 Level 1 (5 points)

    Well, i found some information on the web about this, as i too was having this problem, and i also coincidentally noticed it when trying to upload a keynote file to dropbox. It seems keynote 6 turns the file into a sort of archive and only IT SELF works it properly. I found 2 ways around it:


    1. Export your keynote 6 files to Keynote 09, this should make them behave normally, but you may encounter that reopening them might generate a message saying that keynote 6 removed a few things to make it "compatible". #2 workaround should help you get by.


    2. DO NOT delete or update from Keynote 5.3, you can keep working with this particular version of it on Mavericks.


    Hope that helps guys.


    Apple, please get your head on straight, you all know, and we all know, Keynote 5 was a superb application that helped us build jaw droping and awe inspiring presentations. Dont leave these issues on the table, as it brings a lot of bad rep and bs to a wonderful product family we all enjoy to use.


    Please fix this ASAP!