6 Replies Latest reply: Jul 31, 2014 9:25 AM by tpjasper
mmand Level 1 Level 1 (0 points)

Hello all!

 

During my upgrade from 10.8.5 to Mavericks on my imac I ran into some serious issues. I will try to break it down here:

 

- The mavericks installation failed, indicated damaged hard drive (a quite common problem, it seems, although there does not seem to be the one solution for it).
- When trying to revert to 10.8, I had problems, with safe mode not running faulty, hard drive repair via disk utility impossible and disk utility suggesting wiping the HD.
- I decided to go ahead and erase the HD and do a clean reinstall.
- Trying to reinstall 10.8 from recovery mode (cmd+r at login, or cmd+alt+r for internet recovery mode) failed. It always suggested to restart the installation.

 

I do not have a time machine backup - all critical data is saved elsewhere and I do possess a disk image created with superduper on a network drive. Only this does not help in the present situation.

 

 

So in lack of a better alternative I created a Mavericks installation partition on a USB HD and tried to clean install Mavericks from there, as described by option 1 here:
http://www.macworld.com/article/2056561/how-to-make-a-bootable-mavericks-install -drive.html

 

 

During the installation an error occured. Something along the lines of "could not creat recovery HD". I found that some people had overcome this issue by:
a) changing their main partition size to free some space for the creation of a new recovery HD.
I tried this from recovery mode disk utility, it did not have an effect, and I returned to only having one (visible) partition on my HD.

 

b) using diskutil to wipe the recovery HD and merge it with the main HD partition:
http://derflounder.wordpress.com/2011/10/22/removing-and-rebuilding-a-malfunctio ning-recover-hd-partition/
I tried this, but then the step of merging failed, namely (with different names):
diskutil mergePartitions HFS+ MacHD disk0s3 disk0s4

I do not remember the exact error message.

 

Now:
- Both the Mavericks installer on my USB HD and the 10.8 installer in recovery mode refuse to install on my main partition:
"OS X cannot start up from this disk" / "This disk cannot be used to start up your computer"
- Trying to change partitions from Disk utility as described here fails:

http://support.apple.com/kb/TS3926

 


Presumably this can be repaired by using diskutil in the right way. Only I have no clue how.
I am slightly distressed by this whole thing and would appreciate any help! :/

 

The imac is rather new, with no Bootcamp partition or anything nonstandard.

 

Thank you!

mman

 


Edit:
This seems to be the usual fix:
https://discussions.apple.com/message/23535004#23535004
This does not work, as disk utility does not allow me to resize partitions anymore.

 

Message was edited by: mmand


iMac, OS X Mountain Lion (10.8.5), update to 10.9.0 Mavericks
  • mmand Level 1 Level 1 (0 points)

    When trying to change the partition as described in the last link, the error I get is the following:

    "Partition failed with the error:

    You can't perform this resize unless it has a booter (target partition is probably too small)."


    Also strange: When running the command "diskutil list" in terminal the wiped recovery HD is not shown anymore. Previously it was there with the new name assigned, now it is completely gone.

     

    I have performed an installation of 10.8.5 on my external drive and could run programs from there, if that helps.

     

    Thanks for any suggestions.

  • mmand Level 1 Level 1 (0 points)

    I got my issue solved. A reason for the problem seems to be that I turned in Filevault inadvertently at some point.

     

    For future reference–there seem to be two possible ways:

     

    1. Using the "diskutil" terminal command:
    - Boot and hold cmd+r or cmd+alt/option+r for recovery mode or internet recovery mode (equivalent, the latter may be slower depending on your connection)
    - Open Terminal from Utilities menu

    - Enter "diskutil cs list"; I got the following output:
    [CODE]

    me-mas709:~ mext$ diskutil cs list

    CoreStorage logical volume groups (1 found)

    |

    +-- Logical Volume Group 56374D16-C7A1-47D7-9627-5F93E61E13C9

        =========================================================

        Name:         Macintosh HD

        Status:       Online

        Size:         2999733223424 B (3.0 TB)

        Free Space:   0 B (0 B)

        |

        +-< Physical Volume AD7909DD-1F2E-4F48-848A-A7FB741BDD60

        |   ----------------------------------------------------

        |   Index:    0

        |   Disk:     disk0s2

        |   Status:   Online

        |   Size:     2999733223424 B (3.0 TB)

        |

        +-> Logical Volume Family 148BBF17-B993-4F5E-BEA9-144776CD63C1

            ----------------------------------------------------------

            Encryption Status:       Unlocked

            Encryption Type:         None

            Conversion Status:       NoConversion

            Conversion Direction:    -none-

            Has Encrypted Extents:   No

            Fully Secure:            No

            Passphrase Required:     No

            |

            +-> Logical Volume 135EAF79-E66A-444D-B954-9DB8E94783FE

                ---------------------------------------------------

                Disk:               disk1

                Status:             Online

                Size (Total):       2999414448128 B (3.0 TB)

                Size (Converted):   -none-

                Revertible:         No

                LV Name:            Macintosh HD

                Volume Name:        Macintosh HD

                Content Hint:       Apple_HFS
    [/CODE]

     

    - Type the following commands into terminal (with the appropriate volume names from the previous step):
    [CODE]

    diskutil cs deleteVolume 135EAF79-E66A-444D-B954-9DB8E94783FE
    [\CODE]

     

    [CODE]
    diskutil cs delete 56374D16-C7A1-47D7-9627-5F93E61E13C9
    [/CODE]

     


    - Still in recovery mode, open Disk Utility. It should show the HD without any volumes on it. Go to Erase tab, rename the HD, select "Mac OS Extended [...]", apply.

    - Run "Repair Disk" in Disk Utility to see if any errors occur.

    - Reinstall the OS, migrate/copy data from your backup

     

     

     

     

    2. Using the UNIX level dd command (this is what I used, worked for me):
    - For this solution, you require a working OS X installation on a different (external) drive. In my case, the external drive was smaller than the internal one (where I tried to install), this may be necessary.
    - From terminal in recovery mode (press and hold cmd+r on startup), type "diskutil list"
    - From the output, identify the disk where you want to install OS X (in my case "disk0") and the disk where your working OS X is installed (here: "disk2")
    - Run the command "dd if=/dev/disk2 of=/dev/disk0 bs=4096 conv=notrunc,noerror" with the appropriate disk names. This should create a 1-to-1 copy of the external disk (including all partitions) on the internal disk. This may take a while (took me 2 hours for a 80GB external USB HD). This solved the data structure issue on the internal disk.
    - Once this is done, boot from the Internal HD. Run Disk Utility Repair Disk/Permissions. Reboot.
    - In Disk Utility, expand the new cloned partition on your internal HD to the full size of the HD.

    - You can then rename the partition with "/usr/sbin/diskutil rename "Macintosh HD" "Mac Disk"" command in Terminal

    - Update the OS or migrate / copy data as needed

  • DaCord Level 1 Level 1 (0 points)

    Hi mmand

     

    - Still in recovery mode, open Disk Utility. It should show the HD without any volumes on it. Go to Erase tab, rename the HD, select "Mac OS Extended [...]", apply.

    - Run "Repair Disk" in Disk Utility to see if any errors occur.

     

    I have done part 1 till here above. The disk has split into two HD's now.

    The 1st Disk reads as followes: 121.33 GB "APPLE SSD SD0128F Media"

    2nd one reads as follows: 1 TB "APPLE HDD ST1000DM003 Media"

     

    When I sellected the 1st disk in DU the following message came up:

     

    The storage in this Mac is no longer set up to use Fusion Drive. Would you like to restore it to using Fusion Drive?

    Then it gives me the option of choosing from the two HD. The Text Box asks:

     

    Changing the configuration will erase the following disks:

    Macintosh HD

    Untitled

     

    Ignore or Fix option appears.

     

    I sellected "Ignore"  and continued to  renamed and erased the 1st disk and ran "Repair Disk" which was ok.

     

    But the 2nd disk will not allow me to rename and erase without coming up with "Disk Erase failed" "Disk Erase failed with the error. Couldn't unmount disk."

     

    I don't know what to do from here.

     

    - Reinstall the OS, migrate/copy data from your backup

    Do I reinstall on the 1st disk and not worry about second one until later in step 2. I don't quite understand. Please can you explain.

     

    The 2nd step please can you explain. you require a working OS X installation on a different (external) drive.

     

    I created a OS X 10.9 Install Disk on external drive explained by Todd Olthoff using DiskMaker X http://www.youtube.com/watch?v=s6sTMvluakY&feature=share&list=PLP9lCFXVZfRMmXCcl VW9g_vy9itjyW7gb&index=2 I followed his instructions but was unable to erase disk as the erase option was not present. Hense why I am on this post to erase my hard drive to start afresh. Will this work for your working OS X installation you require.

     

    I'll end here and await further clarification. Many thanks in advance. David

     


  • DaCord Level 1 Level 1 (0 points)

    After I have run diskutil list this is what I get.

     

    /dev/disk0

    #: Type Name                       Size            IDENTIFIER

    0: GUID_partition_scheme     *121.3 GB    disk0

    1: EFI EFI                              209.7 MB   disk0s1

    2: Apple_HFS Macintosh HD   121.0 GB   disk0s2

     

    /dev/disk1

    #: Type Name                        Size            IDENTIFIER

    0: GUID_partition_scheme      *1.0 TB                          disk1

    1: EFI EFI                               209.7 MB   disk1s1

    2: Apple_HFS Macintosh HD2  999.3 GB   disk1s2

    3: Apple_BOOT Recovery HD   650.0 MB   disk1s3

     

    /dev/disk2

    #:          Type Name                                  Size            IDENTIFIER

    0:          GUID_partition_scheme                *1.0 TB        disk2

    1:          EFI EFI                                         209.7 MB   disk2s1

    2:          Apple_HFS G-DRIVE mobile with..  799.9 GB   disk2s2

    3:          Apple_HFS G-DRIVE server data    199.9 GB   disk2s3

     

    /dev/disk3

    #:          Type Name                               Size          IDENTIFIER

    0:          Apple_partition_scheme            *1.3 TB     disk3

    1:          Apple_partition_map                   30.7 KB  disk3s1

    2:          Apple_HFS OS X Base System   1.3 GB   disk3s2

     

    /dev/disk15

    #:          Type Name                                Size             IDENTIFIER

    0:          GUID_partition_scheme              *120.0 GB     disk15

    1:          EFI EFI                                       209.7 MB    disk15s1

    2:          Apple_HFS OS X 10.9 Install Di...     9.0 GB    disk15s2

    3:          Apple_HFS STORAGE                 110.6 GB    disk15s3

     

    /dev/disk4-14

    #:          Type Name   Size                 IDENTIFIER

    0:          untitled         Verious Sizes   disk4-14

  • DaCord Level 1 Level 1 (0 points)

     

     

    It's actually easier than what you wrote.

     

    Download the OS X Recovery Disk Assistant from Apple (it also works with Mavericks) and use a 4GB thumb drive to create a Recovery HD on that thumb drive. Do a full system back up.

     

    Then, all you need to do after you install your SSD into the Mini is:

    • Plug in your thumb drive
    • Restart and press the Option/Alt key and select your thumb drive so it boots into the Recovery HD
    • Launch Disk Utility (you'll see the RED letting for each drive)
    • Click on your SSD which will bring up the IGNORE/FIX screen
    • Click on FIX which will create your Fusion drive
    • Back out of Disk Utility -- back to the OS X Utilities Menu and select Reintall OS X

     

    Mavericks will install onto your SSD and as you reinstall or migrate apps and your data, Core Storage will keep writing to your SSD until is fills up then "spill" over to the HDD.The Recovery HD will be on your Fusion drive after you install OS X. But you won't see it in the Startup Manager if you ever restart using the Option/Alt key. You WILL be able to use Command+R though anytime you need to access it. This is just how it is with a Fusion drive.