Previous 1 2 Next 23 Replies Latest reply: Jan 28, 2016 11:50 AM by Rainer3967
jscottfromfl Level 1 Level 1

I've been trying to sync my google calendar with iCal but I cannot create the account in iCal.  It keeps telling me the google server is not secure and won't set up the account.  Any thoughts?


MacBook Air
Reply by Sky1994 on Dec 3, 2013 9:10 AM Helpful

After quite a bit of wrestling, i got it to work.

1. Go to the calendar application and create a new account.

2.Select "Add CalDAV Account".

3. Select "Account Type" as advanced.

4. Enter your username and password.

5. Enter "Server Address " as google.com

6. Enter "Server Path" as https://www.google.com:443/calendar/dav/username@googlemail.com/user

7. Select "Use SSL" and port should be 443.

 

That's it. It should work.

 


All replies

  • Sky1994 Level 1 Level 1

    After quite a bit of wrestling, i got it to work.

    1. Go to the calendar application and create a new account.

    2.Select "Add CalDAV Account".

    3. Select "Account Type" as advanced.

    4. Enter your username and password.

    5. Enter "Server Address " as google.com

    6. Enter "Server Path" as https://www.google.com:443/calendar/dav/username@googlemail.com/user

    7. Select "Use SSL" and port should be 443.

     

    That's it. It should work.

     


  • CarrieN60436 Level 1 Level 1

    That works but I had a problem.

     

    I typed part of the Server path wrong.  Now it gives me a URL error and I can not delete the account or change the url to be correct.  I was able to do it correctly so I have my caldav in my ical.

     

    Help!

  • Chadburns Level 1 Level 1

    Carrie, you may need to delete or disable the Google account and re-add it.

  • Chadburns Level 1 Level 1

    Thanks Sky, that worked for me!  I've been busting away at this for a day and a half now!

  • CarrieN60436 Level 1 Level 1

    I did that.  This is my bosses computer/gmail accounts. 

     

    He has 2 gmail accounts I set up. the first never uses the cal

    The second is the one I miss typed dar insetad of dav.

     

    Deleted BOTH gmails and logged out of icloud.

    Logged back into icloud

    Set up gmail account 1

    Set up gmail account 2 (did not check the ical box)

    Manually entered the caldev info as a new account

    The old wrong url error comes back

    The correct caldev displays as well.

  • Jillee Level 1 Level 1

    Thanks - followed your instructions and it worked for me.

  • lakeshowpb Level 1 Level 1

    These instructions worked perfectly for me.  Thanks so much for posting.  It's ridiculous that Apple can't fix this issue quickly.

  • kshipp Level 1 Level 1

    THANK YOU. I've been tryin for weeks.

     

    FOR THOSE WITH THE SAME PROBLEM ON iPHONE/iPAD:

     

    The above instructions work the same, with some minor changes:

     

    1. Go to Settings>Mail, Contacts, Calendars >Add Account

    2.Select "Other" at the bottom of the list.

    3. Select "Add CalDAV Account".

    4. Enter "Server Address " as google.com

    5. Enter your username and password, and the description you'd like.

    6. IT WILL NOT WORK when you click next. Wait for verification to fail, then select advanced when it gives you the option in the pop-up dialogue

    7. Enter "account URL ashttps://www.google.com:443/calendar/dav/username@googlemail.com/user

    8. Select "Use SSL" and port should be 443.

     

    That's what I did on my phone, and verification went through and it immediately began populating when I opened the calendar app on my iphone.

  • erinwall Level 1 Level 1

    Sky1994,

     

    Thanks so much for the helpful info. Like others, I have been trying to figure out how to add my Google calendar to iCal for days now. Your solution and instructions are spot on.

  • CussinSailor Level 1 Level 1

    I have used this and it syncs my account initially, but I still get an error that the page returns a 404 and to check the URL. Why is this so freakin hard?

  • Sky1994 Level 1 Level 1

    When you say sync inititally, is it actually pulling any dates from your google account?

    Ensure that the server path and address are entered correctly. A small change is enough to cause a 404.

  • BrotherKz Level 1 Level 1
    expertise.iwork
    iWork

    Not working for me. Anyone have any idea how to do it if your google calendar login doesn't end in googlemail.com?

     

    My login for example is admin@myhosting.com so what would the path be?

  • artie_me Level 1 Level 1

    After much wrestling and trying many different solutions, this one worked like a charm. Thanks very very much

  • Kelarity Level 1 Level 1

    Thank you Sky!!  I was struggling with this.

    Worked perfectly on big computer..

    On my  IOS device, however,  I had to do the following

     

    1. go to settings

    2. go to Mail, Contacts, Calendars

    3. choose "other" (at bottom of choices)

    4. under calendars, choose "Add CalDav Account"

     

    Fill in blanks (note: under server.. you need to put the "server PATH" that sky suggested.. NOT just the server)

    Server: https://www.google.com:443/calendar/dav/username@googlemail.com/user (Note: for the "username" part of this link, I inserted only the first part of my gmail address)

    User Name: username (Note: I put the full email address associated with my google account)

    Password: your password

    Description: google

     

     

     

     

    Message was edited by: Kelarity

Previous 1 2 Next