14 Replies Latest reply: Nov 18, 2014 5:09 PM by KyleKai
Greg Vrchoticky Level 3 Level 3 (615 points)

Why is Maps in Mavericks in the Metric System?

It shows distance in km, how do I switch to Miles?


Mac mini, OS X Mountain Lion (10.8.3), 2.3 ghz i7/4 gb of RAM
  • Barney-15E Level 8 Level 8 (41,140 points)

    You have your regional settings set to use metric.

    Language & Region System Preferences, Advanced button.

  • Greg Vrchoticky Level 3 Level 3 (615 points)

    Nope -  that setting is set correctly.....?

  • Barney-15E Level 8 Level 8 (41,140 points)

    I don't know, then. Mine toggles back and forth if I change that setting.

    Maps doesn't maintain its own user settings, so there is nothing to change there.

     

    Toggle the setting in Region and see if it catches on.

  • Randy_B_ Architect Level 1 Level 1 (0 points)

    Did you get a fix for this? I have the same problem ... leaving maps useless! We need someone who cares as much as Steve Jobs did.

  • Eric Root Level 7 Level 7 (31,140 points)

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Feedback

  • jakob.joergensen Level 1 Level 1 (0 points)

    If you want to change the system into metric you have to select a region, which uses only metric units.

    Apple are not very good when it comes to the world. Especially the many small nationalities suffer from this attitude. Feel like american culture walking all over you,,

     

    Go to System Preferences / Language & Region / Select a region which definitely uses the metric system. Maps should finally work.

  • actionmarker Level 4 Level 4 (1,390 points)

    jakob.joergensen wrote:

     

    If you want to change the system into metric you have to select a region, which uses only metric units.

    Apple are not very good when it comes to the world. Especially the many small nationalities suffer from this attitude. Feel like american culture walking all over you,,

     

    Go to System Preferences / Language & Region / Select a region which definitely uses the metric system. Maps should finally work.

     

    Could you expand on this please?

     

    Setting a region and then the Advanced tab to change the measurement unit, creates a custom region with the measurement unit to the unit selected. (metric or imperial (US)).

  • @MuDaeBoJongShin Level 1 Level 1 (0 points)

    actionmarker wrote:

     

    Could you expand on this please?

     

    Setting a region and then the Advanced tab to change the measurement unit, creates a custom region with the measurement unit to the unit selected. (metric or imperial (US)).

     

    The problem is that it only works in some countries. For example, in the UK then the default setting for "Measurement units" is "Metric" but maps distances are nonetheless displayed in miles. That's an appropriate default for the UK, but it means there's nothing you can do to change maps distances to kilometers.

  • actionmarker Level 4 Level 4 (1,390 points)

    I see what you mean.

     

    I just played around with the settings, with my region as UK, as soon as I changed the currency to say US dollars, I and am now able to change the measurement units and Maps matches the settting (km or miles)

     

    I beleive that this is a bug and should be reported as such.

    http://www.apple.com/feedback/macosx.html

  • Digmaster Level 1 Level 1 (15 points)

    Many thanks for the currency tip actionmarker.

     

    I'm English but live in the Netherlands. I have my system set up as UK English, which uses the metric system except for distances (very bizarre ). When I drive in mainland Europe I like to use KM's and when I'm driving in UK I use miles, it just makes everything a bit easier. I can easily switch between the two units on my iPhone when I'm using Maps for navigation.

     

    Seems rather convoluted in order to plan a trip on my Mac I first need to change the system currency between GBP and Euro. Surely a toggle switch in Maps is more logical. I've sent the feedback, maybe this will change in a future update.

     

    Thanks again for the tips.

  • Bets Level 1 Level 1 (15 points)

    I had this problem - thanks for the solution!  I'm in the US, but travel with my computer. Maps was displaying in metric and I wanted miles. Even though my region was set to US. Finally, by switching the measurement setting in Settings/Language-Regions/Advanced to metric and BACK to US, I got the MAPS app to display in miles. Now I know how to switch too!  Works fine on the iPhone. Thanks everyone. We should just all use metric - but that's another discussion.

  • robsv Level 1 Level 1 (0 points)

    I also had this problem.  Go to System Preferences, Language and Region, and change region to U.S. English (not just english).  Use the "-" button to remove any other regions.  I had to restart my iMac to make the changes now it shows up in miles. 

  • Cham82 Level 1 Level 1 (0 points)

    I am having a similar problem where my accounting software MYOB has replaced all my £ for $ and the date style is also US not UK.

     

    All my regional settings are correct but I can't find a solution - can anyone help?

     

    Many thanks

    Craig.

  • KyleKai Level 1 Level 1 (40 points)

    Can we assume you have the correct setting under the Maps Views->Distances menu?

     

    Screen Shot 2014-11-18 at 5.07.33 PM.png