5 Replies Latest reply: Jan 8, 2014 5:47 PM by LarryDH
Dutchboy777 Level 1 Level 1 (30 points)

I have tried twice to upload a video to YouTube.  It is a short video, 7 min 33 sec.  I get the error, "Failed (unable to convert video file)".  I recently upgraded to Mavericks & iMovie 11 and this is the first time trying to upload since the upgrade.  Any suggestons?


iMac, OS X Mavericks (10.9), iMovie 11.
  • 1. Re: Unable to upload video to YouTube
    Dutchboy777 Level 1 Level 1 (30 points)

    I just tried reducing the size of the upload to a lower quality video.  No help. 

  • 2. Re: Unable to upload video to YouTube
    yuyuxier Level 1 Level 1 (10 points)

    Check your video's format, you should make sure the format is accepted by youtube. If the format isn't compatible with youtube, try to convert it with a third party tool.

    If not, maybe there are something going wrong when you update to OS X 10.9.

  • 3. Re: Unable to upload video to YouTube
    misskellywong Level 1 Level 1 (5 points)

    What kinds of file format your vidoe is in? To upload videos to YouTube, make sure that you’re using one of the following formats: MOV, MPEG4, AVI, WMV, MPEGPS, FLV, 3GPP, WebM.  If you are using a format that is not listed above, you are suggested to convert it to one of the above file formats using proper video converting tool.

     

    <Link Edited By Host>

  • 4. Re: Unable to upload video to YouTube
    Dutchboy777 Level 1 Level 1 (30 points)

    On another thread someone mentioned removing all the tags.  I did that.  It worked!  Yeah!!!

  • 5. Re: Unable to upload video to YouTube
    LarryDH Level 1 Level 1 (0 points)

    Although I believe you when you say it worked after removing tags, I don't think there is a solid cause and effect.  The web is loaded with complaints of the iMovie to YouTube upload.  It is simply NOT stable.  I used iMovie '11 with Mountain Lion and now use the new iMovie 10 with Mavericks.  Yes, I said iMovie 10. Apple named it that way.  Not me.  The iMovie to YouTube upload option is unreliable.  We all want to try to narrow it down to a font or a clip or a photo or a title or the duration or the HD resolution etc...  In fact, we are wasting our time until Apple works out these issues.  I made 20 upload atttempts today. All using an approx 4 minute clip.  Trust me. I got "Failed (unable to convert video file)" several times and each time worked to focus on the problem.  Nothing was logical.  I would add a single photo to a project that had previously worked and it would bomb.  I would then delete that photo and it would still fail.